Beiträge von wn48z

    Danke für den Link zum Bug. Das war wohl Pech, dass sich zufällig kürzlich die Version auf 5.0.0 erhöht hatte - meine leicht ältere Tumbleweed-VM funktioniert noch problemlos.


    Ich habe nun versucht die entsprechenden Dateien aus der Factory zu aktualisieren:

    Code
    zypper ar https://download.opensuse.org/repositories/X11:/Cinnamon:/Next/openSUSE_Factory/X11:Cinnamon:Next.repo
    zypper in --allow-vendor-change cinnamon-control-center
    zypper in --allow-vendor-change cinnamon-gschemas
    zypper mr -d X11_Cinnamon_Next

    Die Dateien dort sind wieder leicht neuer ;)


    cinnamon-control-center hat nichts geändert, nach cinnamon-gschemas war die Bildschirmeinstellung wieder da. Nun läuft es wieder wie gewohnt.


    Seltsam ist lediglich, dass bei einer VM bei Skalierung 125%, 150% und 175% die Maus im Fenster gefangen ist, während sie bei 100% und 200% dieses problemlos verlassen kann - dies ist aber schon so, seit die Skalierungen zwischen 100% und 200% möglich sind. Vielleicht finde ich dazu auch noch irgendwann eine Lösung.

    Hallo zusammen


    Ich habe ein seltsames Problem auf einem neu aktualisierten Tumbleweed mit Cinnamon. Wenn ich auf Einstellungen -> Bildschirm klicke passiert nichts, die anderen Optionen unter Einstellungen sind aber verfügbar. Ich habe dann versucht die Option auf der Shell zu starten mit folgendem Resultat:


    Code
    myuser@vmsusetw:~> cinnamon-settings display
    Using pam module (python3-pampy)
    /usr/share/cinnamon/cinnamon-settings/cinnamon-settings.py:424: DeprecationWarning: Gtk.Window.set_wmclass is deprecated
    self.window.set_wmclass(wm_class, wm_class)
    Loading Display module
    (cinnamon-settings.py:2225): GLib-GIO-ERROR **: 23:44:57.757: Settings schema 'org.cinnamon.control-center.display' is not installed
    Trace/breakpoint trap (Speicherabzug geschrieben)

    Anschliessend habe ich zur Sicherheit das Paket cinnamon-control-center nochmals mit --force neu installiert, hat aber nichts verbessert. Hatte jemand schon ein ähnliches Problem? Wo bekommt man einfehlendes Schema her?


    Alternativ könnte ich die Skalierung von 200% vermutlich auch manuell in einer Konfigurationsdatei eintragen, aber wenn man danach sucht wird immer nur auf die GUI Variante verwiesen. Weiss jemand wie man die Skalierung in Cinnamon (oder Gnome) manuell einträgt und wo das gemacht wird? 100% ist auf einem 4k Monitor einfach viel zu klein ;)

    Könnte auch eine falsch konfigurierte/verwendete "Content-Security-Policy" sein.


    Da ist eine "nonce ID" in der script-src in der Policy definiert - wird diese "nonce ID" denn auch im <script> Aufruf verwendet?


    Lies mal diesen Artikel dazu:
    Content Security Policy - Wie schwer kann es sein?


    Ansonsten wenn es geht die CSP in der Apachekonfiguration mal weglassen und schauen ob es so mit dem Script funktioniert. Ich hatte in der Vergangenheit auch schon JavaScripts die wegen einer CSP nicht mehr funktionierten.

    SLES15 ist komplett modularisiert. D.h. alle Teile einer Installation befinden sich in verschiedenen Modulen. Je nachdem welche Module angebunden werden ist mehr oder weniger Software verfügbar, selbst das Basissystem ist ein Modul. Alle Module befinden sich auf der Installations DVD Nummer 2.


    Bei einer manuellen Installation von DVD Nummer 1 kann man die gewünschten Module dazuwählen. Tut man das nicht hat man nur die Module
    SLE15-Module-Basesystem
    SLE15-SP1-Prod


    am System dran und da ist kein Gnome mit dabei. Wie schon beschrieben - Gnome befindet sich in SLE-Module-Desktop-Applications.



    Siehe Punkt 1.1.6
    Schnelleinführung zur Installation | SUSE Linux Enterprise Server 15 SP1


    Hier "Desktop Applications Module" dazuwählen.

    schtimmt - hat mich endlose Zeit gekostet, das so hinzubiegen. Das sind die Reste der ursprünglichen Win-Partitionen, drei Teile, die ich gern zusammenhängend hätte...

    Mehrere physische XFS Partitionen kannst Du nicht zu einer Partition zusammenführen, das geht nur bei logischen LVM Partitionen.


    Die einzige Möglichkeit mit physischen Partitionen die ich gerade sehe wäre, /home mit btrfs zu formatieren (btrfs-convert geht nur bei ext2-ext4) und dann die beiden andere Devices hinzuzufügen mit:

    Code
    btrfs device add /dev/sda1 /home
    btrfs device add /dev/sda5 /home
    btrfs balance start /home


    Die Daten in /home natürlich zuerst sichern.


    Oder Du baust aus sda1, sda3 und sda5 ein LVM und kannst dann das zusammengeführte logische Laufwerk wieder mit XFS formatieren.

    Kannst Du mir sagen, wie ich es wieder deinstalliere?

    Wenn Du das Repo von Sauerland angebunden hast und Gimp aus diesem installiert (updated) hast - müsste das ältere 2.10.4 ersetzt worden und nicht mehr vorhanden sein.


    Du kannst dann das graphics Repo einfach wieder entfernen.


    Nach dem entfernen ein zypper refresh und danach kannst Du mit diesem Befehl schauen ob noch Repos aus dem graphic Repo vorhanden sind:


    Code
    zypper --no-refresh packages --orphaned