update von 13.1 nach 42.2 Probleme mit sieve

Hinweis: In dem Thema update von 13.1 nach 42.2 Probleme mit sieve gibt es 10 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Wie der Titel schon sagt, habe ich meinen meinen Server von 13.1 auf 42.2 angehoben.
    Das hat soweit alles bestens funktioniert, bis auf die Tatsache, dass meine Mails nicht mehr einsortiert werden.


    Mein Server sammelt klappert alle Mailkonten ab, und sortiert diese dann in die entsprechenden Konten ein.


    fetchmail 6.3.26
    postfix 2.11.8
    dovecot 2.2.25


    Die Mails werden noch immer alle artig abgeholt, werden aber alle in die Inbox geschoben.


    im log taucht folgendes auf:


    2017-02-20T14:48:44.004601+01:00 mailserver dovecot: managesieve(matze):Error: opendir(/home/matze/sieve/tmp) failed: Permission denied
    2017-02-20T14:48:44.009844+01:00 mailserver dovecot: managesieve(matze): Error: sieve: file storage:
    Failed to list scripts: opendir(/home/matze/sieve) failed: Permissiondenied
    2017-02-20T14:49:00.895544+01:00 mailserver dovecot:lda(matze): Error: sieve: binary open: failed to open:open(/home/matze/.dovecot.svbin) failed: Permission denied (euid=1001(matze) egid=100(users) UNIX perms appear ok (ACL/MAC wrong?))
    2017-02-20T14:49:00.896067+01:00 mailserver dovecot: lda(matze): Error: sieve: file script: Failed to open sieve script: open(/home/matze/.dovecot.sieve) failed: Permission denied (euid=1001(matze) egid=100(users) UNIX perms appear ok ACL/MAC wrong?))


    Versuche ich über den Thunderbird auf ein sieve script zuzugreifen wird nach dem Passwort gefragt:
    (Authentifizierung scheint zu funktionieren, mit falschen Passwort wird abgelehnt)


    bei richtigem Passwort kommt dann "Internal error........


    im log sieht das so aus:
    2017-02-20T06:47:15.302157+01:00 mailserver1 dovecot: managesieve(matze): Error: sieve: file storage: Failed to list scripts: opendir(/home/matze/sieve) failed: Permission denied
    2017-02-20T06:47:16.956079+01:00 mailserver1 dovecot: managesieve(matze): Error: sieve: file storage: Failed to list scripts: opendir(/home/matze/sieve) failed: Permission denied


    Das Problem scheint nicht auf der Dateisystemebene zu liegen. Ich habe mein homeverzeichnis /home/matze spasshalber auf 0777 gesetzt. Das hat erstmal NULL Auswirkungen. Der Fehler bleibt.


    /home/matze/sieve
    Besitzer: matze
    Gruppe: users



    dovecot -n


    # 2.2.25 (7be1766): /etc/dovecot/dovecot.conf
    # Pigeonhole version 0.4.15 (97b3da0)
    # OS: Linux 4.4.46-11-default x86_64 openSUSE 42.2 (x86_64)
    auth_mechanisms = plain login
    auth_verbose = yes
    disable_plaintext_auth = no
    mail_location = maildir:~/Maildir
    managesieve_notify_capability = mailto
    managesieve_sieve_capability = fileinto reject envelope encoded-character vacation subaddress comparator-i;ascii-numeric relational regex imap4flags copy include variables body enotify environment mailbox date index ihave duplicate mime foreverypart extracttext
    namespace inbox {
    inbox = yes
    location =
    mailbox Drafts {
    special_use = \Drafts
    }
    mailbox Junk {
    special_use = \Junk
    }
    mailbox Sent {
    special_use = \Sent
    }
    mailbox "Sent Messages" {
    special_use = \Sent
    }
    mailbox Trash {
    special_use = \Trash
    }
    prefix =
    }
    passdb {
    driver = pam
    }
    plugin {
    sieve = file:~/sieve;active=~/.dovecot.sieve
    }
    postmaster_address = admin@localhost
    protocols = imap lmtp pop3 sieve
    service auth {
    unix_listener auth-userdb {
    group = postfix
    mode = 0666
    user = postfix
    }
    }
    service managesieve-login {
    inet_listener sieve {
    port = 4190
    }
    }
    ssl = no
    userdb {
    driver = passwd
    }
    verbose_proctitle = yes
    protocol lmtp {
    mail_plugins = " sieve"
    }
    protocol lda {
    mail_plugins = " sieve"
    }
    protocol sieve {
    info_log_path = /var/log/sieve.log
    log_path = /var/log/sieve.log




    einzige Änderungen zu der vorherigen Istallation:


    plugin {
    sieve = ~/.dovecot.sieve
    sieve_dir = ~/sieve}


    neu:


    plugin {
    sieve = file:~/sieve;active=~/.dovecot.sieve
    }



    Ich hab zu dem Problem zwar im Netz einiges gefunden, werde aner nicht so recht schlau aus den Beiträgen.


    Falls jemand eine Idee hat, lasst bitte hören....



    Danke
    Gruß
    waffel

    Für den Inhalt des Beitrages 105379 haftet ausdrücklich der jeweilige Autor: waffel1971

  • Also, weil jede Klartextfehlermeldung schreit, dass die Rechte nicht passen, ist es kein Problem der Rechte auf Dateisystemebene?


    Postfix reagiert ziemlich empfindlich auf mal eben mit dem Zufallsgenerator gestreute Dateirechte.
    Da wirst du schon ein wenig präziser vollständige Konfig- Fakten vorlegen müssen.


    Prinzipiell hat KEINES der beteiligten Directories auch nur das allergeringste in irgendeinem Home verloren.
    Und ziemlich eigenwillig -falls ich das überhaupt halbwegs richtig verstehe- ist auch die fragwürdige Methode deiner Siebungen: Warum soll dovecot irgendwelche Usermua- Scripte lesen/abarbeiten?


    Abgesehen davon, dass es ziemlich schräg ist, einen Imap/POP-Server für lokale Konten zu betreiben.
    Was versprichst du dir von diesem Szenario?
    Hast du einen interne Domain am Laufen?
    Wie ist dann der Verkehr von und nach extern geregelt? Sind das interne Dummydomains, die auf irgendeine echte Domain abgebildet werden? (Wenn so, dann bitte alle Regeln der Umschreibungen mitposten)


    Und poste die master.cf und main.cf gleich mit. Beschreibe außerdem exakt die komplette Domainlandschaft.
    Nimmst du smtp oder lmtp?
    Irgendwelche Jails/Chroots im Spiel?


    Ich glaube ja fast, dass du das alles gar nicht willst und gar nicht brauchst.
    Kann es sein, dass du lediglich ein paar Mailaccounts lesen willst und ein paar Mails damit senden willst?

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 105384 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo,



    erstmal Danke, dass sich jemand meinem Problem annimmt.
    Ich bin jetzt nicht der IT-Profi. Der Server lief viele Jahre einwandfrei. Soweit ich mich erinnern kann, war auch die 13.1 bereits ein Update von 12. irgendwas.


    Prinzipiell hat KEINES der beteiligten Directories auch nur das allergeringste in irgendeinem Home verloren.
    Das ganze läuft in einer VM unter virtualbox, und ist von der übrigen Landschaft soweit getrennt. So gibt es z.B. keinerlei weitere Zugriffe auf die Homeverzeichnisse dieses Servers.


    Nach dem Warum und wieso........
    Mehrfamilienhaus, zwei (kleine) Firmen.......... 15 Mailaccounts für mehrere Benutzer.........


    Einmal eingerichtet braucht es im Thunderbird immer wieder nur lokale Angaben, und innerhalb von ein paar Minuten ist jeder Rechner mit allen Mails der letzten Jahre versorgt.


    Die Lösung kam mir recht plausibel und sinnvoll vor. Im weiteren habe ich Tine20 mit dran. Adress und Terminverwaltung.....

    Und ziemlich eigenwillig -falls ich das überhaupt halbwegs richtig verstehe- ist auch die fragwürdige Methode deiner Siebungen: Warum soll dovecot irgendwelche Usermua- Scripte lesen/abarbeiten?


    Also so wie ich das verstehe, habe ich dovecot angewiesen, sieve einzubinden. Ich kann dann Userspezifisch ein script erstellen, welches mir de Mails prima einsortiert.


    Mal als kleines Beispiel:
    matze ruft seine Mails von 5 Accounts ab...


    freenet mail kommen in den freenet Ordner
    mails von ebay kommen in den ebay Ordner


    oder eben auch die Weitersortierung:
    mails von ebay kommen in den ebay Ordner
    mails von XXX kommen in den XXX Ordner


    etc etc.....




    Wie ist dann der Verkehr von und nach extern geregelt? Sind das interne Dummydomains, die auf irgendeine echte Domain abgebildet werden? (Wenn so, dann bitte alle Regeln der Umschreibungen mitposten)


    Meine interne Domain ist nt.home , Wenn ich mir intern eine Mail sende sieht das so aus: matze@mailserver.nt.home
    Die Namen werden beim externen Verkehr dann natürlich auf die echten Mailaccounts abgebildet.



    Nimmst du smtp oder lmtp?
    Ich glaube smtp..................sorry, ich hoffe dass sieht man in den unten stehenden configs.

    Irgendwelche Jails/Chroots im Spiel?

    Soweit ich weiss nicht.




    Kann es sein, dass du lediglich ein paar Mailaccounts lesen willst und ein paar Mails damit senden willst?


    Vom Prinzip schon, wenn du eine elegantere Methode kennst, ich bin gerne bereit dazuzulernen.



    Im großen und ganzen funktioniert ja alles. Nur halt sieve mault jetzt rum. Muss ich irgendwas geändert haben.




    Regeln der Umschreibungen

    Ich hoffe du meinst das hier:


    /etc/postfix/sender_canoncial


    matze meinaccount@freenet.de



    /etc/postfix/sender_depent


    meinaccount@freenet.de mx.freenet.de



    Natürlich ist die Liste entsprechend länger mit allen anderen Einträgen........

    Für den Inhalt des Beitrages 105390 haftet ausdrücklich der jeweilige Autor: waffel1971

  • Benutze für Konsolenausgaben bitte Code-Tags

    Für den Inhalt des Beitrages 105392 haftet ausdrücklich der jeweilige Autor: waffel1971

  • Benutze für Konsolenausgaben bitte Code-Tags

    Für den Inhalt des Beitrages 105393 haftet ausdrücklich der jeweilige Autor: waffel1971

  • Benutze bitte für Konsolenausgaben Code-Tags, für Zitate Quote usw.


    Und wenn eine Konsolenausgabe so lang ist wie die obige, bitte in eine Textdatei (!) kopieren und diese hier anhängen.

  • Da ist keine Logik in der Konfiguration.
    Was da wirklich läuft, wissen wohl nicht einmal die Götter.
    Das ergibt nur noch mehr Fragen.


    Ich würde vorschlagen, dass du dir Mumble installierst,
    und wir das dann dort besprechen.
    Hier ein Fachbuch über Mailserver zu schreiben,
    ist nicht so wirklich sinnvoll.


    Wenn du ein Mikrophon hast, egal ob Headset, Webcam oder ein richtiges, installiere dir mit zypper in mumble den Sprachkonferenzclient. (Das is sowas, wie Teamspeak, aber open source, dafür schneller, bei geringerem Speicherverbrauch mit besserer Sprachqualität ohne, dass Teamspeak mithört.)
    Die Verbindungsdaten sind dann schlicht:

    • Bezeichnung : frei wählbarer Name
    • Adresse : computer.interhacktive.de
    • Port : 64738 (bleibt einfach auf Standard)
    • Benutzername : frei wählbarer Nickname

    Sage einfach Ja-.und-Amen, da er beim ersten Verbindungsversuch ein Zertifikat erstellt. (Es wird prinzipiell nur verschlüsselt übertragen; der Zert-Assistent erledigt das ganz einfach)
    (Und ja: Der Rechner ist nicht nur ein Computer, er heißt auch so.)

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 105430 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Erstmal Danke für das Angebot mir helfen zu wollen.


    Ich habe weder Headset noch Microphon oder Webcam. Hab immer gedacht ich komme um solch Teufelszeug herum. ^^


    Ich sieh zu, dass ich mir irgendwas von dem Kram besorge und melde mich dann entsprechend zurück.



    (Und ja: Der Rechner ist nicht nur ein Computer, er heißt auch so.)

    Hab ich irgend etwas verpasst? Ich kann mit Sarkasmus durchaus umgehen, allerdings nur dann wenn ich es verstehe.............. ;)

    Für den Inhalt des Beitrages 105434 haftet ausdrücklich der jeweilige Autor: waffel1971

  • Hab ich irgend etwas verpasst? Ich kann mit Sarkasmus durchaus umgehen, allerdings nur dann wenn ich es verstehe..............

    Adresse : computer.interhacktive.de

    (Und ja: Der Rechner ist nicht nur ein Computer, er heißt auch so.)

  • Hallo,


    hat eine Weile gedauert, aber gut Ding braucht eben seine Zeit.


    Ich habe AppAmor deaktiviert und auf diese Weise erstmal das Problem "gelöst".


    Insofern scheint meine Theorie...


    Zitat von waffel1971

    "Das Problem scheint nicht auf der Dateisystemebene zu liegen"


    ... zu stimmen.



    Wenn jemand weiß, wie man AppAmor so konfiguriert, so dass auch bei eingeschaltetem AppAmor alles funktioniert, dann höre ich gern zu.

    Für den Inhalt des Beitrages 109239 haftet ausdrücklich der jeweilige Autor: waffel1971