Bootvorgang hängt, vermutlich wegen der Maus

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Bootvorgang hängt, vermutlich wegen der Maus gibt es 14 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Bootvorgang hängt, vermutlich wegen der Maus

    Hallo zusammen,

    ich habe vor einem Monat auf Linux umgestellt, zuerst Leap 42.3 installiert und dann den Update nach 15.0 gemacht. Der Bootvorgang bleibt immer wieder mal hängen, ich finde keine Regel. Manchmal kann man ihn zum Weitermachen ermuntern, wenn ich die Konsolen umschalte mit Alt+F1 und dann wieder Alt+F7.

    Als Indiz finde ich folgende Zeilen in der dmesg:


    Quellcode

    1. [ 7.994200] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    2. [ 7.994211] r8169 0000:04:00.0 eth0: link down
    3. [ 10.425198] r8169 0000:04:00.0 eth0: link up
    4. [ 10.425205] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    5. [ 10.831524] NET: Registered protocol family 17
    6. [ 34.587975] logitech-hidpp-device 0003:046D:101B.0004: HID++ 1.0 device connected.
    Hier habe ich nach einiger Wartezeit den oben beschriebenen Umschaltvorgang durchgeführt. Dass dann meine Maus erkannt wird bringt mich zu dem Verdacht, dass diese irgendwie daran Schuld sein könnte. Es ist eine Logitech M705 Funkmaus, die mit dem mitgelieferten USB-Funkteil angeschlossen ist.

    Hat mir jemand einen Tipp, wie ich das Booten ohne Hänger und ohne Alt-F1/Alt-F7 hinbekomme? Der Rechner soll auch von weniger Computer-affinen Familienmitgliedern benutzt werden :smilie_school_012:

    Für den Inhalt des Beitrages 121363 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • und noch eine Info: Hab die dmesg weiter durchgeflöht. Der Dongle wurde schon viel früher erkannt:

    Quellcode

    1. [ 3.464006] usb 5-2: new full-speed USB device number 3 using xhci_hcd
    2. [ 3.608003] usb 4-1.3: new high-speed USB device number 3 using ehci-pci
    3. [ 3.652552] usb 5-2: New USB device found, idVendor=046d, idProduct=c52b
    4. [ 3.652554] usb 5-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    5. [ 3.652555] usb 5-2: Product: USB Receiver
    6. [ 3.652556] usb 5-2: Manufacturer: Logitech
    7. [ 3.712592] usbcore: registered new interface driver usbhid
    8. [ 3.712593] usbhid: USB HID core driver
    9. [ 3.714507] logitech-djreceiver 0003:046D:C52B.0003: hiddev96,hidraw0: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:05:00.0-2/input2

    Nur zu erkennen, dass dahinter eine Maus hängt, das scheint ab und zu zu dauern. Aber jetzt mach ich erst mal, was du vorgeschlagen hast...

    Für den Inhalt des Beitrages 121367 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • Hmm, also eine andere Maus hat nichts gebracht. Beim zweiten Mal der gleiche Hänger, den ich nur mit Alt-F1/Alt-F7 wieder weggebracht habe. Allerdings steht davon dann nichts in der dmesg, die ich diesmal vom Erkennen der Maus bis zum Schluss anhänge:

    Quellcode

    1. [ 3.484075] usb 5-2: new low-speed USB device number 3 using xhci_hcd
    2. [ 3.628077] usb 4-1.3: new high-speed USB device number 3 using ehci-pci
    3. [ 3.656669] usb 5-2: New USB device found, idVendor=192f, idProduct=0916
    4. [ 3.656670] usb 5-2: New USB device strings: Mfr=0, Product=2, SerialNumber=0
    5. [ 3.656671] usb 5-2: Product: USB Optical Mouse
    6. [ 3.670713] usbcore: registered new interface driver usbhid
    7. [ 3.670714] usbhid: USB HID core driver
    8. [ 3.671283] input: USB Optical Mouse as /devices/pci0000:00/0000:00:1c.7/0000:05:00.0/usb5/5-2/5-2:1.0/0003:192F:0916.0001/input/input3
    9. [ 3.671463] hid-generic 0003:192F:0916.0001: input,hidraw0: USB HID v1.11 Mouse [USB Optical Mouse] on usb-0000:05:00.0-2/input0
    10. [ 3.740086] usb 4-1.3: New USB device found, idVendor=05e3, idProduct=0716
    11. [ 3.740087] usb 4-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=2
    12. [ 3.740088] usb 4-1.3: Product: USB Storage
    13. [ 3.740089] usb 4-1.3: SerialNumber: 000000009744
    14. [ 3.742305] usb-storage 4-1.3:1.0: USB Mass Storage device detected
    15. [ 3.743147] scsi host8: usb-storage 4-1.3:1.0
    16. [ 3.743196] usbcore: registered new interface driver usb-storage
    17. [ 3.743624] usbcore: registered new interface driver uas
    18. [ 3.767321] random: crng init done
    19. [ 3.852129] ata2: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
    20. [ 3.853611] ata2.00: ATA-8: Hitachi HDS5C3020ALA632, ML6OA580, max UDMA/133
    21. [ 3.853614] ata2.00: 3907029168 sectors, multi 0: LBA48 NCQ (depth 31/32), AA
    22. [ 3.855227] ata2.00: configured for UDMA/133
    23. [ 3.855455] scsi 1:0:0:0: Direct-Access ATA Hitachi HDS5C302 A580 PQ: 0 ANSI: 5
    24. ... einige Zeilen entfernt, da Nachricht sonst zu lang ...
    25. [ 6.515644] intel_rapl: Found RAPL domain package
    26. [ 6.515645] intel_rapl: Found RAPL domain core
    27. [ 6.515646] intel_rapl: Found RAPL domain uncore
    28. [ 6.524097] input: HDA Intel PCH Front Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input5
    29. [ 6.524146] input: HDA Intel PCH Rear Mic as /devices/pci0000:00/0000:00:1b.0/sound/card0/input6
    30. [ 6.524183] input: HDA Intel PCH Line as /devices/pci0000:00/0000:00:1b.0/sound/card0/input7
    31. [ 6.524216] input: HDA Intel PCH Line Out Front as /devices/pci0000:00/0000:00:1b.0/sound/card0/input8
    32. [ 6.524249] input: HDA Intel PCH Line Out Surround as /devices/pci0000:00/0000:00:1b.0/sound/card0/input9
    33. [ 6.524282] input: HDA Intel PCH Line Out CLFE as /devices/pci0000:00/0000:00:1b.0/sound/card0/input10
    34. [ 6.524314] input: HDA Intel PCH Line Out Side as /devices/pci0000:00/0000:00:1b.0/sound/card0/input11
    35. [ 6.524346] input: HDA Intel PCH Front Headphone as /devices/pci0000:00/0000:00:1b.0/sound/card0/input12
    36. [ 6.524380] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input13
    37. [ 6.524416] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1b.0/sound/card0/input14
    38. [ 6.871032] fuse init (API version 7.26)
    39. [ 6.897859] SGI XFS with ACLs, security attributes, no debug enabled
    40. [ 6.898643] XFS (sde3): Mounting V5 Filesystem
    41. [ 6.915612] XFS (sde3): Ending clean mount
    42. [ 6.923336] systemd-journald[494]: Received request to flush runtime journal from PID 1
    43. [ 7.627265] ip6_tables: (C) 2000-2006 Netfilter Core Team
    44. [ 7.645835] nf_conntrack version 0.5.0 (65536 buckets, 262144 max)
    45. [ 7.655153] ip_tables: (C) 2000-2006 Netfilter Core Team
    46. [ 7.863952] No iBFT detected.
    47. [ 8.002206] r8169 0000:04:00.0 eth0: link down
    48. [ 8.002273] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
    49. [ 8.002290] r8169 0000:04:00.0 eth0: link down
    50. [ 10.280167] r8169 0000:04:00.0 eth0: link up
    51. [ 10.280176] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    52. [ 10.686563] NET: Registered protocol family 17
    53. [ 654.397473] BTRFS info (device sde2): qgroup scan completed (inconsistency flag cleared)
    Alles anzeigen

    Von dem Hänger dazwischen keine Spur. Welche Log-Dateien könnten noch Aufschluss geben? Vielleicht ist die Maus gar nicht die Ursache, sondern lediglich ein Indiz? Geben die letzten Zeilen der /var/log/boot.log einen Hinweis:

    Quellcode

    1. [* ] (1 of 2) A start job is running for wicked managed network interfaces (7s / no limit)^M[** ] (1 of 2) A start job is running for wicked managed network interfaces (7s / no limit)^M[*** ] (1 of 2) A start job is running for wicked managed network interfaces (8s / no limit)^M[ *** ] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (8s / no limit)^M[ *** ] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (9s / no limit)^M[ ***] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (10s / no limit)^M[ **] (1 of 2) A start job is running for wicked managed network interfaces (10s / no limit)^M[ *] (1 of 2) A start job is running for wicked managed network interfaces (11s / no limit)^M[ **] (1 of 2) A start job is running for wicked managed network interfaces (11s / no limit)^M[ ***] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (12s / no limit)^M[ *** ] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (13s / no limit)^M[ *** ] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (13s / no limit)^M[*** ] (1 of 2) A start job is running for wicked managed network interfaces (14s / no limit)^M[** ] (1 of 2) A start job is running for wicked managed network interfaces (14s / no limit)^M[* ] (1 of 2) A start job is running for wicked managed network interfaces (15s / no limit)^M[** ] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (15s / no limit)^M[*** ] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (16s / no limit)^M[ *** ] (2 of 2) A start job is running for Update cron periods from /etc/sysconfig/btrfsmaintenance (17s / no limit)^M[ *** ] (1 of 2) A start job is running for wicked managed network interfaces (17s / no limit)^M[ ***] (1 of 2) A start job is running for wicked managed network interfaces (18s / no limit)^M[ **] (1 of 2) A start job is running for wicked managed network interfaces (18s / no limit)^M[ OK ] Started wicked managed network interfaces.
    2. [ OK ] Reached target Network.
    3. Starting SuSEfirewall2 phase 2...
    4. Starting NTP Server Daemon...
    5. Starting Login and scanning of iSCSI devices...
    6. [ OK ] Started Login and scanning of iSCSI devices.
    7. [ OK ] Reached target Remote File Systems.
    8. Starting Permit User Sessions...
    9. [ OK ] Started Permit User Sessions.
    10. Starting Hold until boot process finishes up...
    11. [ OK ] Started NTP Server Daemon.
    12. [ OK ] Reached target System Time Synchronized.
    13. [ OK ] Started Daily rotation of log files.
    14. [ OK ] Started Discard unused blocks once a week.
    15. [ OK ] Started Backup of RPM database.
    16. [ OK ] Started Discard unused blocks on a mounted filesystem.
    17. [ OK ] Started Balance block groups on a btrfs filesystem.
    18. [ OK ] Started Timeline of Snapper Snapshots.
    19. [ OK ] Started Backup of /etc/sysconfig.
    20. [ OK ] Started Scrub btrfs filesystem, verify block checksums.
    21. [ OK ] Started Check if mainboard battery is Ok.
    22. [ OK ] Reached target Timers.
    23. Starting X Display Manager...
    24. Starting Postfix Mail Transport Agent...
    25. Starting Locale Service...
    26. /
    Alles anzeigen
    Allerdings sieht ziemlich jeder Bootvorgang genau gleich aus, auch der vorhergehende, der gut gelaufen ist.

    Trotzdem gehe ich jetzt mal auf einen anderen USB Port.

    Für den Inhalt des Beitrages 121371 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • Hmm, jetzt gehe ich vielleicht doch auf deinen IPv6-Tipp. in journalctl habe ich gefunden:

    Quellcode

    1. Jun 09 21:02:02 linux-8y2d kernel: r8169 0000:04:00.0 eth0: link up
    2. Jun 09 21:02:02 linux-8y2d kernel: IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
    3. Jun 09 21:02:02 linux-8y2d wickedd-dhcp4[1191]: eth0: Request to acquire DHCPv4 lease with UUID 27241c5b-cddb-0d00-a904-000005000000
    4. Jun 09 21:02:02 linux-8y2d wickedd-dhcp6[1190]: eth0: Request to acquire DHCPv6 lease with UUID 27241c5b-cddb-0d00-a904-000006000000 in mode auto
    5. Jun 09 21:02:02 linux-8y2d ModemManager[1027]: <info> Couldn't check support for device at '/sys/devices/pci0000:00/0000:00:1c.6/0000:04:00.0': not supported by any plugin
    6. Jun 09 21:02:02 linux-8y2d kernel: NET: Registered protocol family 17
    7. Jun 09 21:02:03 linux-8y2d wickedd-dhcp4[1191]: eth0: Committed DHCPv4 lease with address 192.168.178.49 (lease time 864000 sec, renew in 432000 sec, rebind in 756000 sec)
    8. Jun 09 21:02:03 linux-8y2d avahi-daemon[1026]: Joining mDNS multicast group on interface eth0.IPv4 with address 192.168.178.49.
    9. Jun 09 21:02:03 linux-8y2d avahi-daemon[1026]: New relevant interface eth0.IPv4 for mDNS.
    10. Jun 09 21:02:03 linux-8y2d avahi-daemon[1026]: Registering new address record for 192.168.178.49 on eth0.IPv4.
    11. Jun 09 21:02:03 linux-8y2d avahi-daemon[1026]: Joining mDNS multicast group on interface eth0.IPv6 with address fe80::52e5:49ff:febc:b17c.
    12. Jun 09 21:02:03 linux-8y2d avahi-daemon[1026]: New relevant interface eth0.IPv6 for mDNS.
    13. Jun 09 21:02:03 linux-8y2d avahi-daemon[1026]: Registering new address record for fe80::52e5:49ff:febc:b17c on eth0.*.
    14. Jun 09 21:02:03 linux-8y2d dns-resolver[1572]: ATTENTION: You have modified /etc/resolv.conf. Leaving it untouched...
    15. Jun 09 21:02:03 linux-8y2d dns-resolver[1574]: You can find my version in /etc/resolv.conf.netconfig
    16. Jun 09 21:02:17 linux-8y2d wicked[1207]: lo up
    17. Jun 09 21:02:17 linux-8y2d wicked[1207]: eth0 up
    18. Jun 09 21:02:17 linux-8y2d systemd[1]: Started wicked managed network interfaces.
    19. Jun 09 21:02:17 linux-8y2d systemd[1]: Reached target Network.
    20. Jun 09 21:02:17 linux-8y2d systemd[1]: Starting SuSEfirewall2 phase 2...
    21. Jun 09 21:02:17 linux-8y2d systemd[1]: Starting NTP Server Daemon...
    22. Jun 09 21:02:17 linux-8y2d systemd[1]: Starting Login and scanning of iSCSI devices...
    23. J
    Alles anzeigen
    Da ist der Hänger also irgendwie im Bereich der Netzwerkkonfiguration.

    Ich habe jetzt in YaST, Netzwerkeinstellungen, Globale Optionen die Checkbox "IPv6 aktivieren" ausgeschaltet. Ich berichte!

    Für den Inhalt des Beitrages 121372 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • Erst dachte ich, es ist weg. Aber heute früh wieder der Hänger. Diesmal mit folgendem Auszug aus dem Journal:

    Quellcode

    1. Jun 10 07:12:20 linux-8y2d systemd[1]: postfix.service: Control process exited, code=exited status=1
    2. Jun 10 07:12:20 linux-8y2d cond_slp[2059]: /usr/sbin/postconf: fatal: parameter inet_interfaces: no local interface found for ::1
    3. Jun 10 07:12:21 linux-8y2d systemd[1]: Failed to start Postfix Mail Transport Agent.
    4. Jun 10 07:12:21 linux-8y2d systemd[1]: postfix.service: Unit entered failed state.
    5. Jun 10 07:12:21 linux-8y2d systemd[1]: postfix.service: Failed with result 'exit-code'.
    6. Jun 10 07:12:21 linux-8y2d systemd[1]: Started Command Scheduler.
    7. Jun 10 07:12:21 linux-8y2d cron[2063]: (CRON) INFO (RANDOM_DELAY will be scaled with factor 65% if used.)
    8. Jun 10 07:12:21 linux-8y2d cron[2063]: (CRON) INFO (running with inotify support)
    9. Jun 10 07:12:31 linux-8y2d systemd[1]: Started Backup RPM database.
    10. Jun 10 07:13:04 linux-8y2d systemd[1]: Started Hold until boot process finishes up.
    11. Jun 10 07:13:04 linux-8y2d systemd[1]: Started Getty on tty1.
    12. Jun 10 07:13:04 linux-8y2d systemd[1]: Started Getty on tty2.
    13. Jun 10 07:13:04 linux-8y2d systemd[1]: Reached target Login Prompts.
    14. Jun 10 07:13:04 linux-8y2d systemd[1]: Reached target Multi-User System.
    15. Jun 10 07:13:04 linux-8y2d sddm[2079]: Initializing...
    16. Jun 10 07:13:04 linux-8y2d sddm[2079]: Logind interface found
    17. Jun 10 07:13:04 linux-8y2d sddm[2079]: Starting...
    18. Jun 10 07:13:04 linux-8y2d sddm[2079]: Adding new display on vt 7 ...
    19. Jun 10 07:13:04 linux-8y2d sddm[2079]: Loading theme configuration from ""
    20. Jun 10 07:13:04 linux-8y2d sddm[2079]: Display server starting...
    21. Jun 10 07:13:04 linux-8y2d sddm[2079]: Running: /usr/bin/X -nolisten tcp -auth /run/sddm/{8141fab8-f792-4ed9-a1d7-b09fc7366b66} -background none -noreset -displayfd 18 -seat seat0 vt7
    22. Jun 10 07:13:05 linux-8y2d display-manager[1646]: Starting service sddm..done
    23. Jun 10 07:13:05 linux-8y2d systemd[1]: Started X Display Manager.
    24. Jun 10 07:13:05 linux-8y2d systemd[1]: Reached target Graphical Interface.
    Alles anzeigen

    Was bedeutet dieses Jun 10 07:13:04 linux-8y2d systemd[1]: Started Hold until boot process finishes up.? Wer wartet da auf wen? Auch hier hab ich den rechner mit Alt-F1/Alt-F7 zum Weitermachen bewegen können.

    Für den Inhalt des Beitrages 121386 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • Meine weiteren Analysen: Ich habe den "Hold until boot process finishes up" Eintrag mal detailliert angeschaut:

    Quellcode

    1. Sun 2018-06-10 09:55:25.940244 CEST [s=18e711a7c8a647948799cc0808b92cbd;i=31a4f;b=aade5a1946584b318ecddcc74f87a384;m=2219e95;t=56e44f4b5ce32;x=c93a10f861666df4]
    2. PRIORITY=6
    3. SYSLOG_FACILITY=3
    4. _MACHINE_ID=0f15d44a0f14c9bd5662eabc5ae9e467
    5. _HOSTNAME=linux-8y2d
    6. SYSLOG_IDENTIFIER=systemd
    7. _TRANSPORT=journal
    8. _PID=1
    9. _UID=0
    10. _GID=0
    11. _COMM=systemd
    12. _EXE=/usr/lib/systemd/systemd
    13. _CAP_EFFECTIVE=3fffffffff
    14. _SYSTEMD_CGROUP=/init.scope
    15. _SYSTEMD_UNIT=init.scope
    16. _SYSTEMD_SLICE=-.slice
    17. CODE_FILE=src/core/job.c
    18. CODE_LINE=820
    19. CODE_FUNC=job_log_status_message
    20. RESULT=done
    21. MESSAGE_ID=39f53479d3a045ac8e11786248231fbf
    22. UNIT=plymouth-quit-wait.service
    23. MESSAGE=Started Hold until boot process finishes up.
    24. _BOOT_ID=aade5a1946584b318ecddcc74f87a384
    25. _CMDLINE=/usr/lib/systemd/systemd --switched-root --system --deserialize 24
    26. _SOURCE_REALTIME_TIMESTAMP=1528617325940244
    Alles anzeigen
    Da wartet also wohl jemand auf den plymouth. Auch diese Ausgabe deutet darauf hin:

    Quellcode

    1. sudo systemd-analyze blame
    2. 24.312s display-manager.service
    3. 23.836s plymouth-quit-wait.service
    4. 4.834s btrfsmaintenance-refresh.service
    5. 3.919s wicked.service
    6. 2.258s postfix.service

    Hier hiroom2.com/2016/12/21/fedora-…ue-of-plymouth-quit-wait/ hab ich die Empfehlung gefunden, Plymouth zu deinstallieren. Das möchte ich aber nicht ohne euren Rat machen!

    PS: kann jemand eigentlich den Titel der Diskussion ändern? Die Maus ist es ziemlich sicher nicht!

    Für den Inhalt des Beitrages 121390 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • Yep, gemacht per YaST. Jetzt hüpft nichts mehr rum beim Start, sondern ich habe halt die Textmeldungen (wovon eine immer noch sagt, systemd wolle plymouth starten...). Aber:

    Kein Hänger!!

    @Sauerland: Danke für den Support. Kann ich dir hier irgendwo Sternchen geben? Auf alle Fälle ist der Thread "gelöst". Wer kann die Markierung setzen? IPv6 hab ich übrigens wieder eingeschaltet, das macht keinen Unterschied.

    Für den Inhalt des Beitrages 121394 haftet ausdrücklich der jeweilige Autor: letsfindaway