DomU startet nicht, Out of Memory Error

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema DomU startet nicht, Out of Memory Error gibt es 1 Antwort.
  • DomU startet nicht, Out of Memory Error

    Guten Morgen,
    nach zwei Tagen vergebliches Suchen wende ich mich nun an die Community.
    Folgende Situation:
    I386-64 Maschine mit 64 GB Ram, Tumbleweed 4.18 Kernel mit allen Patchen
    Gestartet als XEN-Kernel, parameter DOM0_MEM=2G übergeben.
    Ist nun in /etc/libvirt/libxl.conf und/oder in /etc/xen/xl.conf der Wert autoballoon=0, so startet überhaupt keine DomU.
    Setze ich den autoballoon=1, so starten zwei DomUs, ab der dritten gehts nicht mehr.
    Es sieht auch so aus, als ob der DOMU_MEM Parameter ignoriert werden würde, da:
    xl info
    host : xen-srv2
    release : 4.18.0-1-default
    version : #1 SMP PREEMPT Wed Aug 15 07:02:07 UTC 2018 (280ac93)
    machine : x86_64
    nr_cpus : 12
    max_cpu_id : 11
    nr_nodes : 1
    cores_per_socket : 6
    threads_per_core : 2
    cpu_mhz : 3192.225
    hw_caps : bfebfbff:77faf3ff:2c100800:00000121:0000000f:009c6fbf:00000000:00000100
    virt_caps : hvm hvm_directio
    total_memory : 65371
    free_memory : 6
    sharing_freed_memory : 0
    sharing_used_memory : 0
    outstanding_claims : 0
    free_cpus : 0
    xen_major : 4
    xen_minor : 11
    xen_extra : .0_02-1
    xen_version : 4.11.0_02-1
    xen_caps : xen-3.0-x86_64 xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p hvm-3.0-x86_64
    xen_scheduler : credit
    xen_pagesize : 4096
    platform_params : virt_start=0xffff800000000000
    xen_changeset :
    xen_commandline : vga=gfx-1024x768x16,dom0_mem=2G
    cc_compiler : gcc (SUSE Linux) 8.1.1 20180719 [gcc-8-branch revision 262874]
    cc_compile_by : abuild
    cc_compile_domain : suse.de
    cc_compile_date : Tue Jul 24 15:17:09 UTC 2018
    build_id : 5e61f72ecc662cf688f8879808de2c94
    xend_config_format : 4

    Die Einstellung in /etc/default/grub:
    GRUB_CMDLINE_XEN_DEFAULT="vga=gfx-1024x768x16,dom0_mem=2G"
    GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/disk/by-id/nvme-SAMSUNG_MZVLB256HAHQ-000L7_S41GNE0K707495-part2 splash=silent quiet showopts dom0_mem=2G,max:2G"

    Ein Versuch eine weitere Domäne zu startet schlägt fehl mit:
    (/avr/lib/libvirt/libxl/libxl-driver.log)
    2018-08-27 08:07:01.617+0000: xc: panic: xc_dom_core.c:542: xc_dom_chk_alloc_pages: segment kernel too large (0x621 > 0x400 - 0x0 pages): Out of memory
    2018-08-27 08:07:01.617+0000: libxl: libxl_dom.c:742:libxl__build_dom: xc_dom_build_image failed: Datei oder Verzeichnis nicht gefunden
    2018-08-27 08:07:01.617+0000: libxl: libxl_create.c:1266:domcreate_rebuild_done: Domain 6:cannot (re-)build domain: -3
    Weitere Fehlermeldungen gibt es nicht.
    xentop zeigt mir, dass die beiden laufenden DomUs einen Gesamtverbrauch von 6GB haben, die neue Dom-U ist wie folgt konfiguriert:
    <domain type='xen'>
    <name>Netflow</name>
    <description>Netflow-Server</description>
    <uuid>9506bde6-0608-401a-edfc-98a41ac9b379</uuid>
    <memory unit='KiB'>4096</memory>
    <currentMemory unit='KiB'>4096</currentMemory>
    <vcpu>3</vcpu>
    <on_poweroff>destroy</on_poweroff>
    <on_reboot>restart</on_reboot>
    <on_crash>destroy</on_crash>
    <clock sync='utc'/>
    <os type='opensuse42'>
    <type>linux</type>
    <kernel>/usr/lib/grub2/x86_64-xen/grub.xen</kernel>
    <cmdline> </cmdline>
    </os>
    <devices>
    <disk type='file' device='disk'>
    <driver name='qemu' type='raw' cache='default'/>
    <source file='/home1/XEN/NETFLOW/netflow.img'/>
    <target dev='xvda'/>
    </disk>
    <disk type='file' device='disk'>
    <driver name='qemu' type='raw' cache='default'/>
    <source file='/home1/XEN/NETFLOW/netflow-store.img'/>
    <target dev='xvdb'/>
    </disk>
    <interface type='bridge'>
    <source bridge='br90'/>
    <mac address='00:16:3e:35:da:af'/>
    <script path='/etc/xen/scripts/vif-bridge'/>
    </interface>

    <graphics type='vnc' keymap='de'/>
    </devices>
    </domain>
    Also auch nicht mit mehr Speicher, als die gesamte Maschine hat.
    Was mache ich falsch bzw. welche Parameter muss ich verändern.
    Weitere Hinweise:
    ein 42.3 er Kernel (4.4...) ohne weitere Einstellungen kann ALLE meine DomU's ohne weiteres starten. Erst bei der Umstellung auf 4.18 schlägt es fehl. Den Standard Kernel von Suse 15 kann ich nicht verwenden, der ist nicht stabil auf einem Lenovo M920T mit I7-8700er CPU.
    Auch ohne DomU-Parameter gibt es keine Änderung...

    Für den Inhalt des Beitrages 124253 haftet ausdrücklich der jeweilige Autor: mgaertne

  • Ich habe von XEN keine Ahnung, aber:

    1. benutze für Konsolenausgaben bitte Code-Tags, macht das Lesen einfach einfacher.
    2. Ich habe kein Tumbleweed installiert, lasse sich andere die Köpfe zum rauchen bringen.
    Ich benutze Leap15.0 allerdings mit dem Kernel aus kernel:stable. Wäre für dich evtl. auch ne Möglichkeit.
    3. Oder einfach einen anderen Kernel installieren, z:b: kernel:head oder oder......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 124264 haftet ausdrücklich der jeweilige Autor: Sauerland