"Invalid argument" Fehler beim Scannen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema "Invalid argument" Fehler beim Scannen gibt es 14 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • "Invalid argument" Fehler beim Scannen

    Liebe Leute,
    seit meinem Upgrade von Leap 42.3 auf Leap 15 tritt folgendes Problem auf: alle Scanprogramme (xsane, SimpleScan, Skanlite) können keine Verbindung zum Scanner aufbauen. Ich kann also nicht scannen.

    Die Konfiguration:
    Desktop-PC mit opensuse 15 und HP Photosmart Premium C301, beide per Ethernet-Kabel mit dem Router (Fritzbox 7580) verbunden.
    HPLIP ist installiert und drucken funktioniert auch einwandfrei.
    Der Scannertest unter Yast ist auch erfolgreich.

    Output von scanimage -L: device `hpaio:/net/Photosmart_C309a_series?ip=192.168.xx.xx&port=3' is a Hewlett-Packard Photosmart_C309a_series all-in-one
    Ist also auch ok.

    Aber der Aufruf von xsane bringt immer die Fehlermeldung: Fehler beim Öffnen des Geräts 'hpaio:/net/Photosmart_C309a_series?ip=192.168.xx.xx&port=3': Ungütliges Argument


    So ähnlich auch bei den anderen Scan-Programmen. Der gleiche Fehler tritt auch auf, wenn ich als Root scannen will.


    Ich bin ratlos. Unter Leap 42.3 ging's ja noch. Hat jemand eine Idee?

    Für den Inhalt des Beitrages 125374 haftet ausdrücklich der jeweilige Autor: cbm

  • Teste mal, ob die Firewall etwas blockiert:
    Konsole als Root:

    Quellcode

    1. systemctl stop firewalld.service
    Dadurch wird der Firewall-Dienst, bis zum nächsten Start, angehalten.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 125375 haftet ausdrücklich der jeweilige Autor: sterun

  • hpaio:/net/Photosmart_C309a_series?ip=192.168.xx.xx&port=3
    1. Du kannst die IP schon anzeigen, 192.168 ist ein privates Netzwerk......
    2. Warum &port=3? Hier (allerdings mit Wlan):

    Quellcode

    1. scanimage -L
    2. device `hpaio:/net/ENVY_4520_series?ip=192.168.0.253' is a Hewlett-Packard ENVY_4520_series all-in-one
    3. Hast du hp-setup zum Einrichten benutzt?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 125378 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Neu

    Vielen Dank für Eure Hinweise!

    @sterun: Habe die Firewall angehalten. Hat nichts geändert; xsane bringt nach wie vor dieselbe Fehlermeldung.

    @Sauerland: Ja, zum Einrichten wurde hp-setup (aus Yast heraus) verwendet. Tatsächlich musste ich die IP per Hand eingeben, damit hp-setup das Multifunktionsgerät erkennt. Den Zusatz "&port=3" hat hp-setup dann selbst eingefügt. Das war aber auch unter Leap 42.3 schon so, als alles noch funktioniert hat.

    Für den Inhalt des Beitrages 125474 haftet ausdrücklich der jeweilige Autor: cbm

  • Neu

    Nach dem Aufruf von

    Quellcode

    1. xsane
    auf der Konsole erscheint ein Fenster mit "Suche nach Geräten", das dann wieder verschwindet. Dann erscheint ein Fenster mit Titel "Fehler" und dem Text "Fehler beim Öffnen des Geräts 'hpaio:/net/Photosmart_C309a_series?ip=192.168.188.24&port=3': Ungültiges Argument." Schließe ich das Fenster, erscheint wieder der Eingabeprompt. Keine Ausgabe auf der Konsole, kein Mucks vom Scanner.

    Für den Inhalt des Beitrages 125501 haftet ausdrücklich der jeweilige Autor: cbm

  • Neu

    Hier noch der Abschnitt zum Scanner aus hp-check.log:

    Brainfuck-Quellcode

    1. hp-check[3254]: info: :----------------------
    2. hp-check[3254]: info: :| Scan Configuration |
    3. hp-check[3254]: info: :----------------------
    4. hp-check[3254]: info: :
    5. hp-check[3254]: info: : hpaio HPLIP-SANE-Backend REQUIRED - 3.17.9 OK 'hpaio found in /etc/sane.d/dll.conf'
    6. hp-check[3254]: info: : scanext Scan-SANE-Extension REQUIRED - 3.17.9 OK -
    7. hp-check[3254]: info: :
    8. hp-check[3254]: info: :------------------------------
    9. hp-check[3254]: info: :| DISCOVERED SCANNER DEVICES |
    10. hp-check[3254]: info: :------------------------------
    11. hp-check[3254]: info: :
    12. hp-check[3254]: info: :device `hpaio:/net/Photosmart_C309a_series?ip=192.168.188.24&port=3' is a Hewlett-Packard Photosmart_C309a_series all-in-one
    Alles anzeigen
    Sieht für mich ok aus.

    Für den Inhalt des Beitrages 125502 haftet ausdrücklich der jeweilige Autor: cbm

  • Neu

    Nein, funktioniert nicht. Wenn ich

    Quellcode

    1. xsane hpaio:/net/Photosmart_C309a_series?ip=192.168.188.24

    oder

    Quellcode

    1. xsane hpaio:/net/Photosmart_C309a_series?ip=192.168.188.24&port=3
    aufrufe passiert genau das gleiche wie wenn ich nur xsane aufrufe, siehe oben.

    Für den Inhalt des Beitrages 125535 haftet ausdrücklich der jeweilige Autor: cbm