SSH-Verbindung zum RaspberryPi friert ein

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema SSH-Verbindung zum RaspberryPi friert ein gibt es 28 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • SSH-Verbindung zum RaspberryPi friert ein

    Hallo Leute.

    Ich hatte die Fragen schonmal gestellt, aber es konnte keine Lösung gefunden werden. Darum würde ich dieses Thema nochmal aufrollen. Der alte Thread ist unter WLAN-Verbindung sehr instabil zu finden.

    Kurze Zusammenfassung:
    Ich habe mit meinem Laptop (Lenovo Carbon X1 mit openSuse 15.0) massive WLAN-Probleme. Manchmal brechen einige Verbindungen einfach ab.

    Beispiel:
    Folgendes geht nicht:
    • SSH-Verbindung zum Raspberry Pi halten (alle 1-2 Minuten friert die Konsole für unbestimmte Zeit (zw. 10 Sekunden bis zur Unendlichkeit) ein)
    • Steam verliert falls inaktiv (z.B. bei der Suche einer Online-Partie) ebenfalls die Verbindung
    • Der Browser braucht manchmal bis zu einer Minute um eine angefragte Seite zu öffnen
    Folgendes geht komischerweise:
    • Online-Spiele spielen (in meinem Fall Dota 2, auch unter Linux), dort fliege ich nie aus dem Spiel
    • Von meinem kürzlich aktivierten Desktop-PC (ganz alte Kiste, AMD 6000, Leap 42.2) funktioniert der Zugriff aufs RaspberryPi ohne Unterbrechungen.
    Aufgrund der letzteren beiden Punkte schließe ich mal einen defekten Router und ein schlechtes Internet aus (zumal das Raspberry ja übers LAN angeschlossen ist). Es muss also am Laptop liegen und ich habe keine Ahnung wo ich ansetzen soll. Habe schon alle Spielereien ausprobiert, IPv6 deaktiviert, statische IP's vergeben, das Testskript aus Sauerlands Signatur gecheckt. Ohne Erfolg oder Erkenntnisse.

    Mein Router ist eine o2-Box. Um WLAN-Verbindungen kümmert sich NetworkManager (das ist doch der Dienst, der mit "nm-applet" gesteuert wird, oder?). Hier noch ein paar Daten zu meinem System:

    Quellcode

    1. max@linux-ogpy:~> sudo lspci | grep -i network
    2. 04:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 88)
    3. max@linux-ogpy:~> uname -a
    4. Linux linux-ogpy 4.19.5-1.g6210279-default #1 SMP PREEMPT Tue Nov 27 19:56:09 UTC 2018 (6210279) x86_64 x86_64 x86_64 GNU/Linux
    5. max@linux-ogpy:~> cat /etc/os-release
    6. NAME="openSUSE Leap"
    7. VERSION="15.0"
    8. ID="opensuse-leap"
    9. ID_LIKE="suse opensuse"
    10. VERSION_ID="15.0"
    11. PRETTY_NAME="openSUSE Leap 15.0"
    12. ANSI_COLOR="0;32"
    13. CPE_NAME="cpe:/o:opensuse:leap:15.0"
    14. BUG_REPORT_URL="https://bugs.opensuse.org"
    15. HOME_URL="https://www.opensuse.org/"
    Alles anzeigen



    Sorry wenn ich schon wieder mit diesem Thema nerven sollte. Aber besonders die Arbeit mit dem Raspberry macht mich wahnsinnig.


    Viele Grüße
    Max

    Für den Inhalt des Beitrages 127056 haftet ausdrücklich der jeweilige Autor: max3000

  • Hab am RaspberryPi nichts in der Richtung umgestellt. Nur, dass er vom DHCP eine feste IP zugewiesen bekommt. Das Raspi steckt via Ethernet-Kabel dran.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von max3000 ()

    Für den Inhalt des Beitrages 127058 haftet ausdrücklich der jeweilige Autor: max3000

  • Dann versuch es doch mit fester IP, festem nameserver und festem gateway.

    Das die ssh Verbindung mal weg ist, ist auch normal.

    Ansonsten befaase dich mal mit screen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 127059 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ich habe auf statische IP-Adresse umgestellt. Dabei habe ich die Anleitung aus raspbian - How do I set up networking/WiFi/static IP address? - Raspberry Pi Stack Exchange (Network interfaces method) verwendet. Leider hat das nichts am Problem geändert.

    Was kann man mit screen machen? Was meinst du soll ich damit tun?

    Für den Inhalt des Beitrages 127060 haftet ausdrücklich der jeweilige Autor: max3000

  • Du meldest dich mit ssh an und startest dann eine screen-Session.
    Wenn die Verbindung abbricht, kannst du dich neu mit ssh verbinden und in der screen-Session dort weiterarbeiten,als der Abbruch stattfand.
    Es geht nichts verloren.

    Zusatz: Es können sich auch mehrere verschiedenen User mit dieser screen-Session verbinden und arbeiten.

    Siehe:

    Quellcode

    1. man screen
    Übrigens läuft mein irc-Programm (irssi) auch in einer screen Session auf meinem Server.
    Darauf verbinde ich mich mit meinen Computern per Konversation.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 127061 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Und zu deinem Wlan und raspberry:
    Ist der Wlan Stich an einem aktiven (mit Netzteil) USB-Hub?
    Wenn nein, mal versucht?


    Nachgelesen und gestrichen.........

    Vom openSUSE Rechner:
    Tja, wo es dran liegt, kann ich nicht sagen, evtl. mal den Standort wechseln, anderen Stick ausprobieren oder oder oder.
    Poste auch mal:

    Quellcode

    1. cat /etc/resolv.conf
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 127063 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Wenn es mal wieder nicht funktioniert:
    neue Konsole öffnen und:

    Quellcode

    1. ping -c3 8.8.8.8



    Quellcode

    1. ping -c3 google.com
    Wichtig ist dann die vorletzte Zeile:

    Quellcode

    1. ping -c3 google.com
    2. PING google.com (172.217.16.142) 56(84) bytes of data.
    3. 64 bytes from zrh04s06-in-f142.1e100.net (172.217.16.142): icmp_seq=1 ttl=55 time=27.8 ms
    4. 64 bytes from zrh04s06-in-f142.1e100.net (172.217.16.142): icmp_seq=2 ttl=55 time=27.8 ms
    5. 64 bytes from zrh04s06-in-f142.1e100.net (172.217.16.142): icmp_seq=3 ttl=55 time=27.8 ms
    6. --- google.com ping statistics ---
    7. 3 packets transmitted, 3 received, 0% packet loss, time 2003ms
    8. rtt min/avg/max/mdev = 27.825/27.845/27.875/0.021 ms
    3 übertragen, 3 empfangen, 0 verloren.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 127065 haftet ausdrücklich der jeweilige Autor: Sauerland