Geogebra funktioniert nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Geogebra funktioniert nicht gibt es 25 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Geogebra funktioniert nicht

    Hallo,

    ich habe mir auf meinem PC (OpenSuse Leap 15, mit KDE 5.12.8) das Programm Geogebra (Version 5.0.525.0+git1550701550.99a87384) installiert. Wen ich es aber starten will kommt diese Fehlermeldung:

    Quellcode

    1. mark@Marks-PC:~> geogebra
    2. Unrecognized option: -p
    3. Error: Could not create the Java Virtual Machine.
    4. Error: A fatal exception has occurred. Program will exit.
    Ich habe Geogebra mit Yast ohne Fehlermeldungen installiert. Kann mir jemand sagen was der Fehler ist, und wie ich ihn löse?

    Für den Inhalt des Beitrages 132257 haftet ausdrücklich der jeweilige Autor: Newt

  • Weil nicht alles in einen Nachricht passt mache ich es in zwei.

    Brainfuck-Quellcode

    1. mark@Marks-PC:~> zypper se -si java geobra
    2. Repository-Daten werden geladen...
    3. Installierte Pakete werden gelesen...
    4. S | Name | Typ | Version | Arch | Repository
    5. ---+--------------------------------+-------+--------------------------------------+--------+--------------------------------
    6. i+ | java-10-openjdk | Paket | 10.0.2.0-lp150.2.3.2 | x86_64 | Hauptaktualisierungs-Repository
    7. i+ | java-10-openjdk | Paket | 10.0.2.0-lp150.2.3.2 | x86_64 | openSUSE:Leap:15.0:Update
    8. i+ | java-10-openjdk-headless | Paket | 10.0.2.0-lp150.2.3.2 | x86_64 | Hauptaktualisierungs-Repository
    9. i+ | java-10-openjdk-headless | Paket | 10.0.2.0-lp150.2.3.2 | x86_64 | openSUSE:Leap:15.0:Update
    10. i+ | java-11-openjdk | Paket | 11.0.2.0-lp150.2.12.1 | x86_64 | Hauptaktualisierungs-Repository
    11. i+ | java-11-openjdk | Paket | 11.0.2.0-lp150.2.12.1 | x86_64 | openSUSE:Leap:15.0:Update
    12. i+ | java-11-openjdk-headless | Paket | 11.0.2.0-lp150.2.12.1 | x86_64 | Hauptaktualisierungs-Repository
    13. i+ | java-11-openjdk-headless | Paket | 11.0.2.0-lp150.2.12.1 | x86_64 | openSUSE:Leap:15.0:Update
    14. i+ | java-1_8_0-openjdk | Paket | 1.8.0.201-lp150.2.12.1 | x86_64 | Hauptaktualisierungs-Repository
    15. i+ | java-1_8_0-openjdk | Paket | 1.8.0.201-lp150.2.12.1 | x86_64 | openSUSE:Leap:15.0:Update
    16. i+ | java-1_8_0-openjdk-headless | Paket | 1.8.0.201-lp150.2.12.1 | x86_64 | Hauptaktualisierungs-Repository
    17. i+ | java-1_8_0-openjdk-headless | Paket | 1.8.0.201-lp150.2.12.1 | x86_64 | openSUSE:Leap:15.0:Update
    18. i+ | javapackages-tools | Paket | 5.0.0+git20180104.9367c8f6-lp150.1.2 | x86_64 | Haupt-Repository (OSS)
    19. i+ | libjavascriptcoregtk-4_0-18 | Paket | 2.24.0-lp150.2.16.1 | x86_64 | Hauptaktualisierungs-Repository
    20. i+ | libjavascriptcoregtk-4_0-18 | Paket | 2.24.0-lp150.2.16.1 | x86_64 | openSUSE:Leap:15.0:Update
    21. i+ | timezone-java | Paket | 2018i-lp150.2.16.1 | noarch | Hauptaktualisierungs-Repository
    22. i+ | timezone-java | Paket | 2018i-lp150.2.16.1 | noarch | openSUSE:Leap:15.0:Update
    23. i+ | typelib-1_0-JavaScriptCore-4_0 | Paket | 2.24.0-lp150.2.16.1 | x86_64 | Hauptaktualisierungs-Repository
    24. i+ | typelib-1_0-JavaScriptCore-4_0 | Paket | 2.24.0-lp150.2.16.1 | x86_64 | openSUSE:Leap:15.0:Update
    Alles anzeigen

    Für den Inhalt des Beitrages 132262 haftet ausdrücklich der jeweilige Autor: Newt

  • Brainfuck-Quellcode

    1. mark@Marks-PC:~> zypper lr -d
    2. Repository-Prioritäten treten in Kraft: (Siehe 'zypper lr -P' für Details)
    3. 70 (erhöhte Priorität) : 1 Repository
    4. 99 (Standard-Priorität) : 10 Repositorys
    5. 100 (gesenkte Priorität) : 6 Repositorys
    6. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    7. ---+-------------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+----------------------------------------------------------------------------------------------+-------
    8. 1 | download.nvidia.com-leap | nVidia Graphics Drivers | Ja | (r ) Ja | Ja | 99 | rpm-md | https://download.nvidia.com/opensuse/leap/15.0 |
    9. 2 | download.opensuse.org-non-oss | Haupt-Repository (NON-OSS) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/ |
    10. 3 | download.opensuse.org-non-oss_1 | Aktualisierungs-Repository (Nicht-Open-Source-Software) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.0/non-oss/ |
    11. 4 | download.opensuse.org-oss | Haupt-Repository (OSS) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15.0/repo/oss/ |
    12. 5 | download.opensuse.org-oss_1 | Hauptaktualisierungs-Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.0/oss |
    13. 6 | http-download.opensuse.org-002e6c86 | home:ecsos:messenger:matrix | Ja | (r ) Ja | Ja | 100 | rpm-md | http://download.opensuse.org/repositories/home:/ecsos:/messenger:/matrix/openSUSE_Leap_15.0/ |
    14. 7 | http-download.opensuse.org-01682aab | multimedia:apps | Ja | (r ) Ja | Ja | 100 | rpm-md | http://download.opensuse.org/repositories/multimedia:/apps/openSUSE_Leap_15.0/ |
    15. 8 | http-download.opensuse.org-155f31b6 | KDE:Frameworks5 | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_15.0/ |
    16. 9 | http-download.opensuse.org-384b1016 | multimedia:libs | Ja | (r ) Ja | Ja | 100 | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_Leap_15.0/ |
    17. 10 | http-download.opensuse.org-488cbff2 | network | Ja | (r ) Ja | Ja | 100 | rpm-md | http://download.opensuse.org/repositories/network/openSUSE_Leap_15.0/ |
    18. 11 | http-download.opensuse.org-55d97581 | KDE:Qt5 | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_15.0/ |
    19. 12 | http-download.opensuse.org-6e35c627 | games:tools | Ja | (r ) Ja | Ja | 100 | rpm-md | http://download.opensuse.org/repositories/games:/tools/openSUSE_Leap_15.0/ |
    20. 13 | http-download.opensuse.org-db157b29 | openSUSE:Leap:15.0:Update | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.0/oss/ |
    21. 14 | http-download.opensuse.org-f898db55 | games | Ja | (r ) Ja | Ja | 100 | rpm-md | http://download.opensuse.org/repositories/games/openSUSE_Leap_15.0/ |
    22. 15 | openSUSE-Leap-15.0-1 | openSUSE-Leap-15.0-1 | Nein | ---- | ---- | 99 | rpm-md | cd:///?devices=/dev/disk/by-id/ata-ATAPI_DVD_A_DH16AAS |
    23. 16 | opensuse-guide.org-repo | Libdvdcss Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/ |
    24. 17 | packman.inode.at-suse | Packman Repository | Ja | (r ) Ja | Ja | 70 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.0/ |
    25. 18 | repo-debug | openSUSE-Leap-15.0-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/ |
    26. 19 | repo-debug-non-oss | openSUSE-Leap-15.0-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/ |
    27. 20 | repo-debug-update | openSUSE-Leap-15.0-Update-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.0/oss/ |
    28. 21 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.0/non-oss/ |
    29. 22 | repo-source | openSUSE-Leap-15.0-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/ |
    30. 23 | repo-source-non-oss | openSUSE-Leap-15.0-Source-Non-Oss | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/ |
    31. 24 | snappy | snappy | Ja | (r ) Ja | Ja | 99 | rpm-md | https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.0
    Alles anzeigen

    Für den Inhalt des Beitrages 132264 haftet ausdrücklich der jeweilige Autor: Newt

  • Brainfuck-Quellcode

    1. mark@Marks-PC:~> sudo update-alternatives --config java
    2. There are 3 choices for the alternative java (providing /usr/bin/java).
    3. Selection Path Priority Status
    4. ------------------------------------------------------------
    5. * 0 /usr/lib64/jvm/jre-11-openjdk/bin/java 2105 auto mode
    6. 1 /usr/lib64/jvm/jre-1.8.0-openjdk/bin/java 1805 manual mode
    7. 2 /usr/lib64/jvm/jre-10-openjdk/bin/java 2005 manual mode
    8. 3 /usr/lib64/jvm/jre-11-openjdk/bin/java 2105 manual mode

    Für den Inhalt des Beitrages 132268 haftet ausdrücklich der jeweilige Autor: Newt

  • Dann solltest du dem Maintainer des Paketes eine bugreport schreiben:
    Show home:concyclic:java / geogebra - openSUSE Build Service
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 132271 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Übrigens:
    Requires: jlatexmath
    Requires: jna
    Requires: openjfx
    Hast du bei der Installation irgendwelche Abhängigkeiten ignoriert?

    Quellcode

    1. zypper ve
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 132280 haftet ausdrücklich der jeweilige Autor: Sauerland