Update auf 15.1 mit StableKernel

Hinweis: In dem Thema Update auf 15.1 mit StableKernel gibt es 28 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    ich fahre jetzt schon eine Weile Leap auf meinem Notebook (Lenovo T510) 15.0 mit Stablekernel damit ich den propriäteren NVIDA Treiber nutzen kann.
    Jetzt habe ich mich mal an ein Update getraut :


    Ich hatte vor dem Update das Stable Repo drin gelassen.
    Hat soweit geklappt.
    Ich musste beim ersten Booten halt mit nomodeset ins Level 3 booten und den NVIDIA Treiber neu installieren.
    Es gab insgesamt 3 Probleme wobei ich die Lösung beim dritten kenne aber es nie verstanden habe.


    1) Das Blacklisting für den nouveau-Treiber klappt nicht. Ich muss immer mit nomodeset starten (hat das negative Effekte ?).
    2) Der WLAN - Treiber läuft und behauptet mein Router sei verbunden,aber ich hab aber keine Internetverbindung (Router ist definiv OK andere Rechner laufen).
    3) Boinc spinnt.


    Da ich 1 und 2 nicht spontan lösen konnte habe ich erst mal mein 15.0 Backup wieder eingespielt da ich den Rechner brauche.


    3) Kannte ich schon Virtualbox geht nicht mehr und BOINC hält sich für Virtualbox -> die Lösung war (von 42.3 auf 15.0) schon Virtual Box deinstallieren -> update -> boinc geht ->
    virtual Box wieder installieren.


    Damals hatte ich die VBOX von Virtualbox.org dann durch die aus dem OpenSuse-Repo ersetzt.
    Wegen mehrfachen Ärgers bei Kernelupdate habe ich dann doch vor zwei Wochen wieder die von Virtualbox.org genommen. (Vorher konnte ich die aus dem Repo einmal durch manuelles
    Sourcepatchen retten).
    Bin mir jetzt nicht sicher ob das Problem speziell an der von Virtualbox.org liegt.
    Ist aber auch egal-> vor dem nächsten Updateversuch wird die VBOX erstmal wieder deinstalliert.


    1 und 2 würde mich dagegen interessieren.


    Was Positives : Da ich Thunderbird im Moment von Updates ausklammere weil ich FireTray benutze hatte ich eigentlich gedacht das das Update mir
    eine neuere Version einschleppt. Aber Nein. Die Sperre im Yast hat das Update tatsächlich überlebt.


    Ulli

    Für den Inhalt des Beitrages 133512 haftet ausdrücklich der jeweilige Autor: beeblebrox

  • 1) Das Blacklisting für den nouveau-Treiber klappt nicht. Ich muss immer mit nomodeset starten (hat das negative Effekte ?).

    Das du wie machst?
    Poste:

    Code
    grep -i 'blacklist nouveau' /etc/modprobe.d/*



    2) Der WLAN - Treiber läuft und behauptet mein Router sei verbunden,aber ich hab aber keine Internetverbindung (Router ist definiv OK andere Rechner laufen).

    Verbindest du dich per dhcp?
    Dann als root:


    Code
    netconfig update -f

    Übrigens brauchst du beim kernel:stable für Virtualbox ein extra Repo, aber da kernel:stable gegen factory gebaut ist, kann es da natürlich zu Problemen kommen, z.B. war das mal mit openssl glaub ich.

  • Mal wieder Danke für die SUPERSCHNELLE Antwort.


    Netzwerk ist via Networkmanager aber mit fester IP.
    Die Konfiguration wurde auch korrekt übernommen.


    Das Blacklisten habe ich unter 15.0 über die 50-blacklist.conf in /etc/modprobe.d gemacht mit folgenden Zeilen :

    Code
    blacklist nouveau
    options nouveau modeset=0

    Wenn das nicht geht kann ich ja auch dafür sorgen das immer mit nomodeset gestartet wird. Aber eben da die Frage :
    Hat das negative Seiteneffekte weil das ja sehr ungezielt ist.


    Für die VirtualBox habe ich dieses

    Code
    https://download.opensuse.org/repositories/Kernel:/stable:/KMP/standard/

    Repo eingebunden.


    Dieses komische Problem hatte ich aber schon mehrfach beim Updaten.
    Irgendwie beißen sich VBOX und BOINC.
    Aber das kann ich ja lösen.


    Früher gab es da regelrechte Endlosbootschleifen. Top zeigt an VBOXMANAGER (der gar nicht gestartet wurde) vom USER Boinc.
    Wie gesagt VBOX deinstallieren -> updaten -> VBOX wieder installieren dann geht das.


    Ulli

    Für den Inhalt des Beitrages 133515 haftet ausdrücklich der jeweilige Autor: beeblebrox

  • So,


    zwei Probleme sind gelöst.
    Ich habe noch mal neu installiert und vorher die Virtualbox deinstalliert.
    Kannte ich ja schon.


    1) Nach der Installation von 15.1 und Reboot läuft mein BOINC mit Seti wieder :-).
    2) Für das dauerhafte "Blacklisten" von nouveau musste ich diesmal noch ein mkinitrd aufrufen.
    Jetzt geht's auch ohne "nomodeset" beim booten.
    Alles SUPER aaaber ->
    Keine Namensauflösung: Wlan steht, für ein internes Netzwerk nutze ich das Kabel (keine Verbindung zum Inet).
    Alles geht, ich kriege nur keine Namensauflösung.


    sudo netconfig update -f habe ich gemacht.
    Die /etc/resolv.conf gelöscht und neu gebootet.


    Nutzt alles nix. In der resolv.conf steht der richtige Nameserver (nämlich die IP meiner Fritz.box).
    Diese ist auch per Ping erreichbar.
    Mal von statischer auf dynamische IP gewechselt -> kein Erfolg.


    Jetzt fällt mir erst mal nix mehr ein.


    Schaade. Ich hatte schon "sprödere" Updates. Das sieht doch richtig gut aus.
    Hatte gestern in einer "Firmen VM (also Arbeit) schon Problemlos von 42.3 auf 15.1 upgegradet) da gab
    es nur ein kleines SSH Problem (das nur bei VMWARE existiert).


    Ulli

    Für den Inhalt des Beitrages 133549 haftet ausdrücklich der jeweilige Autor: beeblebrox

  • In die böse weite Welt.
    Intern klappt es über die /etc/hosts


    Die Fritz.box welche hier Nameserver spielt macht auch alles richtig.
    Ich schreibe hier gerade aus einer VM-mit Opensuse 15.1


    Und wenn ich wieder auf 15.0 "restore" geht mein T510 mit den selben Einstellungen auch.


    Ulli

    Für den Inhalt des Beitrages 133551 haftet ausdrücklich der jeweilige Autor: beeblebrox

  • Ok,
    Gott sei Dank habe ich 'ne ssh-Verbindung zum dem Notebook, sonst müsste ich alles abtippen ;-)


    Also resolv.conf :


    und ls -al /etc/resolv.conf


    Code
    kandy@trillian2:/etc> ls -al /etc/resolv.conf
    lrwxrwxrwx 1 root root 30 8. Jun 17:12 /etc/resolv.conf -> /var/run/netconfig/resolv.conf
    kandy@trillian2:/etc>

    Ulli

    Für den Inhalt des Beitrages 133553 haftet ausdrücklich der jeweilige Autor: beeblebrox

  • Ok,
    Gott sei Dank habe ich 'ne ssh-Verbindung zum dem Notebook, sonst müsste ich alles abtippen ;-)


    und ls -al /etc/resolv.conf


    Code
    kandy@trillian2:/etc> ls -al /etc/resolv.conf
    lrwxrwxrwx 1 root root 30 8. Jun 17:12 /etc/resolv.conf -> /var/run/netconfig/resolv.conf
    kandy@trillian2:/etc>


    Ulli

    Ich hab noch eine /etc/resolv.conf:

    Code
    ls -al /etc/resolv.conf
    -rw-r--r-- 1 root root 820 20. Apr 00:52 /etc/resolv.conf
  • Zitat

    Gott sei Dank habe ich 'ne ssh-Verbindung zum dem Notebook, sonst müsste ich alles abtippen

    Ich auch, sitze hier vorm Desktop mit Leap 15.0......