NFS-Client: Unterschiedliches Verhalten Leap 15.1 und Tumbleweed (Tumbleweed mit Problemen)

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema NFS-Client: Unterschiedliches Verhalten Leap 15.1 und Tumbleweed (Tumbleweed mit Problemen) gibt es 39 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • NFS-Client: Unterschiedliches Verhalten Leap 15.1 und Tumbleweed (Tumbleweed mit Problemen)

    Hallo,

    ich habe ein Problem mit NFS. Bin kein Neueinsteiger (aber auch kein super Experte) und betreibe NFS schon seit Jahren.

    Mein Setup:
    - avahi auf allen Rechnern installiert und aktiviert
    - NFS server und client auf allen Rechnern installiert
    - Firewalls sind alle gleich konfiguriert
    - alle Systeme auf dem neuesten Stand


    NFS- Server
    openSUSE Leap 15.1
    Rechnername: linux-multimedia (linux-multimedia.local)
    User-name: multimedia
    NFS-Export: /home/multimedia

    NFS-Client I + II
    NFS client I:
    - openSUSE Leap 15.1
    - /etc/fstab: linux-multimedia.local:/home/multimedia /mnt/linux-multimedia/home/multimedia nfs users,noauto,nfsvers=4 0 0
    ==> NFS Verzeichnis wird komplett problemlos gemounted :)

    NFS client II:
    - openSUSE Tumbleweed
    - /etc/fstab: linux-multimedia.local:/home/multimedia /mnt/linux-multimedia/home/multimedia nfs users,noauto,nfsvers=4 0 0
    - showmount -e linux-multimedia.local ergibt /home/multimedia * :thumbsup:
    ==> NFS Verzeichnis wird nicht gemounted :smilie_pc_057:

    Also, da der NFS-Client I (mit Leap 15.1) vollkommen problemlos funktioniert, kann ich davon ausgehen, dass der NFS-Server (mit Leap 15.1) funktioniert und alles korrekt (inkl. Firewall) konfiguriert ist.
    Der NFS-Client II (mit Tumbleweed) ist absolut identisch konfiguriert - aber das NFS Verzeichnis wird nicht gemounted.


    Bin mit meinem Latein am Ende. Ich bin aber noch nicht soweit, einen Bugreport zu schreiben, da ich glaube, es liegt an mir. Kann mir eventuell jemand helfen?

    Für den Inhalt des Beitrages 138036 haftet ausdrücklich der jeweilige Autor: Sebastian1969

  • Um Schreibfehler auszuschließen, poste mal von dem Tumbleweed Rechner:

    Quellcode

    1. cat /etc/fstab

    Quellcode

    1. ls -al /mnt/linux-multimedia/home/multimedia/


    Benutze Code-Tags, Link hier unter diesem Text.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 138039 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Quellcode

    1. linux-sebastian:/home/sebastian # cat /etc/fstab
    2. UUID=d8f0c4a4-a274-4654-a3a4-561777bd9c64 swap swap defaults 0 0
    3. UUID=46dfafac-fbe2-48eb-b037-156c4bb3d053 / ext4 acl,user_xattr 1 1
    4. UUID=8c67e208-4533-4e3e-a29a-6736d5fe8992 /home ext4 acl,user_xattr 1 2
    5. UUID=95e6c316-096a-4b3c-b2f6-d9b1df9e4317 /mnt/linux-sebastian_hdd_internal ext4 defaults 1 2
    6. tmpfs /tmp tmpfs nosuid 0 0
    7. linux-multimedia.local:/home/multimedia /mnt/linux-multimedia/home/multimedia nfs users,noauto,nfsvers=4 0 0
    8. linux-sebastian:/home/sebastian #

    Für den Inhalt des Beitrages 138045 haftet ausdrücklich der jeweilige Autor: Sebastian1969

  • Quellcode

    1. linux-sebastian:/home/sebastian # ls -al /mnt/linux-multimedia/home/multimedia/
    2. insgesamt 8
    3. drwxr-xr-x 2 root root 4096 15. Mai 2018 .
    4. drwxr-xr-x 3 root root 4096 15. Mai 2018 ..

    Für den Inhalt des Beitrages 138046 haftet ausdrücklich der jeweilige Autor: Sebastian1969

  • Im 1. Terminal als root:

    Quellcode

    1. journalctl -f

    In einem 2. Terminal als root:

    Quellcode

    1. mount -a
    Und im 1. Terminal schauen, ob es dort etwas anzeigt.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 138048 haftet ausdrücklich der jeweilige Autor: Sauerland

  • PS:
    Ich hoffe mal, das bei dem Tumbleweed Rechner kein Wlan oder kein Netzwerkmanager am werkeln ist.......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 138049 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Quellcode

    1. linux-sebastian:/home/sebastian # journalctl -f
    2. -- Logs begin at Thu 2019-08-22 18:03:00 CEST. --
    3. Dez 30 23:05:38 linux-sebastian org_kde_powerdevil[2002]: powerdevil: Scheduling inhibition from ":1.14" "firefox" with cookie 4 and reason "video-playing"
    4. Dez 30 23:05:39 linux-sebastian org_kde_powerdevil[2002]: powerdevil: Releasing inhibition with cookie 4
    5. Dez 30 23:05:39 linux-sebastian org_kde_powerdevil[2002]: powerdevil: It was only scheduled for inhibition but not enforced yet, just discarding it
    6. Dez 30 23:05:43 linux-sebastian org_kde_powerdevil[2002]: powerdevil: Enforcing inhibition from ":1.14" "firefox" with cookie 4 and reason "video-playing"
    7. Dez 30 23:05:43 linux-sebastian org_kde_powerdevil[2002]: powerdevil: By the time we wanted to enforce the inhibition it was already gone; discarding it
    8. Dez 30 23:05:44 linux-sebastian org_kde_powerdevil[2002]: powerdevil: Scheduling inhibition from ":1.14" "firefox" with cookie 5 and reason "video-playing"
    9. Dez 30 23:05:45 linux-sebastian org_kde_powerdevil[2002]: powerdevil: Releasing inhibition with cookie 5
    10. Dez 30 23:05:45 linux-sebastian org_kde_powerdevil[2002]: powerdevil: It was only scheduled for inhibition but not enforced yet, just discarding it
    11. Dez 30 23:05:49 linux-sebastian org_kde_powerdevil[2002]: powerdevil: Enforcing inhibition from ":1.14" "firefox" with cookie 5 and reason "video-playing"
    12. Dez 30 23:05:49 linux-sebastian org_kde_powerdevil[2002]: powerdevil: By the time we wanted to enforce the inhibition it was already gone; discarding it
    13. Dez 30 23:06:30 linux-sebastian kwin_x11[1971]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 63988, resource id: 35668832, major code: 18 (ChangeProperty), minor code: 0
    14. Dez 30 23:06:40 linux-sebastian su[3689]: The gnome keyring socket is not owned with the same credentials as the user login: /run/user/1000/keyring/control
    15. Dez 30 23:06:40 linux-sebastian su[3689]: gkr-pam: couldn't unlock the login keyring.
    16. Dez 30 23:06:40 linux-sebastian su[3689]: (to root) sebastian on pts/3
    17. Dez 30 23:06:40 linux-sebastian su[3689]: pam_unix(su:session): session opened for user root(uid=0) by sebastian(uid=1000)
    Alles anzeigen
    Wenn mount -a ausgeführt --> keine Änderung

    Für den Inhalt des Beitrages 138050 haftet ausdrücklich der jeweilige Autor: Sebastian1969