Codecs installieren

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Codecs installieren gibt es 3 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Codecs installieren

    Hallo zusammen,
    ich habe versucht nach der Anleitung im Forum die nicht unterstützten Codecs nach zu installieren.
    Restricted Formats installieren / Codecs installieren

    Leider bin ich da in der Bash in einer Schleife gefangen die ich selbst nicht aufgelöst bekomme:

    Brainfuck-Quellcode

    1. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI
    2. ---+---------------------------+------------------------------------+-----------+-----------------+----------------+-----------+-------------------------------------------------------------------------------
    3. 1 | Packman Repository | Packman Repository | Ja | (r ) Ja | Ja | 20 | http://packman.inode.at/suse/openSUSE_Leap_15.1/
    4. 2 | nvidia | nvidia | Ja | (r ) Ja | Ja | 99 | https://download.nvidia.com/opensuse/leap/15.1/
    5. 3 | openSUSE-Leap-15.1-1 | openSUSE-Leap-15.1-1 | Nein | ---- | ---- | 99 | hd:/?device=/dev/disk/by-id/usb-Innostor_Innostor_000000000000001537-0:0-part2
    6. 4 | repo-debug | Debug Repository | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/
    7. 5 | repo-debug-non-oss | Debug Repository (Non-OSS) | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/
    8. 6 | repo-debug-update | Update Repository (Debug) | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/update/leap/15.1/oss/
    9. 7 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/update/leap/15.1/non-oss/
    10. 8 | repo-oss | Haupt-Repository | Ja | (r ) Ja | Ja | 99 | http://download.opensuse.org/distribution/leap/15.1/repo/oss/
    11. 9 | repo-source | Source Repository | Nein | ---- | ---- | 99 | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/
    12. 10 | repo-source-non-oss | Source Repository (Non-OSS) | Nein | ---- | ---- | 99 | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/
    13. 11 | repo-update | Hauptaktualisierungs-Repository | Ja | (r ) Ja | Ja | 99 | http://download.opensuse.org/update/leap/15.1/oss
    Alles anzeigen

    Dann gebe ich

    Quellcode

    1. zypper dup --from 1
    ein, und bekomme dann:

    Quellcode

    1. Repository-Daten werden geladen...
    2. Installierte Pakete werden gelesen...
    3. Distributions-Aktualisierungen werden verarbeitet...
    4. 20 Probleme:
    5. Problem: Problem mit installiertem Paket libavresample3-3.4.4-lp151.2.2.x86_64
    6. Problem: Problem mit installiertem Paket libavdevice57-3.4.4-lp151.2.2.x86_64
    7. Problem: Problem mit installiertem Paket libswresample2-3.4.4-lp151.2.2.x86_64
    8. Problem: Problem mit installiertem Paket libavcodec57-3.4.4-lp151.2.2.x86_64
    9. Problem: Problem mit installiertem Paket libswscale4-3.4.4-lp151.2.2.x86_64
    10. Problem: Problem mit installiertem Paket libavformat57-3.4.4-lp151.2.2.x86_64
    11. Problem: Problem mit installiertem Paket libavutil55-3.4.4-lp151.2.2.x86_64
    12. Problem: Problem mit installiertem Paket libavfilter6-3.4.4-lp151.2.2.x86_64
    13. Problem: Problem mit installiertem Paket libpostproc54-3.4.4-lp151.2.2.x86_64
    14. Problem: Problem mit installiertem Paket libvlccore9-3.0.7.1-lp151.6.3.1.x86_64
    15. Problem: Problem mit installiertem Paket vlc-codec-gstreamer-3.0.7.1-lp151.6.3.1.x86_64
    16. Problem: Problem mit installiertem Paket libvlc5-3.0.7.1-lp151.6.3.1.x86_64
    17. Problem: Problem mit installiertem Paket vlc-3.0.7.1-lp151.6.3.1.x86_64
    18. Problem: Problem mit installiertem Paket vlc-qt-3.0.7.1-lp151.6.3.1.x86_64
    19. Problem: Problem mit installiertem Paket libquicktime0-1.2.4cvs20150223-lp151.4.3.x86_64
    20. Problem: Problem mit installiertem Paket libgstgl-1_0-0-1.12.5-lp151.3.1.x86_64
    21. Problem: Problem mit installiertem Paket vlc-vdpau-3.0.7.1-lp151.6.3.1.x86_64
    22. Problem: Problem mit installiertem Paket vlc-noX-3.0.7.1-lp151.6.3.1.x86_64
    23. Problem: Problem mit installiertem Paket libgstphotography-1_0-0-1.12.5-lp151.3.1.x86_64
    24. Problem: Problem mit installiertem Paket vlc-lang-3.0.7.1-lp151.6.3.1.noarch
    25. Problem: Problem mit installiertem Paket libavresample3-3.4.4-lp151.2.2.x86_64
    26. Lösung 1: libavresample3-3.4.4-lp151.3.7.x86_64 installieren (mit Anbieterwechsel)
    27. openSUSE --> http://packman.links2linux.de
    28. Lösung 2: veraltetes libavresample3-3.4.4-lp151.2.2.x86_64 beibehalten
    29. Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/u/w/a/d/?] (a):
    Alles anzeigen
    Und bin dann irgendwie in der Dauerschleife:

    Quellcode

    1. Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/u/w/a/d/?] (a): #1
    2. Problem: Problem mit installiertem Paket libavdevice57-3.4.4-lp151.2.2.x86_64
    3. Lösung 1: libavdevice57-3.4.4-lp151.3.7.x86_64 installieren (mit Anbieterwechsel)
    4. openSUSE --> http://packman.links2linux.de
    5. Lösung 2: veraltetes libavdevice57-3.4.4-lp151.2.2.x86_64 beibehalten
    6. Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/u/w/a/d/?] (a): #1
    7. Problem: Problem mit installiertem Paket libswresample2-3.4.4-lp151.2.2.x86_64
    8. Lösung 1: libswresample2-3.4.4-lp151.3.7.x86_64 installieren (mit Anbieterwechsel)
    9. openSUSE --> http://packman.links2linux.de
    10. Lösung 2: veraltetes libswresample2-3.4.4-lp151.2.2.x86_64 beibehalten
    11. Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/u/w/a/d/?] (a): #1
    12. Problem: Problem mit installiertem Paket libavcodec57-3.4.4-lp151.2.2.x86_64
    13. Lösung 1: libavcodec57-3.4.4-lp151.3.7.x86_64 installieren (mit Anbieterwechsel)
    14. openSUSE --> http://packman.links2linux.de
    15. Lösung 2: veraltetes libavcodec57-3.4.4-lp151.2.2.x86_64 beibehalten
    Alles anzeigen
    Kann mir hier bitte jemand helfen?
    Vielen Dank!

    Für den Inhalt des Beitrages 138210 haftet ausdrücklich der jeweilige Autor: Kronos

  • Du hast das Packman-Repo richtig hinzugefügt.
    Auch die Prio hast du angepasst.
    Mit deinem Befehl wirst du lediglich gefragt, ob schon vorhandene Pakete von einem anderen Repo auf Packman umgestellt werden dürfen (Lösung 1).
    Gib mal lieber ein:

    Quellcode

    1. zypper -vv dup --allow-vendor-change --from "Packman Repository"
    Damit erlauben wir einen Anbieterwechsel.

    Für den Inhalt des Beitrages 138212 haftet ausdrücklich der jeweilige Autor: sterun

  • Kronos schrieb:

    Problem: Problem mit installiertem Paket libavresample3-3.4.4-lp151.2.2.x86_64
    Lösung 1: libavresample3-3.4.4-lp151.3.7.x86_64 installieren (mit Anbieterwechsel)
    openSUSE --> PackMan :: Startseite
    Lösung 2: veraltetes libavresample3-3.4.4-lp151.2.2.x86_64 beibehalten
    Nur mal zur Erklärung:
    Du willst ja alle Pakete auf die Version von Packman umstellen und wenn du dann liest:

    Lösung 1: libavresample3-3.4.4-lp151.3.7.x86_64 installieren (mit Anbieterwechsel)

    openSUSE --> PackMan :: Startseite
    von openSUSE auf Packman........
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 138223 haftet ausdrücklich der jeweilige Autor: Sauerland