Leap 15.1 und AMD Grafikkarte

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Leap 15.1 und AMD Grafikkarte gibt es 42 Antworten auf 5 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Leap 15.1 und AMD Grafikkarte

    Hallo Forum!
    Habe mich nach Jahren ein neues Notebook zugelegt.
    Diese Notebook verfügt über eine Ryzen 7 und einer AMD Grafikkarte, die nach der Installation von Leap 15.1 bisher noch nicht erkannt wird.
    Unter Systemeinstellungen -> Monitor wird "default" mit einer Auflösung von nur 1024x768 angezeigt.


    Unter Windows wird die GraKa als Radeon RX Vega 10 Grafics gelistet.
    Habe dann mittels Yast die Hardware-Informationen abgefragt:
    Danach soll es sich um eine ATI Picasso handeln.

    Dann habe ich mittels /usr/bin/hwinfo folgende Nachricht bekommen:

    Quellcode

    1. [Created at pci.386]
    2. Unique ID: +3So.VUoRfOwWb10
    3. Parent ID: JZZT.A_VqgZKlSp2
    4. SysFS ID: /devices/pci0000:00/0000:00:08.1/0000:04:00.4
    5. SysFS BusID: 0000:04:00.4
    6. Hardware Class: usb controller
    7. Model: "AMD Raven USB 3.1"
    8. Vendor: pci 0x1022 "AMD"
    9. Device: pci 0x15e1 "Raven USB 3.1"
    10. SubVendor: pci 0x103c "Hewlett-Packard Company"
    11. SubDevice: pci 0x85b3
    12. Driver: "xhci_hcd"
    13. Driver Modules: "xhci_pci"
    14. Memory Range: 0xfc800000-0xfc8fffff (rw,non-prefetchable)
    15. IRQ: 24 (no events)
    16. Module Alias: "pci:v00001022d000015E1sv0000103Csd000085B3bc0Csc03i30"
    17. Driver Info #0:
    18. Driver Status: xhci_pci is active
    19. Driver Activation Cmd: "modprobe xhci_pci"
    20. Config Status: cfg=no, avail=yes, need=no, active=unknown
    21. Attached to: #19 (PCI bridge)
    22. 24: PCI 18.0: 0600 Host bridge
    23. [Created at pci.386]
    24. Unique ID: fiDB.+Xupf_VMM4C
    25. SysFS ID: /devices/pci0000:00/0000:00:18.0
    26. SysFS BusID: 0000:00:18.0
    27. Hardware Class: bridge
    28. Model: "AMD Raven/Raven2 Device 24: Function 0"
    29. Vendor: pci 0x1022 "AMD"
    30. Device: pci 0x15e8 "Raven/Raven2 Device 24: Function 0"
    31. Module Alias: "pci:v00001022d000015E8sv00000000sd00000000bc06sc00i00"
    32. Config Status: cfg=no, avail=yes, need=no, active=unknown
    33. 27: PCI 18.7: 0600 Host bridge
    34. [Created at pci.386]
    35. Unique ID: j_e1.cRV31_KI2mE
    36. SysFS ID: /devices/pci0000:00/0000:00:18.7
    37. SysFS BusID: 0000:00:18.7
    38. Hardware Class: bridge
    39. Model: "AMD Raven/Raven2 Device 24: Function 7"
    40. Vendor: pci 0x1022 "AMD"
    41. Device: pci 0x15ef "Raven/Raven2 Device 24: Function 7"
    42. Module Alias: "pci:v00001022d000015EFsv00000000sd00000000bc06sc00i00"
    43. Config Status: cfg=no, avail=yes, need=no, active=unknown
    44. 28: PCI 400.0: 0300 VGA compatible controller (VGA)
    45. [Created at pci.386]
    46. Unique ID: YmUS.RcUsV3lVLg8
    47. Parent ID: JZZT.A_VqgZKlSp2
    48. SysFS ID: /devices/pci0000:00/0000:00:08.1/0000:04:00.0
    49. SysFS BusID: 0000:04:00.0
    50. Hardware Class: graphics card
    51. Device Name: "Onboard IGD"
    52. Model: "ATI Picasso"
    53. Vendor: pci 0x1002 "ATI Technologies Inc"
    54. Device: pci 0x15d8 "Picasso"
    55. SubVendor: pci 0x103c "Hewlett-Packard Company"
    56. SubDevice: pci 0x85b3
    57. Revision: 0xc1
    58. Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
    59. Memory Range: 0xf0000000-0xf01fffff (ro,non-prefetchable)
    60. I/O Ports: 0xd000-0xd0ff (rw,disabled)
    61. Memory Range: 0xfcb00000-0xfcb7ffff (rw,non-prefetchable)
    62. IRQ: 255 (no events)
    63. Module Alias: "pci:v00001002d000015D8sv0000103Csd000085B3bc03sc00i00"
    64. Config Status: cfg=no, avail=yes, need=no, active=unknown
    65. Attached to: #19 (PCI bridge)
    Alles anzeigen
    Dort steht unter Punkt 28 "ATI Picasso". Könnte/sollte dies richtig erkannt worden sein?
    Gib es sonst noch eine Möglichkeit die GraKa eindeutig unter Leap zu identifizieren?
    Wenn die Eintragung unter der Hardware-Information mittels Yast (also ATI Picasso) richtig ist, welchen Grafiktreiber sollte ich dann verwenden?

    Danke schon mal im vorab
    Viele Grüße
    Günter

    Für den Inhalt des Beitrages 138763 haftet ausdrücklich der jeweilige Autor: musenkuss

  • Hallo Günter,

    ich würde es mal mit einem neueren Kernel versuchen.
    Repo hinzufügen (als Root mit User su):

    Quellcode

    1. zypper ar -f -p 20 https://download.opensuse.org/repositories/Kernel:/stable/standard/ kernel:stable
    Installation mit (als Root mit User su):

    Quellcode

    1. zypper -vv dup --allow-vendor-change --from kernel:stable

    Für den Inhalt des Beitrages 138765 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo Guenter,

    falls du X.org verwendest, schau mal ob

    Quellcode

    1. xf86-video-amdgpu

    installiert ist.

    ATI Picasso wird bei mir auch gelistet.
    AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx

    Für den Inhalt des Beitrages 138771 haftet ausdrücklich der jeweilige Autor: Rhiller

  • @ Rhiller:
    das rpm-Packet: xf86-video-amdgp wurde bereits bei der Erst-Installation aufgespielt. Jedoch zeigt dieses Paket keine Wirkung - leider.

    @ Sterun:
    Das Repository habe ich nachinstalliert. Jetzt habe ich eine Menge Auswahl an Kerneln
    Installiert ist:
    kernel-default -> 4.12.14
    kernel-firmware -> 20191118
    und
    ucode-amd -> 20191118

    welchen Kernel muss ich nehmen?
    Und (Holy Moly) wie kann man Kernel updaten?
    Hab mich an so ner Mammutaufgabe noch nicht herangewagt ( bin ein alter Nur-user) :rolleyes:

    Günter

    Für den Inhalt des Beitrages 138781 haftet ausdrücklich der jeweilige Autor: guenter57

  • Dann poste mal:

    Quellcode

    1. zypper lr -d
    ...klicke auf deinen "Start-Knopf" und dort findest du "Konsole".
    Dort gibst du den Befehl ein, bestätigst mit ENTER, kopierst dann alles und fügst es hier als Code-Tag ein (ist das Symbol </>, wenn du hier eine Antwort postest).

    @Sauerland
    Hast du bzgl. Ryzen 7 / Grafik eine bessere Idee, als einen neuen Kernel zu installieren?
    Habe selber nur einen i5 / 1. Generation :(

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 138783 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo sterum
    vielen Dank für deine Rückantwort.
    Hier die Ausgabe von zypper lr -d :

    Brainfuck-Quellcode

    1. guenter@linux-d2dc:~> zypper lr -d
    2. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    3. ---+-------------------------------------+------------------------------------+-----------+-----------------+----------------+-----------+--------+--------------------------------------------------------------------------------------+-------
    4. 1 | Kernel:stabel | Kernel:stabel | Ja | (r ) Ja | Ja | 20 | rpm-md | https://download.opensuse.org/repositories/Kernel:/stable/standard/ |
    5. 2 | http-download.opensuse.org-dc7aeeb2 | home:Sauerland | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/repositories/home:/Sauerland/openSUSE_Leap_15.1_Update/ |
    6. 3 | openSUSE-Leap-15.1-1 | openSUSE-Leap-15.1-1 | Ja | (r ) Ja | Nein | 99 | rpm-md | cd:/?devices=/dev/disk/by-id/usb-hp_DVDRW_DA8AESH_GTN02GTCVTZP-0:0 |
    7. 4 | packman.inode.at-suse | Packman Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://packman.inode.at/suse/openSUSE_Leap_15.1/ |
    8. 5 | repo-debug | Debug Repository | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/ |
    9. 6 | repo-debug-non-oss | Debug Repository (Non-OSS) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/ |
    10. 7 | repo-debug-update | Update Repository (Debug) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.1/oss/ |
    11. 8 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.1/non-oss/ |
    12. 9 | repo-non-oss | Non-OSS Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/ |
    13. 10 | repo-oss | Main Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/ |
    14. 11 | repo-source | Source Repository | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/ |
    15. 12 | repo-source-non-oss | Source Repository (Non-OSS) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/ |
    16. 13 | repo-update | Main Update Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/ |
    17. 14 | repo-update-non-oss | Update Repository (Non-Oss) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/ |
    18. 15 | repo-update_1 | Hauptaktualisierungs-Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/oss |
    19. guenter@linux-d2dc:~>
    Alles anzeigen

    Für den Inhalt des Beitrages 138784 haftet ausdrücklich der jeweilige Autor: musenkuss

  • 15 | repo-update_1 | Hauptaktualisierungs-Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | Index of /update/leap/15.1/oss |
    Das kann erst mal raus, ist doppelt.

    Dann die Frage:
    Warum mein /home-Repo:

    2 | http-download.opensuse.org-dc7aeeb2 | home:Sauerland | Ja | (r ) Ja | Ja | 99 | rpm-md | Index of /repositories/home:/Sauerland/openSUSE_Leap_15.1_Update |
    Ist bei kernel:stable nicht nötig.

    @sterun
    Ich würde es mit kernel:stable versuchen.
    Kann man ja immer noch wieder rückgängig machen.:
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 138787 haftet ausdrücklich der jeweilige Autor: Sauerland