Probleme mit Online-Aktualisierungen

Hinweis: In dem Thema Probleme mit Online-Aktualisierungen gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    seit einiger Zeit laufen bei mir die Online-Aktualisierungen nicht mehr fehlerfrei durch.

    Wenn ich es per zypper update versuche bekomme ich folgende Fehlermeldung, mit der ich nicht weiterkomme:


    Code
    Installation von kernel-syms-5.8.9-1.1.g52f63c2.x86_64 fehlgeschlagen:
    Fehler: Subprocess failed. Error: RPM fehlgeschlagen: error: unpacking of archive failed: cpio: Bad magic
    error: kernel-syms-5.8.9-1.1.g52f63c2.x86_64: install failed

    Hat jemand eine Idee, was ich tun kann? Sind weitere Infos erforderlich?


    Im Voraus vielen Dank für die Hilfe

    Für den Inhalt des Beitrages 283476 haftet ausdrücklich der jeweilige Autor: mini3475

  • Als Root (su) ausführen und anschl. erneut testen...

    Code
    rpm -vv --rebuilddb

    Ansonsten hier einmal posten:

    Code
    zypper lr -d

    Für den Inhalt des Beitrages 283479 haftet ausdrücklich der jeweilige Autor: sterun

  • Code
    rpm -vv --rebuilddb

    hat leider nichts geändert.


    und


    Für den Inhalt des Beitrages 283482 haftet ausdrücklich der jeweilige Autor: mini3475

  • Code
    2 | Virtualization | Virtualization (openSUSE_Leap_15.1) | Ja | (r ) Ja | Nein | 99 | rpm-md | http://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.1/ |

    Das solltest du aktivieren.

    Vorsicht:

    die kmps in dem Repo passen nicht zu kernel:stable.

  • Code
    rpm -iv https://download.opensuse.org/repositories/Kernel:/stable/standard/x86_64/kernel-syms-5.8.9-1.1.g52f63c2.x86_64.rpm
    Retrieving https://download.opensuse.org/repositories/Kernel:/stable/standard/x86_64/kernel-syms-5.8.9-1.1.g52f63c2.x86_64.rpm
    error: Failed dependencies:
    rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed by kernel-syms-5.8.9-1.1.g52f63c2.x86_64

    Für den Inhalt des Beitrages 283486 haftet ausdrücklich der jeweilige Autor: mini3475

  • Was meinst Du damit?


    Sorry für die doofe Frage

    Nun, wenn du virtualbox installieren möchtest, ist in dem Repo nur ein Kernel-Modul für kernel 4.12 und nicht für den bei dir laufenden Kernel 5.8........

  • Code
    rpmlib(PayloadIsZstd) <= 5.4.18-1 is needed by kernel-syms-5.8.9-1.1.g52f63c2.x86_64

    Und schon hat er wieder zugeschlagen:

    https://lists.opensuse.org/ope…ort/2020-08/msg00097.html

    https://bugzilla.suse.com/show_bug.cgi?id=1175810

    https://bugzilla.suse.com/show_bug.cgi?id=1175882


    Deswegen hab ich jetzt hier Leap 15.2 am laufen........