yast2 http-Server und letsencrypt

Hinweis: In dem Thema yast2 http-Server und letsencrypt gibt es 12 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    ich habe auf meinerm Leap 15.1 4 Webseiten am laufen.

    Per letsencrypt bekomme ich auch die SSL Zertifikate installiert.

    Habe das Ganze per Console zum Laufen gebracht. Mit certbot -renew werden auch abgelaufene Zertifikate erneuert.

    Im Ordner vhost.d befinden sich 2 Dateien

    - ip-based_vhosts.conf (für Port 80)

    - ip-based_vhosts-le-ssl.conf (für Port 443)

    In jeder Datei sind die 4 Seiten eingerichtet. Die Datei ip-based_vhosts.conf bräuchte ich eigentlich nicht mehr, da alle Anfragen auf Port 443 umgeleitet wird,


    Soweit funktioniert alles.


    Wenn ich aber nun yast2 http-Server starte, bekomme ich die Meldung das "ip-based_vhosts-le-ssl.conf" manuell erstellt wurde und wohl nicht mehr funktioniert.

    Tatsächlich werden die ssl vhosts nicht mehr angezeigt.

    Entferne ich "ip-based_vhosts.conf", bekomme ich wieder die selbe Meldung und der Bereich "Host" ist leer.


    Was habe ich am Apache falsch konfiguriert, obwohl alles funktioniert?


    Danke


    Gruß


    Edit: Die Datei "ip-based_vhosts-le-ssl.conf" wurde durch certbot erzeugt.

    Für den Inhalt des Beitrages 283732 haftet ausdrücklich der jeweilige Autor: jochene

  • Entweder du lernst, wie man bei Apache die Vhosts konfiguriert,

    oder du postest die relevanten Config- Dateien.


    Bislang kann man nur antworten, dass dein Fehler ein zu geringes Verständnis des Vhost- Config- Mechanismus beim Apache ist.

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 283740 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo,

    stimmt wohl, das mein Verständnis über vhost gering ist.

    Hatte die Hoffnung, hier einen neuen Ansatz zu finden.

    Obwohl es funktioniert, gefällt es mir nicht so richtig.

    Bin schon ein wenig älter und habe Props mit den fremdländischen Anleitungen.


    Aber OK, werde mich mal wieder auf die Suche begeben und hoffen etwas neues zu finden.


    Gruss

    Für den Inhalt des Beitrages 283742 haftet ausdrücklich der jeweilige Autor: jochene

  • Alter hilft nicht weiter.

    (Und ich bin wahrscheinlich etwas älter, als du. Hilft auch nicht.)


    Warum postest du nicht einfach alle relevanten Infos?

    Dann gibbet auch eine hilfreiche Antwort.


    Das darstellen samt allen nötigen Configs zu posten, verlangt jedes Support Forum.

    Weil Fragen, wie "was habe ich da falsch gemacht?" niemandem hilft.

    Information zur Sache und die tatsächlichen Configs - nicht irgendwelche Meinungen.

    Alles andere kannst du dir und uns ersparen.

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 283743 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Nnatürlich vor allem die Datei, die angeblich nicht funktionieren soll.

    Hast du die getestet?


    Und wenn das nicht hilft, alle anderen beteiligten Configs auch.


    Poste lieber das nächste Mal gleich alles, was du glaubst, dass wir lesen sollten.

    Nur wenn wir echte Configs haben, können wir helfen.

    Der Rest bleibt unfruchtbar Geschwätz.

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 283750 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Moin,


    hier der Inhalt der Datei, die nicht funktioniert im Yast. Der Apache funktioniert damit ohne Probleme, bzw. die Seite wird im Browser als "sicher" eingestuft. Aufrufe per http werden nach https umgeleitet.


    <IfModule mod_ssl.c>

    <VirtualHost *:443>

    DocumentRoot /srv/www/htdocs/XXXXX

    ServerName www.XXXXX.de

    ServerAdmin webmaster@XXXXX.de

    ServerAlias XXXXX *.XXXXX.de

    <Directory /srv/www/htdocs/XXXXX>

    AllowOverride All

    Require all granted

    DirectoryIndex index.html index.php

    </Directory>

    Include /etc/letsencrypt/options-ssl-apache.conf

    SSLCertificateFile /etc/letsencrypt/live/www.XXXXX.de/fullchain.pem

    SSLCertificateKeyFile /etc/letsencrypt/live/www.XXXXX.de/privkey.pem

    </VirtualHost>

    </IfModule>

    <IfModule mod_ssl.c>

    u.s.w. Für jede Website ein eigener Eintrag so wie oben.


    Gruß

    Für den Inhalt des Beitrages 283761 haftet ausdrücklich der jeweilige Autor: jochene

  • Wenn ich dich jetzt richtig verstanden habe, dann funktionieren ja alle TLS Verbindungen auf dem Standart- SSL-- Port.


    Womit sich die Frage stellt, ob du das wirklich ändern möchtest.

    Jede Änderung wird die Situation dann schlicht verschlechtern.


    Möchtest du ein wirklich ohne jede Warnungen und Meldungen laufendes Linux bleibt dir nur ein sehr spezifisch auf dich und deine Zwecke gebautes LFS. Viele Warnungen sind absichtlich und absichtlich harmlos. Sie sind gewollt. (und meist einfach abstellbar - wovon aber dringend abzuraten ist.)


    Was ist nun das eigentliche Problem?

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 283772 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Mein Problem ist eigentlich nur, das diese conf-Datei beim Aufruf vom "Yast Http-Server" ignoriert bzw.bei speichern vom "Yast Http-Server" gelöscht wird.

    Ich möchte gerne verstehen warum "Yast Http-Server" diese conf nicht mag.


    Danke

    Für den Inhalt des Beitrages 283773 haftet ausdrücklich der jeweilige Autor: jochene

  • Keine Ahnung.

    Ich verwende YaST kaum. (und statt Apache ausschließlich nginx)

    Fragen Sie Ihren Distributor.

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 283778 haftet ausdrücklich der jeweilige Autor: Berichtigung