Kann seit dem Upgrade auf Leap 15.2 meine Canon Kamera EOS 7 D nicht mehr anschließen

Hinweis: In dem Thema Kann seit dem Upgrade auf Leap 15.2 meine Canon Kamera EOS 7 D nicht mehr anschließen gibt es 5 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Früher konnte ich die Bilder meiner Kamera EOS 7D nach dem Anschluss über ein USB Kabel problemlos einlesen, weil OpenSuse 42.3 die Kamera als USB Laufwerk automatisch eingebunden hat. Vor einem halben Jahr habe ich den Notebook auf Opensuse 15.2 upgraded und nun bindet Linux die Kamera nicht mehr als USB Laufwerk ein sondern irgendwie anders.
    Unter zuletzt angeschlossene Geräte erscheint die Kamera und wenn ich die Option "Mit Dateimanager öffnen" aufrufe erscheint ein Ordner "Canon EOS 7D". Aber Bilder werden nicht angezeigt. Nach kurzer Zeit erhalte ich die Fehlermeldung "Lesen nicht möglich. Grund: konnte das USB Gerät nicht beanspruchen".


    Die Kamera ist eingebunden als Gerät "camera:/" und nicht als USB Laufwerk.


    Hier die Ausgabe von lsusb

    Wenn ich die Kamera mit digicam einbinden will, kommt nach dem Hinzufügen der Kamera beim testen die Fehlermeldung "Falscher Parameter" und danach "Kann USB Gerät nicht beanspruchen"


    Beim Import mit Gwenview ebenfalls "Kann USB Gerät nicht beanspruchen"


    An der Kamera kann es nicht liegen. Ich kann alle Bilder der Kamera an meinem Desktoprechner mit Opensuse Leap 15.2 als USB Device auslesen.

    Für den Inhalt des Beitrages 292043 haftet ausdrücklich der jeweilige Autor: rebell21

  • hier die Ausgaben von gphoto2

    Code
    peter@localhost:~> gphoto2 --auto-detect
    Modell Port
    ----------------------------------------------------------
    Canon EOS 7D usb:002,015

    Für den Inhalt des Beitrages 292046 haftet ausdrücklich der jeweilige Autor: rebell21

  • Kamera ab, Im Terminal als root:

    Code
    journalctl -f

    Kamera anstöpseln und alle neu hinzugekommenen Meldungen hier posten.


    Dasselbe kannst du auch auf dem Rechner machen, auf dem es funktioniert, evtl gibt es ja Unterschied.

    Für den Inhalt des Beitrages 292052 haftet ausdrücklich der jeweilige Autor: Sauerland

  • nach einschalten der Kamera kommt aus journatctl


    Code
    Jul 31 19:06:40 localhost.localdomain su[23222]: pam_unix(su:session): session opened for user root by peter(uid=1000)
    Jul 31 19:07:08 localhost.localdomain kernel: usb 1-1.2: new high-speed USB device number 9 using ehci-pci
    Jul 31 19:07:08 localhost.localdomain kernel: usb 1-1.2: New USB device found, idVendor=04a9, idProduct=319a, bcdDevice= 0.02
    Jul 31 19:07:08 localhost.localdomain kernel: usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
    Jul 31 19:07:08 localhost.localdomain kernel: usb 1-1.2: Product: Canon Digital Camera
    Jul 31 19:07:08 localhost.localdomain kernel: usb 1-1.2: Manufacturer: Canon Inc.
    Jul 31 19:07:08 localhost.localdomain mtp-probe[23300]: checking bus 1, device 9: "/sys/devices/pci0000:00/0000:00:1a.0/usb1/1-1/1-1.2"
    Jul 31 19:07:08 localhost.localdomain mtp-probe[23300]: bus: 1, device: 9 was not an MTP device

    Für den Inhalt des Beitrages 292053 haftet ausdrücklich der jeweilige Autor: rebell21

  • perfekt das war die Lösung


    ich habe eine Datei 90-myrules.rules in /etc/udev/rules.d mit folgendem Inhalt angelegt


    Code
    SUBSYSTEMS=="usb", ENV{MODALIAS}=="usb:04a9:319a", ENV{MODALIAS}="usb-storage"

    Nach einem Neustart wird die Kamera und ihr Speicher als USB Laufwerk eingebunden und ich kann mit Dolphin Bilder importieren

    Danke

    Für den Inhalt des Beitrages 292056 haftet ausdrücklich der jeweilige Autor: rebell21