Kein Start aus Ruhezustand nach Update auf Opensuse Leap 15.3

Hinweis: In dem Thema Kein Start aus Ruhezustand nach Update auf Opensuse Leap 15.3 gibt es 10 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo zusammen,

    die Suche im Forum hat mir nicht geholfen. Sollte es für mein Problem doch schon eine Antwort geben freue ich mich auch über einen Link dorthin oder ein besseres Suchmuster als "Ruhezustand".


    Unter Opensuse Leap 15.1 hatte der Ruhezustand sehr schön funktioniert. Dann habe ich ein Update auf Opensuse Leap 15.3 gemacht, Hardware ist unverändert. Im Menü Energieverwaltung/Sitzung ist der Ruhezustand weiterhin vorhanden. Schicke ich den Rechner damit in den Ruhezustand tut er das auch. Die init 0 Prozeduren werden nicht durchlaufen, nach kurzer Zeit geht der Rechner aus.


    Aber beim erneuten Einschalten fährt er ganz normal hoch, als wenn ich ihn runtergefahren hätte. Die ganzen init Prozeduren werden durchlaufen, uptime zeigt 1 Minute an :(

    Hier noch der optionale Parameter für die Kernel Befehlszeile:

    Code
    splash=silent resume=/dev/sda6

    Für den Inhalt des Beitrages 293353 haftet ausdrücklich der jeweilige Autor: mathias61

  • Unter Opensuse Leap 15.1 hatte der Ruhezustand sehr schön funktioniert. Dann habe ich ein Update auf Opensuse Leap 15.3 gemacht,

    Direkt von openSUSE Leap 15.1 auf Version 15.3? Kann klappen, muss aber nicht.

    Zitat

    Warning: Do not skip a release when upgrading! Example: do not upgrade from 15.1 to 15.3. Instead, from 15.1 upgrade to 15.2, and only then from 15.2 to upgrade to 15.3.


    Quelle: https://en.opensuse.org/SDB:System_upgrade


    Zum Thema:

    Poste doch mal als Root:

    Code
    journalctl -b 0 -p err


    Und die neue Repoliste:

    Code
    zypper lr -d


    Was war denn vorher anders? Bessere Bootzeit aus dem Ruhezustand? Nicht, dass Standby u. Ruhezustand verwechselt werden. Standby ist deutlich schneller, aber der Ruhezustand fährt den PC herunter.


    Als Root den Ruhezustand mit...

    Code
    systemctl hibernate

    ...auch mal manuell testen und anschl. hier als Root posten...

    Code
    journalctl -b 0 -p err

    ...wenn er wieder hochgefahren ist.

    2 Mal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 293389 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo sterun,


    Danke sehr für Deine Antwort.

    Ja, von 15.1 habe ich das Update direkt nach 15.3 gemacht. Die Warnung habe ich leider übersehen.


    Standby nutze ich gar nicht, weil ich den Rechner immer mit Schalterleiste vom Strom trennen will.


    Aus dem Ruhezustand war er früher deutlich schneller wieder da, als er es jetzt nach einem Neustart ist. Gefühlt war auch der Neustart unter 15.1 etwas schneller, als unter 15.3. Oder vielleicht habe ich mich auch einfach nur an den schnellen Start aus dem Ruhezustand gewöhnt. Beide Zeiten vor dem Update habe ich leider nicht gestoppt.


    Die Ausgaben von zypper lr -d und den beiden journalctl -b 0 -p err füge ich als Anlagen bei. Das ist hoffentlich ok.



    Ruhezustand mit systemctl hibernate:

    Er bootet neu.

    1:03 Minuten von der ersten Grub Meldung bis zum Loginfenster (also ohne die Zeit des Bios).

    44 Sekunden von der Passworteingabe bis der KDE Desktop bereit ist (aufgebaut werden 3 xterm, 2 dolphin, Systemmonitor und ein Firefox, meine Standardprogramme). Auch dies war nach dem Ruhezustand deutlich schneller.


    journalctl -b 0 -p err > journalctl.systemctlHibernate.txt



    Ruhezustand manuell (über das KDE Menü)

    Vorführeffekt: Es hat jetzt funktioniert. Hoffentlich bleibt das so.

    Bios bis login: 20 Sekunden

    Passwort bis fertiger Desktop 2 Sekunden.


    journalctl -b 0 -p err > journalctl.manuell.txt



    Und wenn gar nix hilft mache ich im nächsten Urlaube eine Neuininstallation.


    LG

    Mathias

  • Hallo Mathias


    Doppeltes Repo, nicht schlimm, trotzdem mal löschen - dient der Übersichtlichkeit:

    Code
    zypper rr "openSUSE-Leap-15.3-1"


    Source und Debug Repos ebenfalls, wenn du diese nicht benötigst (dient auch nur der Übersichtlichkeit):

    Code
    zypper rr "repo-debug"
    Code
    zypper rr "repo-debug-non-oss"
    Code
    zypper rr "repo-debug-update"
    Code
    zypper rr "repo-debug-update-non-oss"
    Code
    zypper rr "repo-source"


    Danach einmal zeigen:

    Code
    uname -a
    Code
    systemctl --failed
    Code
    systemd-analyze blame
    Code
    systemd-analyze critical-chain

    Versuch mal bitte, Konsolenausgaben, vom eigegebenen Befehl bis zum Ende der Ausgabe, als Code-Tags zu posten. Ist besser lesbar:

    ------------------------------------------------

    Verwendung des Editors im Forum

    ------------------------------------------------

    Für den Inhalt des Beitrages 293436 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo sterun,



    heute ist das System auch wieder schnell aus dem Ruhezustand gestartet. Drück mir die Daumen, dass es so bleibt.



    Trotzdem habe ich danach die von Dir genannten Repos entfernt, jetzt sind noch 6 übrig. Wenn davon etwas fehlen sollte wird es wohl auffallen. Außer der mitgelieferten Software nutze ich hier nur vmplayer.



    Hier kommen die weiteren Ausgaben:


    Fortsetzung in nächster Nachricht, da max 10000 Zeichen möglich sind.

    Für den Inhalt des Beitrages 293489 haftet ausdrücklich der jeweilige Autor: mathias61

  • Danke sehr für die Hilfe und schönen Abend

    Mathias

    Für den Inhalt des Beitrages 293490 haftet ausdrücklich der jeweilige Autor: mathias61

  • Nachtrag, da ich leider vorerst offline bin...


    Mit meiner letzten Frage (fdisk) wollte ich kontrollieren, ob du mit Logical Volumes arbeitest. Wenn nicht, kann der "lvm2-monitor.service" zu einem verzögerten Boot- und Shutdown beitragen. Solltest du "postfix" und "iscsi" nicht nutzen, lohnt es sich, diese ebenfalls zu deaktivieren.


    Als Root stoppen und deaktivieren wir folgende Services:


    Logical Volumes:

    Code
    systemctl stop lvm2-monitor.service
    Code
    systemctl disable lvm2-monitor.service


    Postfix:

    Code
    systemctl stop postfix.service
    Code
    systemctl disable postfix.service


    iscsi:

    Code
    systemctl stop iscsi.service
    Code
    systemctl disable iscsi.service


    Anschl. einmal Neustart, testen und berichten.

    Für den Inhalt des Beitrages 293503 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo sterun,


    heute hat der Start aus dem Ruhezustand auch wieder funktioniert, so kann es bleiben :-)

    lvn nutze ich (meines Wissens) nicht.


    Code
    init 6

    Nach dem Neustart sind die 3 Services weiterhin disabled:

    Der Rechner scheint normal zu laufen.

    In den Ruhezustand und wieder starten:

    Zeit von nach dem BIOS bis zum fertigen Desktop: 29 Sekunden :-)


    Schönen Abend
    Mathias

    Für den Inhalt des Beitrages 293564 haftet ausdrücklich der jeweilige Autor: mathias61

  • Sieht alles sauber aus. Wenn der Ruhezustand jetzt funktioniert und als Nebeneffekt die Bootzeit halbiert wurde, sind wir hier durch. Wenn dem so ist, kannst du deine Anfrage noch als "erledigt" markieren. Das machst du mit einem Doppelklick in das "Unerledigt" Kästchen - ganz oben unter deiner Themenüberschrift :-)

    Für den Inhalt des Beitrages 293566 haftet ausdrücklich der jeweilige Autor: sterun