Nach Update startet mysqld nicht mehr

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Nach Update startet mysqld nicht mehr gibt es 29 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Nach Update startet mysqld nicht mehr

    Hallo,
    bei mir läuft seit einem guten Jahr OpenSuSE 12.1 mit KDE4.8 recht stabil (KDE mit Akonadi mucken immer mal 'rum) ; verwendet wird mysql-community-server_56.

    Seit einem letzten (umfangreichen) Update, der auch mysql-Pakete enthielt, startet mysql nicht mehr und Akonadi verweigert (mal wieder) den Dienst. Bis auf das Update habe ich nichts im System geändert. All meine Versuche, mysql zu starten, scheiterten, und die Web-Suche ergab fast nur 'was für den Client.

    Ich erhalte als root

    Quellcode

    1. # rcmysql start
    2. redirecting to systemctl
    3. Job failed. See system logs and 'systemctl status' for details.


    und

    Quellcode

    1. # rcmysql status
    2. redirecting to systemctl
    3. mysql.service - LSB: Start the MySQL database server
    4. Loaded: loaded (/etc/init.d/mysql)
    5. Active: failed since Sat, 19 Jan 2013 15:22:53 +0100; 1min 16s ago
    6. Process: 29631 ExecStart=/etc/init.d/mysql start (code=exited, status=1/FAILURE)
    7. CGroup: name=systemd:/system/mysql.service


    und

    Quellcode

    1. mysqld_safe
    2. 130119 15:32:37 mysqld_safe Logging to '/var/log/mysql/mysqld.log'.
    3. 130119 15:32:37 mysqld_safe Starting mysqld daemon with databases from /var/lib/mysql
    4. 130119 15:32:39 mysqld_safe mysqld from pid file /var/lib/mysql/koto.pid ended


    und als user

    Quellcode

    1. /usr/sbin/mysqld
    2. 130119 15:34:43 [ERROR] Error message file '/usr/share/mysql/english/errmsg.sys' had only 728 error messages,
    3. but it should contain at least 762 error messages.
    4. Check that the above file is the right version for this program!
    5. ...


    Hier ist auch die einzige Fehlermeldung zu lesen, die ich finden konnte. Wo bekomme ich jetzt eine korrekte mysql/english/errmsg.sys her? Auch /var/log/mysql/mysqld.log enthält nur diesen Fehler

    Es erscheint auch keine mysql.sock Nach /etc/my.conf:

    Quellcode

    1. # Example MySQL config file for medium systems.
    2. #
    3. # This is for a system with little memory (32M - 64M) where MySQL plays
    4. # an important part, or systems up to 128M where MySQL is used together with
    5. # other programs (such as a web server)
    6. #
    7. # MySQL programs look for option files in a set of
    8. # locations which depend on the deployment platform.
    9. # You can copy this option file to one of those
    10. # locations. For information about these locations, see:
    11. # http://dev.mysql.com/doc/mysql/en/option-files.html
    12. #
    13. # In this file, you can use all long options that a program supports.
    14. # If you want to know which options a program supports, run the program
    15. # with the "--help" option.
    16. # The following options will be passed to all MySQL clients
    17. [client]
    18. #password = your_password
    19. port = 3306
    20. socket = /var/run/mysql/mysql.sock
    21. # Here follows entries for some specific programs
    22. # The MySQL server
    23. [mysqld]
    24. port = 3306
    25. socket = /var/run/mysql/mysql.sock
    26. # Change following line if you want to store your database elsewhere
    27. datadir = /var/lib/mysql
    28. skip-external-locking
    29. key_buffer_size = 16M
    30. max_allowed_packet = 5M
    31. table_open_cache = 128
    32. sort_buffer_size = 512K
    33. net_buffer_length = 8K
    34. read_buffer_size = 256K
    35. read_rnd_buffer_size = 512K
    36. myisam_sort_buffer_size = 8M
    37. # Don't listen on a TCP/IP port at all. This can be a security enhancement,
    38. # if all processes that need to connect to mysqld run on the same host.
    39. # All interaction with mysqld must be made via Unix sockets or named pipes.
    40. # Note that using this option without enabling named pipes on Windows
    41. # (via the "enable-named-pipe" option) will render mysqld useless!
    42. #
    43. #skip-networking
    44. # Replication Master Server (default)
    45. # binary logging is required for replication
    46. log-bin=mysql-bin
    47. # binary logging format - mixed recommended
    48. binlog_format=mixed
    49. # required unique id between 1 and 2^32 - 1
    50. # defaults to 1 if master-host is not set
    51. # but will not function as a master if omitted
    52. server-id = 1
    53. # Replication Slave (comment out master section to use this)
    54. #
    55. # To configure this host as a replication slave, you can choose between
    56. # two methods :
    57. #
    58. # 1) Use the CHANGE MASTER TO command (fully described in our manual) -
    59. # the syntax is:
    60. #
    61. # CHANGE MASTER TO MASTER_HOST=<host>, MASTER_PORT=<port>,
    62. # MASTER_USER=<user>, MASTER_PASSWORD=<password> ;
    63. #
    64. # where you replace <host>, <user>, <password> by quoted strings and
    65. # <port> by the master's port number (3306 by default).
    66. #
    67. # Example:
    68. #
    69. # CHANGE MASTER TO MASTER_HOST='125.564.12.1', MASTER_PORT=3306,
    70. # MASTER_USER='joe', MASTER_PASSWORD='secret';
    71. #
    72. # OR
    73. #
    74. # 2) Set the variables below. However, in case you choose this method, then
    75. # start replication for the first time (even unsuccessfully, for example
    76. # if you mistyped the password in master-password and the slave fails to
    77. # connect), the slave will create a master.info file, and any later
    78. # change in this file to the variables' values below will be ignored and
    79. # overridden by the content of the master.info file, unless you shutdown
    80. # the slave server, delete master.info and restart the slaver server.
    81. # For that reason, you may want to leave the lines below untouched
    82. # (commented) and instead use CHANGE MASTER TO (see above)
    83. #
    84. # required unique id between 2 and 2^32 - 1
    85. # (and different from the master)
    86. # defaults to 2 if master-host is set
    87. # but will not function as a slave if omitted
    88. #server-id = 2
    89. #
    90. # The replication master for this slave - required
    91. #master-host = <hostname>
    92. #
    93. # The username the slave will use for authentication when connecting
    94. # to the master - required
    95. #master-user = <username>
    96. #
    97. # The password the slave will authenticate with when connecting to
    98. # the master - required
    99. #master-password = <password>
    100. #
    101. # The port the master is listening on.
    102. # optional - defaults to 3306
    103. #master-port = <port>
    104. #
    105. # binary logging - not required for slaves, but recommended
    106. #log-bin=mysql-bin
    107. # Uncomment the following if you are using InnoDB tables
    108. #innodb_data_home_dir = /var/lib/mysql
    109. #innodb_data_file_path = ibdata1:10M:autoextend
    110. #innodb_log_group_home_dir = /var/lib/mysql
    111. # You can set .._buffer_pool_size up to 50 - 80 %
    112. # of RAM but beware of setting memory usage too high
    113. #innodb_buffer_pool_size = 16M
    114. #innodb_additional_mem_pool_size = 2M
    115. # Set .._log_file_size to 25 % of buffer pool size
    116. #innodb_log_file_size = 5M
    117. #innodb_log_buffer_size = 8M
    118. #innodb_flush_log_at_trx_commit = 1
    119. #innodb_lock_wait_timeout = 50
    120. # The safe_mysqld script
    121. [safe_mysqld]
    122. log-error = /var/log/mysql/mysqld.log
    123. socket = /var/run/mysql/mysql.sock
    124. [mysqldump]
    125. socket = /var/run/mysql/mysql.sock
    126. quick
    127. max_allowed_packet = 16M
    128. [code=sql]
    129. no-auto-rehash
    130. # Remove the next comment character if you are not familiar with SQL
    131. #safe-updates
    132. [myisamchk]
    133. key_buffer_size = 20M
    134. sort_buffer_size = 20M
    135. read_buffer = 2M
    136. write_buffer = 2M
    137. [mysqlhotcopy]
    138. interactive-timeout
    139. [mysqld_multi]
    140. mysqld = /usr/bin/mysqld_safe
    141. mysqladmin = /usr/bin/mysqladmin
    142. log = /var/log/mysqld_multi.log
    143. # user = multi_admin
    144. # password = secret
    145. # If you want to use mysqld_multi uncomment 1 or more mysqld sections
    146. # below or add your own ones.
    147. # WARNING
    148. # --------
    149. ...
    Alles anzeigen

    Der simple Versuch aus einem Backup eine socket ins Verzeichnis zu linken, endete mit dem löschen des links. Es passiert also irgendwas. Nur eine neue socket wurde nicht erzeugt.
    Schon mal Dankeschön

    Für den Inhalt des Beitrages 51069 haftet ausdrücklich der jeweilige Autor: Koto

  • Koto schrieb:


    130119 15:34:43 [ERROR] Error message file '/usr/share/mysql/english/errmsg.sys' had only 728 error messages,
    but it should contain at least 762 error messages.
    Check that the above file is the right version for this program!

    Also das bedeutet schon mal das der Message Text File (wo der Text von MySQL Fehlermeldungen drin steht) nicht die richtige Version ist.
    Da das eine ziemlich elementare Datei darstellt, wuerde ich mal raten das das Upgrade von deiner MySQL Installation nur teilweise erfolgreich war.
    Mein Ratschlag daher MySQL neu zu installieren und zu sehen ob das den Fehler beseitigt.

    Check auch mal den Status des entsprechenden Service (systemctl status)und Fehlermeldungen im syslog (dmesg).

    Für den Inhalt des Beitrages 51072 haftet ausdrücklich der jeweilige Autor: Gondwana

  • Poste bitte einmal

    Quellcode

    1. zypper se -si mysql

    Quellcode

    1. zypper lr -uP


    da:
    verwendet wird mysql-community-server_56.

    und hier:

    Quellcode

    1. i | mysql-community-server | Paket | 5.5.28-1.4.1 | x86_64 | openSUSE-12.2-Update
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 51087 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo! Wow!

    Das ging schnell, vielen Dank nochmal.

    Ja, ich fand mit Yast schon eine andere Version, die aber nichts half. Zur Zeit traue ich mich kaum noch, ein Update durchzuführen, weil hinterher irgendwas nicht klappt. Hier der erste Befehl:

    Brainfuck-Quellcode

    1. zypper se -si mysql
    2. Daten des Repositories laden ...
    3. Installierte Pakete lesen ...
    4. S | Name | Typ | Version | Arch | Repository
    5. --+--------------------------------------+-------+---------------------------+--------+--------------------------------------------
    6. i | calligra-kexi-mysql-driver | Paket | 2.5.93git.1357739922-13.1 | x86_64 | (Systempakete)
    7. i | libmysql56client18 | Paket | 5.6.4-2.1 | x86_64 | openSUSE BuildService - Datenbank
    8. i | libmysql56client_r18 | Paket | 5.6.4-2.1 | x86_64 | openSUSE BuildService - Datenbank
    9. i | libmysqlclient-devel | Paket | 5.5.29-109.1 | x86_64 | (Systempakete)
    10. i | libmysqlclient18 | Paket | 5.5.29-109.1 | x86_64 | (Systempakete)
    11. i | libmysqlclient18-32bit | Paket | 5.5.29-109.1 | x86_64 | (Systempakete)
    12. i | libmysqlclient_r18 | Paket | 5.5.29-109.1 | x86_64 | (Systempakete)
    13. i | libmysqld18 | Paket | 5.5.29-109.1 | x86_64 | (Systempakete)
    14. i | libqt4-sql-mysql | Paket | 4.8.4-286.1 | x86_64 | KDE 4.8 Kern
    15. i | libqt4-sql-mysql-32bit | Paket | 4.8.4-286.1 | x86_64 | KDE 4.8 Kern
    16. i | libreoffice-base-drivers-mysql | Paket | 3.5.4.13-4.11.1 | x86_64 | Aktualisierungen für openSUSE 12.1 12.1-1.4
    17. i | libreoffice-base-drivers-mysql | Paket | 3.5.4.13-4.11.1 | x86_64 | openSUSE:12.1:Update
    18. i | mysql-community-server-errormessages | Paket | 5.5.28-3.14.1 | x86_64 | Aktualisierungen für openSUSE 12.1 12.1-1.4
    19. i | mysql-community-server-errormessages | Paket | 5.5.28-3.14.1 | x86_64 | openSUSE:12.1:Update
    20. i | mysql-community-server_56 | Paket | 5.6.4-2.1 | x86_64 | openSUSE BuildService - Datenbank
    21. i | mysql-community-server_56-bench | Paket | 5.6.4-2.1 | x86_64 | openSUSE BuildService - Datenbank
    22. i | mysql-community-server_56-client | Paket | 5.6.4-2.1 | x86_64 | openSUSE BuildService - Datenbank
    23. i | mysql-community-server_56-test | Paket | 5.6.4-2.1 | x86_64 | openSUSE BuildService - Datenbank
    24. i | mysql-community-server_56-tools | Paket | 5.6.4-2.1 | x86_64 | openSUSE BuildService - Datenbank
    25. i | mysql-connector-java | Paket | 5.1.6-14.9 | noarch | openSUSE BuildService - Java-Pakete
    26. i | mysql-connector-java-javadoc | Paket | 5.1.6-14.9 | noarch | openSUSE BuildService - Java-Pakete
    27. i | mysql-connector-java-manual | Paket | 5.1.6-14.9 | noarch | openSUSE BuildService - Java-Pakete
    28. i | mysql-workbench | Paket | 5.2.44-52.4 | x86_64 | openSUSE BuildService - Datenbank
    29. i | perl-DBD-mysql | Paket | 4.020-2.1.4 | x86_64 | openSUSE-12.1-Oss
    30. i | perl-DBD-mysql | Paket | 4.020-2.1.4 | x86_64 | openSUSE-12.1-12.1-1.4
    31. i | perl-DateTime-Format-MySQL | Paket | 0.04-3.1.3 | noarch | openSUSE-12.1-Oss
    32. i | php5-mysql | Paket | 5.3.17-145.1 | x86_64 | openSUSE BuildService - PHP
    33. i | php5-pear-MDB2_Driver_mysql | Paket | 1.4.1-6.1.1 | noarch | openSUSE-12.1-Oss
    34. i | php5-pear-MDB2_Driver_mysqli | Paket | 1.4.1-6.1.1 | noarch | openSUSE-12.1-Oss
    35. i | python-mysql | Paket | 1.2.3-6.1.3 | x86_64 | openSUSE-12.1-Oss
    36. i | rsyslog-module-mysql | Paket | 5.10.1-6.15.1 | x86_64 | Aktualisierungen für openSUSE 12.1 12.1-1.4
    37. i | rsyslog-module-mysql | Paket | 5.10.1-6.15.1 | x86_64 | openSUSE:12.1:Update
    38. i | rubygem-mysql | Paket | 2.8.1-3.1.2 | x86_64 | openSUSE-12.1-Oss
    39. i | rubygem-mysql | Paket | 2.8.1-3.1.2 | x86_64 | openSUSE-12.1-12.1-1.4
    Alles anzeigen

    Für den Inhalt des Beitrages 51127 haftet ausdrücklich der jeweilige Autor: Koto

  • Und hier die Repos:

    Brainfuck-Quellcode

    1. zypper lr -uP
    2. # | Alias | Name | Aktiviert | Aktualisieren | Priorität | URI
    3. ---+-------------------------------------------------+-------------------------------------------------+-----------+---------------+-----------+-----------------------------------------------------------------------------------------------------
    4. 1 | Aktualisierungen-für-openSUSE-12.1-12.1-1.4 | Aktualisierungen für openSUSE 12.1 12.1-1.4 | Ja | Ja | 99 | http://download.opensuse.org/update/12.1/
    5. 2 | Documentation:Tools | Documentation:Tools | Ja | Ja | 99 | http://download.opensuse.org/repositories/Documentation:/Tools/openSUSE_12.1/
    6. 3 | KDE_4.8_Extra | KDE 4.8 Extra | Ja | Ja | 99 | http://download.opensuse.org/repositories/KDE:/Extra/KDE_Release_48_openSUSE_12.1/
    7. 4 | KDE_4.8_Kern | KDE 4.8 Kern | Ja | Ja | 99 | http://download.opensuse.org/repositories/KDE:/Release:/48/openSUSE_12.1
    8. 5 | KDE_4.8_unstable | KDE 4.8 unstable | Nein | Ja | 99 | http://download.opensuse.org/repositories/KDE:/Unstable:/Playground/KDE_Release_48_openSUSE_12.1/
    9. 6 | M17N:fonts | M17N:fonts | Ja | Ja | 99 | http://download.opensuse.org/repositories/M17N:/fonts/openSUSE_12.1/
    10. 7 | Packman | Packman | Ja | Ja | 99 | ftp://ftp.gwdg.de/pub/linux/misc/packman/suse/12.1/
    11. 8 | Publishing | Publishing | Ja | Ja | 99 | http://download.opensuse.org/repositories/Publishing/openSUSE_12.1/
    12. 9 | download.nvidia.com-opensuse | nVidia Graphics Drivers | Ja | Ja | 99 | ftp://download.nvidia.com/opensuse/12.1/
    13. 10 | download.opensuse.org-Education | openSUSE BuildService - Bildungswesen | Ja | Ja | 99 | http://download.opensuse.org/repositories/Education/openSUSE_12.1/
    14. 11 | download.opensuse.org-Stable | openSUSE BuildService - LibreOffice | Ja | Ja | 99 | http://download.opensuse.org/repositories/LibreOffice:/Stable/openSUSE_12.1/
    15. 12 | download.opensuse.org-database | openSUSE BuildService - Datenbank | Ja | Ja | 99 | http://download.opensuse.org/repositories/server:/database/openSUSE_12.1/
    16. 13 | download.opensuse.org-games | openSUSE BuildService - Spiele | Ja | Ja | 99 | http://download.opensuse.org/repositories/games/openSUSE_12.1/
    17. 14 | download.opensuse.org-mozilla | openSUSE BuildService - Mozilla | Ja | Ja | 99 | http://download.opensuse.org/repositories/mozilla/openSUSE_12.1/
    18. 15 | download.opensuse.org-oss | Haupt-Repository (Quellen) | Ja | Ja | 99 | http://download.opensuse.org/source/distribution/12.1/repo/oss/
    19. 16 | download.opensuse.org-packages | openSUSE BuildService - Java-Pakete | Ja | Ja | 99 | http://download.opensuse.org/repositories/Java:/packages/openSUSE_12.1/
    20. 17 | download.opensuse.org-php | openSUSE BuildService - PHP | Ja | Ja | 99 | http://download.opensuse.org/repositories/server:/php/openSUSE_12.1/
    21. 18 | google-earth | google-earth | Ja | Ja | 99 | http://dl.google.com/linux/earth/rpm/stable/x86_64
    22. 19 | home:ailin_nemui:branches:home:koprok:base-11.4 | home:ailin_nemui:branches:home:koprok:base-11.4 | Nein | Nein | 99 | http://download.opensuse.org/repositories/home:/ailin_nemui:/branches:/home:/koprok:/base-11.4/12.1/
    23. 20 | home:ecsos | home:ecsos | Ja | Ja | 99 | http://download.opensuse.org/repositories/home:/ecsos/openSUSE_12.1/
    24. 21 | home:koprok:base-12.1 | home:koprok:base-12.1 | Ja | Ja | 99 | http://download.opensuse.org/repositories/home:/koprok:/base-12.1/standard/
    25. 22 | isv:ownCloud:community | isv:ownCloud:community | Ja | Ja | 99 | http://download.opensuse.org/repositories/isv:/ownCloud:/community/openSUSE_12.1/
    26. 23 | isv:ownCloud:devel | isv:ownCloud:devel | Ja | Ja | 99 | http://download.opensuse.org/repositories/isv:/ownCloud:/devel/openSUSE_12.1/
    27. 24 | isv:ownCloud:ownCloud2012 | isv:ownCloud:ownCloud2012 | Ja | Ja | 99 | http://download.opensuse.org/repositories/isv:/ownCloud:/ownCloud2012/openSUSE_12.1/
    28. 25 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Ja | Nein | 99 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_DVDWBD_SH-B123L_R8496GHZC12349,/dev/sr0
    29. 26 | openSUSE:12.1:Update | openSUSE:12.1:Update | Ja | Ja | 99 | http://download.opensuse.org/update/12.1/
    30. 27 | opensuse-guide.org-repo | libdvdcss repository | Ja | Ja | 99 | http://opensuse-guide.org/repo/12.1/
    31. 28 | repo-debug | openSUSE-12.1-Debug | Nein | Ja | 99 | http://download.opensuse.org/debug/distribution/12.1/repo/oss/
    32. 29 | repo-debug-update | openSUSE-12.1-Update-Debug | Nein | Ja | 99 | http://download.opensuse.org/debug/update/12.1/
    33. 30 | repo-non-oss | openSUSE-12.1-Non-Oss | Ja | Ja | 99 | http://download.opensuse.org/distribution/12.1/repo/non-oss/
    34. 31 | repo-oss | openSUSE-12.1-Oss | Ja | Ja | 99 | http://download.opensuse.org/distribution/12.1/repo/oss/
    35. 32 | repo-source | openSUSE-12.1-Source | Nein | Ja | 99 | http://download.opensuse.org/source/distribution/12.1/repo/oss/
    Alles anzeigen

    Für den Inhalt des Beitrages 51128 haftet ausdrücklich der jeweilige Autor: Koto

  • Koto schrieb:

    Hallo! Wow!

    Das ging schnell, vielen Dank nochmal.

    Ja, ich fand mit Yast schon eine andere Version, die aber nichts half. Zur Zeit traue ich mich kaum noch, ein Update durchzuführen, weil hinterher irgendwas nicht klappt. Hier der erste Befehl:


    Also da musst du nicht so viel Angst haben, das mit den Updates funzt normalerweise schon OK, solange die Repo Liste richtig eingerichtet wurde.
    Bei deinen Ausgaben faellt mir folgendes auf:
    mysql-community-server-errormessages -> 5.5.28-3.14.1 -> Repo: openSUSE:12.1:Update
    mysql-community-server_56 -> 5.6.4-2.1 -> Repo: openSUSE BuildService - Datenbank

    Das sieht fuer mich danach als ob du den Server mit einer Version aus einerm Repo und die dazugehoerigen Error Messages mit einer anderen Version aus einem anderen Repo installiert hast.
    Das wuerde zumindest schon mal die Fehlermeldung erklaeren welche du beim Start des Servers bekommst.
    Generel gesehen scheint die Liste bei dir aus vielen verschiedenen Repos gezogen worden zu sein, und ich denke mir mal das haengt damit zusammen das deine Repositories alle die gleiche Prioritaet haben.

    Wenn das der Fall ist, dann ist es nicht vorhersagbar aus welchem Repo ein Paket waehrend eines Update Vorgangs gezogen wird - was im Zweifelsfall dazu fuehren kann das miteinander inkompatible Pakete installiert werden.

    Lies dir mal diese beiden Links durch, und danach kannst du einen der alteingesessenen im Forum fragen falls du noch mehr Details zu Repositoryliste hast:
    foertsch.name/Artikel/yast-10-3-repository-order.shtml
    linupedia.org/opensuse/Zypper

    Also jetzt erst mal deine Repo Liste auf Vordermann bringen, danach die MySQL relevanten Pakete nochmal installieren und dann sollte alles funktionieren.

    Für den Inhalt des Beitrages 51133 haftet ausdrücklich der jeweilige Autor: Gondwana

  • Gondwana schrieb:

    Lies dir mal diese beiden Links durch, und danach kannst du einen der alteingesessenen im Forum fragen falls du noch mehr Details zu Repositoryliste hast:
    foertsch.name/Artikel/yast-10-3-r…ory-order.shtml
    linupedia.org/opensuse/Zypper

    Der erste Link ist ja wohl out-of-date.
    Das kann man per Yast----Repositoryverwaltung oder zypper mr -p xx ändern.

    An den Prioritäten sollte wirklich mal gearbeitet werden, sowie auch an den Repos.

    Wie sind die alle hereingekommen?
    Brauchst Du die alle?
    19 | home:ailin_nemui:branches:home:koprok:base-11.4 | home:ailin_nemui:branches:home:koprok:base-11.4 | Nein | Nein | 99 | download.opensuse.org/reposito…:/koprok:/base-11.4/12.1/

    Das Repo kann auf jeden Fall heraus, läuft ins Leere.

    Was ist daraus Installiert?
    20 | home:ecsos | home:ecsos | Ja | Ja | 99 | download.opensuse.org/reposito…ome:/ecsos/openSUSE_12.1/
    21 | home:koprok:base-12.1 | home:koprok:base-12.1 | Ja | Ja | 99 | download.opensuse.org/reposito…prok:/base-12.1/standard/


    Das kannst Du deaktivieren und deaktualisieren, ist im Prinzip das OSS-Repo:
    25 | openSUSE-12.1-12.1-1.4 | openSUSE-12.1-12.1-1.4 | Ja | Nein | 99 | cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_DVDWBD_SH-B123L_R8496GHZC12349,/dev/sr0


    Und dann schauen wir einmal weiter.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 51140 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ja. Mit YAST lies sich bei "Software installieren" mit dem Tab "Version" erkennen, dass die errormessages aus einem anderen Repo waren. Die bereits oben erwähnte 2 Version, stammt vom gleichen Repo. Das habe ich dort nun angepasst ohne das es etwas bewirkte.

    Die Zeilen 19 und 21 ("koprok") sagen mir nichts, habe beides entfernt und die Zeile
    20 | home:ecsos | home:ecsos | ...
    bezieht sich auf einen Epson Druckertreiber.

    Die Zeile 25 betreffs DVD habe ich deaktiviert.

    Es ist mir tatsächlich nicht klar, wie ich die Prioritäten setzen soll. Das Anwachsen der Repoliste ist mir selber unheimlich. Weil ich bisher aber diese Probleme nicht hatte, habe ich da auch nicht "herumgefummelt".

    Wie die die da alle hineinkommen? Wer weiß das schon?
    Sicher bin ich mir bei KDE4.8 und Owncloud, die habe ich hinzugefügt. Die Repos mit dem "Debug" -Hinweis, sollten nicht von mir stammen. Ich nehme mal an, das es da irgendwann und irgenwo ein Button gab, wo "Hinzufügen" draufstand. "Google-Earth" ist sicher so entstanden. NVidia mit der Installation. Bei den "opensuse" -Zeilen, weiß ich nicht, was zur Installation gehört und was später hinzukam.

    Für den Inhalt des Beitrages 51144 haftet ausdrücklich der jeweilige Autor: Koto

  • Epson Druckertreiber gibt es als rpm von der Epson Homepage.

    Wahrscheinlich sind die anderen Repos als sogenannte 1-Klicker hinzugefügt worden.

    Die debug Repos werden bei der Installation mit hinzugefügt, ebenso das source-Repo.
    Die braucht jedoch ein normaler Anwender nicht.

    Zu den Prioritäten:
    opensuse-forum.de/allgemeiner-…llgemeines-f17/t8365-f19/
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 51145 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Yup, der Artikel im ersten Link war nicht "up-to-date", da hatte ich jedoch auch nur einfach eine Google Suche nach "Wie Yast entscheidet woher ein Paket installiert wird" gemacht und nicht weiter als den Titel gelesen ;(

    Also dieser Link hier sollte da eine aktuelle Erklaerung fuer diese Frage enthalten:
    de.opensuse.org/Upgrade

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Gondwana ()

    Für den Inhalt des Beitrages 51147 haftet ausdrücklich der jeweilige Autor: Gondwana