Energiesparfunktionen des Monitors komplett ausschalten

Hinweis: In dem Thema Energiesparfunktionen des Monitors komplett ausschalten gibt es 14 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo!


    Ich möchte den Gnome Desktop meines openSUSE 12.3 auf einem Public Display anzeigen. Dazu müssen natürlich sämtliche Energiesparfunktionen und der Bildschirmschoner aus sein. Das gelingt mir leider nicht vollständig.


    Das habe ich gemacht:



    • Systemeinstellungen -> Leistung -> "Nicht in Bereitschaft gehen"
    • Systemeinstellungen -> Helligkeit und Sperren -> "Bildschirm abdunkeln, um Energie zu sparen" weggeklickt
    • Leider gibt es unter "Bildschirm abschalten, wenn inaktiv für: ...." nirgends die Möglichkeit "Nie" einzustellen. Das Größtmögliche ist "1 Stunde".


    und vermutlich schaltet sich deswegen immer der Bildschirm ab und muss erst wieder mit einem Tastendruck oder einer Mausbewegung aufgeweckt werden.


    Danke für Eure Hilfe!
    Robert


  • Das Ausschalten des Displays geschieht immer so: Wenn der eingestellte Timerwert von "Bildschirm abschalten, wenn inaktiv für: ...." erreicht ist, dimmt das Bild auf schwarz runter, und dann sagt der Monitor, dass das VGA Eingangssignal fehlt und schaltet sich aus. Wenn man da nur "Nie" einstellen könnte...

  • inspiriert aufgrund des Hinweises von thomas23 hab jetzt noch "xset -dpms" eigegeben, sodass "xset q" nun "DPMS is Disabled" zurückmeldet.


    Nachdem das nicht geholfen hat, hab ich auch noch "systemctl stop upower.service" probiert und auch mal den "gnome-power-manager" deinstalliert.


    Auch habe ich mal den "Bildschirm abschalten, wenn inaktiv für: ...."-Wert verändert und mit "find /etc -mmin -1" und "find /home/fotouser -mmin -1" nachgesehen, wo der Wert hingeschrieben wird, in der Hoffnung ich könnte das File selbst editieren und auf einen Wert so verstellen. Es scheint so als ob sich danach nur die Datei "/home/fotouser/.config/dconf/user" ändert. Da man diese nicht direkt textuell editieren kann, habe ich es mit dem gconf-editor probiert den Wert zu finden. Kein Erfolg!


    Hilft leider alles nichts ?(

  • DPMS (Energy Star):
    Standby: 0 Suspend: 0 Off: 0


    Merkwürdig; danach dürfte der Bildschirm gar nicht ausgehen.


    Plan B: Erstelle eine Textdatei mit folgendem Inhalt:



    Bash
    #!/bin/sh
    xset -dpms s noblank


    Speichere sie unter einen Namen wie Bildschirm.sh oder ähnlich, in Deinem Autostartordner, mache sie Berechtigungsmäßig ausführbar und starte den Rechner mal neu.


    Dieser Befehl schaltet das abschalten des Bildschirms aus.


    Durch deine Ausgabe des Konsolenbefehsl xset bin ich mir aber nicht mehr sicher

    Für den Inhalt des Beitrages 55480 haftet ausdrücklich der jeweilige Autor: thomas23

  • inspiriert aufgrund des Hinweises von thomas23 hab jetzt noch "xset -dpms" eigegeben, sodass "xset q" nun "DPMS is Disabled" zurückmeldet.



    Code
    /etc/X11/xdm/Xsetup


    Dort

    Code
    #
    # Special screensaver parameters for xset, see manual page xset(1x).
    # Default is no special parameters. Use DPMS (VESA Power Savings
    # Protocol) if USEDPMS is set to "yes".
    #
    SAVESC=""
    USEDPMS="no"


    diesen Abschnitt mal editieren, so dass er wie oben aussieht

    Für den Inhalt des Beitrages 55482 haftet ausdrücklich der jeweilige Autor: thomas23

  • Das war die einzige Möglichkeit, auf Betriebssystemebene noch was auszuschalten.


    Dann kann es nur am Bildschirm selber liegen; sprich Hardware

    Für den Inhalt des Beitrages 55489 haftet ausdrücklich der jeweilige Autor: thomas23

  • Aber warum dunkelt er zuerst langsam ab, bevor er abschaltet? Das ist keine Funktion des Monitors, da ich das langsame Abdunkeln (ca. 2 Sekunden) auch über x11vnc sehen kann.
    Das beweist definitiv, dass das Abschalten vom PC aus initiiert ist.
    Würde das der Monitor selbst tun, dann wäre es auch egal, ob ich unter "Bildschirm abschalten, wenn inaktiv für: ...." 1 Minute oder 1 Stunde eintrage. Er schaltet sich aber immer genau nach der eingestellten Zeit aus.

  • Schreib in die ~/.xsession
    xset s off

    Für den Inhalt des Beitrages 55492 haftet ausdrücklich der jeweilige Autor: uhelp