Beiträge von egostra

    Ich habe auch schon mitbekommen, dass es nicht auf dieser Seite angezeigt wird, keine Ahnung warum. Die Pakete sind aber vorhanden.

    Steam ist auch bei Leap 15.3 in den offiziellen Repos drin.

    Auch die 32-bit Pakete für Mesa usw. sind in den offiziellen Repos, nur nicht im Repo von Xorg, wo leider die aktuellsten Treiber drin sind.

    Ich hab das Problem gelöst.


    Die Links von /lib/modules/5.12.9-1-default/build und /lib/modules/5.12.9-1-default/source waren gebrochen und ich habe sie einfach mit

    Code
    [13-06]root@Orange3:/lib/modules/5.12.9-1-default # ln -s /usr/src/linux-5.12.9-1/include/ /lib/modules/5.12.9-1-default/source

    und

    Code
    [13-06]root@Orange3:/lib/modules/5.12.9-1-default # ln -s /usr/src/linux-5.12.9-1-obj/x86_64/default/ /lib/modules/5.12.9-1-default/build

    neu gesetzt und dann hat es funktioniert.


    Beste Grüße

    Hallöchen Community,


    heute habe ich mal ein Anliegen. Es geht um meinen Tumbleweed-Rechner.


    Ich habe den Quellcode vom xpad kernelmodul über git als root gedownloaded

    Code
    [12-06]root@Orange3:~ # git clone https://github.com/paroj/xpad.git /usr/src/xpad-0.4

    und den Quellcode von xpad.c etwas abgeändert.


    Nun wollte ich mit dkms das geänderte Modul einbinden.

    Code
    [12-06]root@Orange3:~ # dkms install -m xpad -v 0.4
    Creating symlink /var/lib/dkms/xpad/0.4/source ->
    /usr/src/xpad-0.4
    DKMS: add completed.
    Error! echo
    Your kernel headers for kernel 5.12.9-1-default cannot be found at
    /lib/modules/5.12.9-1-default/build or /lib/modules/5.12.9-1-default/source.

    Wo bekomme ich die Header vom Kernel her? Ich dachte ich hätte bereits alles Nötige installiert.

    Code
    [12-06]root@Orange3:~ # uname -a
    Linux Orange3 5.12.9-1-default #1 SMP Thu Jun 3 07:44:58 UTC 2021 (f17eb01) x86_64 x86_64 x86_64 GNU/Linux

    Beste Grüße

    Poste bitte erstmal die Ausgabe von:

    Code
    zypper lr -up

    Ruckler könnten verschiedene Gründe haben. Vielleicht reicht der Arbeitsspeicher nicht aus und es wird etwas auf dem SWAP verlagert. Man könnte mal die Ausgabe von "top" beobachten.


    Es kann auch an den Grafikeinstelleungen liegen. Bei mir gab es in regelmäßigen Abständen mal kurze Ruckler (2sec). Der Grund war die Vsync-Einstellung auf meinem XFCE Desktop.


    Es gibt mit Sicherheit noch andere mögliche Gründe.

    Der Beitrag von tux2go hat mich gerade nochmal getriggert. Ich glaube wir müssen uns erstmal über den Begriff "einsteigerfreundlich" einigen. Für mich bedeutet das nämlich nicht, dass das System es mir so bequem wie möglich macht, ohne jegliches zutun, damit zu arbeiten, sondern das es mir es einfach macht die Funktion des Systems zu verstehen, also quasi Hilfe zur Selbsthilfe.


    So hart es auch klingt, aber genau das ist immer das Problem bei vielen, die nur von Windows weg wollen. Sie wollen ein anderes System nutzen, ohne ihre gewohnten Strukturen aufzugeben und das ist einfach unsinnig und ignorant.


    Das ist nur meine Meinung, ich will damit niemanden zu nahe treten.