Beiträge von TheFan1968

    Mehrere Dinge:
    Ich habe den Artikel zu voller Länge gelesen und da auch im Standard-vhots-ssl-tamplate von openSuse _default_ drin steht, ist das zumindest kein Grund dafür, dass es nicht funktionieren könnte. Zuviele gleichzeitge Änderungen in einem Skript führen dazu, dass man hinterher nicht mehr weiß, welche falsch ist.
    Solltest du bei deinem Beruf eigentlich auch wissen.


    Was hat das mit dem DUP hier zu suchen? Das ist hier mal off-topic und nicht mein Fokus.


    Ich habe mein Problem gelöst.
    Keiner deiner Tipps war dabei hilfreich, sondern das Lesen von anderen Seiten, mal was ausprobieren, das Ergebnis ansehen und weitersuchen.

    Bitteschön:

    Firewall mal deaktivieren, gehts dann?


    Wenn du an der config vom Indianer rumgefummelt hast, Indianer neu gestartet?

    Ohne Firewall zeigt nmap folgendes Ergebnis:


    Port 80 nach wie vor erreichbar.


    Ja, der Indianer wird nach jeder Bearbeitung neu gestartet.


    Inzwischen habe ich auch mal die beiden vordefiniierten Regeln für http und https aus der Firewall gelöscht und explizit die Ports 443 und 80 als offen definiert.
    Das Ergebnis war dann wieder ein offener Port 80 und ein closed 443.


    Da bin ich nun echt ratlos.

    Nun. Es wäre schön, wenn es so einfach funktionieren würde..
    Ich habe die Konfiguration so auch angelegt, aber der Server verweigert die Verbindung


    Der Port 443 ist closed, sagt nmap


    Und ja, in der Firewall, die auch aktiv ist, ist HTTPS als erlaubter Service eingetragen.


    Der Server ist erreichbar, aber eben nicht über https.


    Was können, außer der Firewall, Ursachen dafür sein?



    Code
    authz_host actions alias authn_file authz_groupfile auth_basic
    authz_user autoindex cgi dir include log_config mime negotiation
    setenvif status asis headers imagemap info rewrite vhost_alias
    reqtimeout authn_core socache_shmcb socache authz_core nss php
    version tidy ssl

    Hallo zusammen!


    Man hat ja oft so viele Talente, aber meins endet bei dem Versuch einen Webserver mittels certbot mit der Fähigkeit von https zu versehen.


    Gegeben ist ein Server mit openSuse Leap 42.2 und einem apache2 Webserver.


    Der Webserver wurde, da ich schon einige Zeit da herumprobiere, komplett neu und lupenrein leer neu aufgesetzt.
    Alle Konfigurationsdateien sind also im Ur-Zustand nach der Installation.


    Die Firewall lässt Verbindungen mit HTTPS zu.


    Die mit certbot erstellten Zertifikate liegen auch vor.

    Bash
    - Congratulations! Your certificate and chain have been saved at
    /etc/certbot/live/meineDomain.de/fullchain.pem. Your cert will
    expire on 2017-09-13. To obtain a new or tweaked version of this
    certificate in the future, simply run certbot again. To
    non-interactively renew *all* of your certificates, run "certbot
    renew"

    Was ist jetzt noch zu tun?


    Ich bin ehrlich gesagt, je länger ich suche, immer ratloser, zumal sich die apache2-Konfiguration ja bei openSuse auch über eine gefühlte Million Dateien erstreckt.
    Wer kann mich auf den richtigen Weg schubsen?


    Gruß, Pete

    Dann kannste das auch löschen, macht dann gar keine Probleme mehr. Und ein zypper up ist schnell abgesetzt.

    Wenn ich das Lösche ist die Problematik, das andere Pakete das als Abhängigkeit mitbringen aber nocht behoben... und schwupps kommt es wieder an Bord.
    Besser wäre es funktioniert einfach so wie es soll.


    Wennich alle zickenden Pakete von openSUSe gleich löschen würde, wäre nichts mehr da... ;)