Beiträge von DL1EKC

    Hallo,


    ich konnte zum geschilderten Problem zwar keine Informationen finden, bin aber letztlich wie folgt erfolgreich gewesen:


    - im UEFI die Keys für das Secure Boot gelöscht (dadurch Umschaltung des Secure Boot in den Setup Mode)

    - OpenSUSE gestartet

    - in Discover die angebotenen Updates für Lenovo System Firmware und Embedded Controller ausgeführt

    - Rechner neu starten

    - im BIOS Startbildschirm nach F12 im Geräteauswahlmenü das Gerät "Linux update manager" ausgewählt


    Danach erschien kurzzeitig die Meldung "System Reset" und dann für mehrere Minuten ein großes Lenovo Logo ohne erkennbare Aktivität. Plötzlich startete der Rechner neu. Im BIOS Startbildschirm erschien die neue Versionsnummer! Kurz danach erschien die Meldung, dass die Embedded Controller Firmware geflasht wird.


    Nach einem erneuten automatischen Neustart lief die Maschine normal hoch. Beide Firmwares werden nun mit den aktuellen Versionsnummern angezeigt.


    Ich hoffe, das hilft irgendwem irgendwann weiter.


    Viele Grüße


    Marcus

    Hallo beisammen,


    in Discover werden mir für mein Lenovo P1 folgende zwei Aktualisierungen angeboten:


    1. Embedded Controller auf Version 0.1.05
    2. LENOVO System Firmware auf Version 0.1.07

    Lasse ich beide Aktualisierungen laufen, werden die Dateien heruntergeladen, kurz danach verschwinden beide Aktualisierungen; so, als ob die Aktualisierung erfolgt sei.


    Bei der nächsten Überprüfung auf Aktualisierungen tauchen diese beiden Pakete wieder auf. Das ganze läßt sich beliebig of wiederholen.


    Ich habe dann auf der Konsole als su fwupdmgr update ausgeführt. Dort werden diese beiden Updates auch angeboten und laufen fehlerfrei durch. Anschließend wird ein Neustart gefordert. Danach sind beide Firmwares wieder auf dem alten Stand und das Update wird erneut angeboten. Auch hier kann ich das beliebig oft wiederholen.


    Es sieht so aus, als ob die Firmware fehlerfrei geladen wird, aber offenbar letzendlich nicht ins Flash geschrieben wird.


    Kennt einer dieses Phänomen und hat eine Lösung dafür parat?


    Viele Grüße


    Marcus

    Das ist das Problem mit Verschlüsselungen und deswegen nutze ich so etwas nicht.

    Naja, ich hätte genau andersherum argumentiert: Durch die Verschlüsselung kann nicht jedes probeweise gestartete System direkt in der Partition rumrühren; so zumindest bisher meine Vorstellung. Selbstverständlich muss LUKS unterstützt werden, wenn man dann in der Partition etwas machen möchte; das ist dann evtl. als "Nachteil" zu beurteilen.

    Clonezilla (oder eigentlich die Person vor dem Monitor!) kann nicht in einer verschlüsselten Partition rumlöschen. Aber man kann die gesamte Partition löschen oder überschreiben oder eben den Einhänge/Mount-Punkt umbenennen. Wie bei einem verschlossenen Briefumschlag. Du kannst nicht hineinsehen, aber du kannst ihn in den Müll oder ins Feuer werfen und einen neuen Umschlag auf den Schreibtisch legen.

    Da möchte ich nochmal nachhaken:


    Ich habe eine LUKS1 verschlüsselte Systempartition. /home befindet sich im btrfs Subvolume /@/home. Wie sollte Clonzilla ohne Kenntnis der Passphrase den Einhängpunkt für /home verändern? Der Einhängpunkt ist doch innerhalb der verschlüsselten Partition definiert. Das einzige was ich als Nutzer gemacht habe, ist das Clonzilla System zu booten und festzustellen, dass es ab Hauptmenü abstürzt (vermutlich wegen LUKS).


    Ich verstehe das einfach nicht. Eine gelöschte oder sonstwie gänzlich zerstörte Partition würde ich verstehen, aber so ...


    Gruß


    Marcus

    Hallo,


    ein spezielles Dankeschön an "Dr. Heinberg". Dein Post hat mich auf die richtige Fährte gesetzt. Ich habe Deinen Weg allerdings etwas abgekürzt:


    1) den normalen User abgemeldet

    2) root angemeldet

    3) /home in /home_alt umbenannt

    4) /home2 nach /home kopiert (zur Sicherheit nicht verschoben)

    5) mit chown Eigentümer und Gruppenzugehörigkeit auf das Userkonto gesetzt

    6) User wieder angemeldet und ALLES WIEDER DA


    Ich bin so erleichtert. DANKE DANKE !


    Es bleibt das ungute Gefühl, ob ich der Maschine trauen kann. Ich verstehe nicht, was da passiert ist. Wer oder was hat da plötzlich während eines Neustarts mein /home "übermounted" ? Clonzilla werde ich jedenfalls nicht mehr starten, obwohl ich weiterhin der Meinung bin, dass auch Clonzilla nicht in einer verschlüsselten Partition rumlöschen kann.


    Aber wie Welm auch schon meinte, gibt es da bei btrfs wohl noch einiges zu lernen. Der von Heinz-Peter verlinkte Beitrag könnte ein wichtiger Hinweis sein. Das schaue ich mir nochmal an, aber nicht jetzt. Habe erstmal fertig.


    Einstweilen wird mein Sicherungsrhythmus aber ziemlich schnell sein.


    Leute, ich danke Euch nochmals!


    Viele Grüße


    Marcus

    Ja richtig, auf nvme0n1p3 ist \ eingehängt und es gibt ein btrfs Subvolume @/home, das als /home eingehängt ist. Das wurde vom Installer so angelegt.


    Das wurde vom Installer zum einen so vorgeschlagen und mir schien das auch flexibler, als wenn ich im Vorfeld Partitionen mit fester Größe anlegen würde.


    Ich weiss aber nicht, ob man für den Zugriff auf btrfs subvolumes von einem Live-System aus was spezielles machen muss, bzw. welches/welche Subvolumes ich von der Partition überhaupt sehe.


    Ich kann ja jetzt prinzipiell auf alle Daten unter dem Ordner home2 zugreifen. Nur wie bekomme ich die nach /home, wenn ich mit einem Live-Linux vom Stick die Daten unter /home gar nicht sehen kann. Das ist ja der Standardfall, dass man mal eine Sicherung zurückspielen muss.

    Weiterer Test:


    Das, was in meinem System als /home eingehängt ist, ist mit dem Rescue System nicht auffindbar (probiert mit einem Dateinamen, den es nur unterhalb /home gibt). Somit kann ich da hinein auch keine Sicherung zurückspielen.


    Echt schräg ...


    Viele Grüße


    Marcus

    Hallo Welm,


    mein Home-Verzeichnis ist /home/$user; richtig? Oben meinte ich aber den Pfad /home.


    Nochmal in hoffentlich verständlicher Kurzform der chronologische Ablauf:


    1. Einrichtung eines Systems mit OpenSUSE Tumbleweed einschl. Partitionierung der SSD.
    2. Einspielen meiner Nutzerdateien und Vornahme div. Nutzereinstellungen in KDE (ganz normal in der GUI)
    3. Erstellung eines clonezilla Livesystem auf USB Stick
    4. Booten von clonezilla USB Stick; Clonezilla funktioniert nicht, friert im Hauptmenü ein
    5. Neustart des Rechners mit Start des "Wirksystems", also OpenSUSE. Login nicht mehr möglich. An der Konsole festgestellt, dass /home leer ist.
    6. Mit Rescuesystem meine tar Sicherung des $user Ordners zurückgespielt in /home/$user
    7. System läuft wieder, bis auf die merkwürdigen Kleinigkeiten wie s.o. Auf dem Desktop erscheinen die ganzen Ordner Dokumente, Videos, Bilder etc., sodass der Desktop offenbar den Pfad /home/$user anzeigt.
    8. Gestern weitere Dateien unterhalb von Dokumente eingepflegt.
    9. Nach einem Neustart sind alle neuen Dateien, E-Mail und geänderten KDE-Einstellungen weg. Div. überschriebene Dokumente liegen wieder in der alten Version vor. Dafür erscheint aber auf dem Desktop wieder die Verknüpfung "Persönlicher Ordner", die auf /home/$user zeigt. Der Desktop zeigt also offenbar wieder den Pfad /home.

    Ich möchte klarstellen, dass ich niemals per Hand etwas statisch eingehängt habe oder sonstwie in den Tiefen des Systems "geschraubt" habe. Ich kann mir aber auch nicht vorstellen, dass clonezilla in einer verschlüsselten Partition gezielt den Pfad /home zerstört.


    Aufgrund Deines Hinweises bzgl. mounten auf /home habe ich folgendes probiert:


    Mit dem Rescuesystem habe ich den Ordner /home auf meiner Platte in /home2 umbenannt. Nach dem Neustart des "Wirksystems" habe ich nun tatsächlich /home und /home2. /home hat einen älteren Stand, und /home2 entspricht dem (verschwundenen) aktuellsten Stand von gestern vor dem Neustart.


    Nun bin ich platt. Was passiert da? Und wie bekomme ich das wieder gerade gezogen?


    Ich verstehe, dass offenbar etwas als /home über meinen Ordner /home gemountet war, vermutlich ab dem Moment, als ich mich nicht mehr einloggen konnte und /home leer angezeigt wurde. Aber wieso? Ich habe manuell nichts gemountet.


    Vom Rescuesystem aus sehe ich auf der Festplatte jetzt übrigens ein leeres /home und /home2.


    Viele Grüße


    Marcus

    Hallo Alero,

    Sehr merkwürdig ... Poste mal bitte

    Code
    ls -al

    Für den Ordner home:


    Code
    ls-al
    insgesamt 0
    drwxr-xr-x 1 root root 12 9. Jan 15:09 .
    drwxr-xr-x 1 root root 232 21. Jan 09:54 ..
    drwxr-xr-x 1 DL1EKC users 644 23. Jan 13:16 DL1EKC


    Für den Ordner home/$USER

    Viele Grüße


    Marcus