Opensuse Tumbleweed Startproblem nach Update vom 15.4.2021

Hinweis: In dem Thema Opensuse Tumbleweed Startproblem nach Update vom 15.4.2021 gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo beisammen,


    nach dem Update vom 15.4.2021 ließ sich mein Tumbleweed nicht mehr starten. Mit diesem Update wurde Kernel 5.11.12-1 default installiert.


    Fehlerbild:


    Beim Start mit deaktivierter splash=silent Bootoption bleibt der Startjob nach der Hardwareerkennung hängen und nach dem 90 s Timeout lande ich im emergency mode auf der bash Konsole.


    Nach Durchprobieren der letzten Snapshots konnte ich das System schließlich mit dem Snapshot, das unmittelbar vor dem Update auf Kernel 5.11.12-1 default erstellt wurde, wieder starten. Es war aber NICHT erfolgreich, das aktuelle System lediglich mit der Boot-Option kernel 5.11.11-1 default zu starten (auch wieder emergency mode).


    Weiteres Problem: Frühere Snapshots kann ich nur starten, wenn ich im UEFI das TPM Modul ausschalte. Bei aktivem TPM erhalte ich beim Aufruf des Bootmenüs für die gespeicherten Snapshot einen "unknown TPM error". Danach lässt sich kein Kernel mehr starten.


    Nach einem Rollback auf den Stand unmittelbar vor der Installation von Kernel 5.11.12-1 läuft das System jetzt erstmal wieder. Das jetzt aktuelle System läuft mit aktivem TPM-Modul, ein Zugriff auf gespeicherte Snapshots ist mit aktivem TPM Modul weiterhin nicht möglich.


    Wie jetzt am geschicktesten weiter? Durch das Rollback warten jetzt natürlich wieder 645 Updates auf mein Tumbleweed.


    Und ist das Problem noch bei anderen aufgetreten?


    Viele Grüße


    Marcus

    Für den Inhalt des Beitrages 290515 haftet ausdrücklich der jeweilige Autor: DL1EKC

  • Und ist das Problem noch bei anderen aufgetreten?

    Nein, in keinster Weise ...

    Code
    uname -a
    Linux linux.fritz.box 5.11.12-1-default #1 SMP Wed Apr 7 17:30:21 UTC 2021 (92a542e) x86_64 x86_64 x86_64 GNU/Linux

    Mein System schnurrt wie ein Kätzchen. Da hast du sicher sehr viel darin herum konfiguriert.

  • Hier läuft 5.11.12 auch ohne Probleme. Ebenfalls mit aktiviertem TPM. Allerdings gibt es hier kein BTRFS sondern EXT4.

    Eines der gut 600 Updates war wohl für das System nicht so gut. Aber wohl nicht der Kernel, sonst hätte der alte laufen müssen.

    Für den Inhalt des Beitrages 290518 haftet ausdrücklich der jeweilige Autor: Forentroll

  • Beim Start mit deaktivierter splash=silent Bootoption bleibt der Startjob nach der Hardwareerkennung hängen und nach dem 90 s Timeout lande ich im emergency mode auf der bash Konsole.

    90 Sekunden Pause das deutet auf systemd Fehler. Poste mal als root:

    Code
    systemd-analyze blame

    Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt. Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

    Für den Inhalt des Beitrages 290525 haftet ausdrücklich der jeweilige Autor: Heinz-Peter

  • Hallo Heinz-Peter,


    vielen Dank für das Hilfsangebot. Da ich einen Rollback gemacht habe, ist der Fehler ja jetzt wieder weg. Der Befehl ist aber genau das richtige; den werde ich mir für die Zukunft mal notieren. Vielen Dank!


    Die Rückmeldungen hier deuten darauf hin, dass der Schluckauf hier wohl ein Einzelfall ist. Daher habe ich dann eben die inzwischen 664 Updates nochmal installiert und diesmal läuft alles einwandfrei.


    Unklar ist mir aber weiterhin der "unknown TPM error", wenn ich im Bootmenü aus einem Snapshot starten möchte. Irgendwelche Ideen dazu?


    Viele Grüße


    Marcus

    Für den Inhalt des Beitrages 290526 haftet ausdrücklich der jeweilige Autor: DL1EKC

  • Chartwalker

    Hier in diesem Beitrag wird dir keine Hilfe zuteil. Eröffne für dein Problem einen eigenen Beitrag und kapere nicht anderen ihre Beiträge.