zypper hat sein Suchverhalten geändert

Hinweis: In dem Thema zypper hat sein Suchverhalten geändert gibt es 2 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Sauerland und ich haben gerade festgestellt, dass ein subtiler Bug in zyppers Suchfähigkeiten auftritt.


    Man konnte früher®™ mit zypper se Paketname nach allen Paketen suchen lassen, die die Zeichenfolge Paketname enthalten.


    Sucht man heute mit zypper se python so erhält man auch das Paket python-wxWidgets. Was korrekt wäre und bislang auch so funktionierter.
    Sucht man aber mit zypper se python-wx so findet er python-wxWidgets nicht.


    Sauerland schreibt gerade einen Bugreport.


    Bis das geregelt ist (und es scheint mit dem Wildcardhandling noch mehr Probleme zu geben),
    rate ich solange immer mit expliziten Wildcards zu suchen, die man auch sauber quoten sollte.
    Also derzeit mit zypper se '*TeilPaketname*' suchen.

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 108133 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Ich kann das bestätigen.

    Code
    zypper se python-wx
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    Keine passenden Objekte gefunden.



    Aber mit einer Wildcard geht es.

    Code
    zypper se python-w*
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    S | Name | Zusammenfassung | Typ
    --+------------------------------+------------------------------------------------------------------------------+-----------
    | python-WSGIProxy | HTTP proxying tools for WSGI apps | Paket
    | python-WSGIProxy2 | WSGI Prox und noch einige Fundstellen

    Vielleicht hilft mein Versuch bei einer Lösung.