OpenSUSE lässt sich nicht auf deutsch umstellen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema OpenSUSE lässt sich nicht auf deutsch umstellen gibt es 18 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • OpenSUSE lässt sich nicht auf deutsch umstellen

    Hallo,

    gerade habe ich openSUSE Leap 15 (KDE Plasma) neu in Virtual Box installiert (schon zum zweiten Mal!). Dafür habe ich heute auch nochmal die Installations-DVD runtergeladen (um sicherzustellen, dass ich die aktuellste Version erhalte).
    Bei der Installation wird man ja nach der Sprache gefragt. Dort habe ich Deutsch eingestellt, danach sprang auch das Tastaturlayout auf deutsch um (dies ist auch das einzige, was jetzt stimmt!). Dann wird man noch nach der Zeitzone gefragt, dort habe ich Europa -> Deutschland gewählt.
    Während der Installation hat der Installer wohl auch noch ein paar Sachen aus dem Internet runtergeladen. Das kann ich sehen, da ich meinen Netzwerkerkehr überwache. Die Internetverbindung funktionierte also, sowohl während, als auch direkt nach der Installation, was ich auch daran gemerkt habe, dass mir nach der Installation direkt noch Updates angeboten wurden, die ich dann auch installiert habe.

    Nun ist aber alles in Englisch!
    Ich sehe im System im Wesentlichen zwei Anlaufstellen, wo man die Sprache einstellen kann (das ist auch so ziemlich das einzige, was ich über Google gefunden habe).
    Habe das mal in einem zusammengefassten Screenshot angefügt:

    Das kleinere (vorne liegende) Fenster erhalte ich über Settings -> Configure Desktop -> Personalization -> Regional settings -> language
    Das größere (hinten liegende) Fenster erhalte ich über Yast und dort z.B. über die Sucheingabe "language".
    (Beides erhält man auch direkt über das Auswahlmenü durch Eingabe von "language"; da erscheint dann 2x language und das eine bringt mich eben zu ersterem, das zweite zu zweiterem.)

    Im kleineren Fenster stand zunächst auf der rechten Seite unter "preferred languages" gar nichts, also komischerweise auch nicht mal englisch. Nach Eintragen von Deutsch (so wie man es jetzt auf dem Bild sieht) und anschließendem Neustart änderte sich aber auch nichts, außer, dass jetzt eben Deutsch dort als ausgewählt drin steht (es aber nichts bewirkt).

    Im größeren Fenster stand schon German als primäre Sprache drin. Als sekundäre Sprache war nichts ausgewählt. Dort habe ich dann auch nochmal Deutsch ausgewählt, aber nach einem Neustart ist es wieder abgewählt.
    Ich habe auch schon mal testweise die Sprache auf englisch umgestellt und dann wieder zurück auf deutsch (in beiden Auswahlfenstern), hat aber auch nichts gebracht.

    Testweise habe ich schon mal folgenden Befehl in die Konsole eingegeben (habe ich aus einem anderen Thread):

    Quellcode

    1. zypper se -si bundle-lang
    Das Ergebnis:

    Quellcode

    1. linux-bz7q:~ # zypper se -si bundle-lang
    2. Loading repository data...
    3. Reading installed packages...
    4. No matching items found.
    5. linux-bz7q:~ #
    Habe auch gelesen, dass man über Yast2 Sprachpakete nachinstallieren könnte ... aber wie finde ich die richtigen, so dass auch wirklich das ganze System inkl. vorinstallierter Software (wie z.B. Firefox) auf deutsch ist?

    Für den Inhalt des Beitrages 122749 haftet ausdrücklich der jeweilige Autor: Neuer1

  • Ja, danke, aber das habe ich ja schon alles gemacht. Über diesen Leitfaden bin ich auch schon im Internet gestolpert. Und das ist ja auch der Screenshot, den ich gepostet habe. Es funktioniert so leider nicht.

    PS:
    Vielleicht hat es was damit zu tun, dass ich als root angemeldet bin. Das habe ich aus Testgründen extra so installiert. Bei der Installation bin ich bei Benutzererstellung auf "Überspringen" gegangen und habe nur ein Passwort für root ausgewählt.
    Es gibt also in dem System keinen anderen Benutzer als root.

    Dazu steht in der Anleitung unter Punkt 6.1(4):
    4. To change language settings specific to the user root , click Details.
    a. Set Locale Settings for User root to the desired value. For more information, click Help.
    b. Decide if you want to Use UTF-8 Encoding for root or not.
    Tja, wenn ich dort auf "details" klicke steht dort aber auch schon "de_DE" ausgewählt und mehr kann ich da nicht machen. (Außer UTF-8 Kodierung vewenden = ausgewählt).

    Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von Neuer1 ()

    Für den Inhalt des Beitrages 122752 haftet ausdrücklich der jeweilige Autor: Neuer1

  • Neuer1 schrieb:

    Es gibt also in dem System keinen anderen Benutzer als root.
    Ist keine gute Idee. Auch nicht für Testzwecke. Ein normaler User für normales arbeiten und root für die Administration.

    Poste bitte mal die Ausgabe von:

    Quellcode

    1. id

    und die Ausgabe von:

    Quellcode

    1. locale

    Für den Inhalt des Beitrages 122755 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Nochmal edit:

    Jetzt habe ich unter Einstellungen -> Systemeinstellungen -> Persönliche Informationen -> Regionaleinstellungen
    Und dort auf Formate -> Region
    Dort stand vorher "no change" drin, das habe ich umgestellt auf deutsch und neugestartet. Jetzt scheint das meiste auf Deutsch zu sein. Komischerweise steht dort jetzt wieder/immer noch "no change" drin, statt "Deutschland - deutsch de_DE".
    Und wenn ich z.B. an dieser Stelle im Menü schaue, steht oben auch "All settings" und "Help" immer noch in englisch.
    Also, so ganz "eingedeutscht" ist es wohl immer noch nicht!

    Für den Inhalt des Beitrages 122757 haftet ausdrücklich der jeweilige Autor: Neuer1

  • Die Quellcodes:


    Quellcode

    1. linux-bz7q:~ # id
    2. uid=0(root) gid=0(root) Gruppen=0(root)
    3. linux-bz7q:~ # locale
    4. LANG=de_DE.UTF-8
    5. LC_CTYPE=de_DE.UTF-8
    6. LC_NUMERIC="de_DE.UTF-8"
    7. LC_TIME="de_DE.UTF-8"
    8. LC_COLLATE="de_DE.UTF-8"
    9. LC_MONETARY="de_DE.UTF-8"
    10. LC_MESSAGES="de_DE.UTF-8"
    11. LC_PAPER="de_DE.UTF-8"
    12. LC_NAME="de_DE.UTF-8"
    13. LC_ADDRESS="de_DE.UTF-8"
    14. LC_TELEPHONE="de_DE.UTF-8"
    15. LC_MEASUREMENT="de_DE.UTF-8"
    16. LC_IDENTIFICATION="de_DE.UTF-8"
    17. LC_ALL=
    18. linux-bz7q:~ #
    Alles anzeigen
    Schon wieder PS:
    Nach einem erneuten Neustart wurde jetzt auch wie o.g unter Formate -> Region Deutschland übernommen und nun ist auch der letzte Rest der Menüsprache in deutsch. Das gibt ja auch (soweit ich das beurteilen kann!) die Konsolenausgabe wider.
    Also, Merke, die Einstellung unter Formate -> Region zweimal auf deutsch umstellen, jeweils mit Neustart dazwischen und dann passt es. Ein bisschen komisch ist es ja trotzdem?!

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Neuer1 ()

    Für den Inhalt des Beitrages 122759 haftet ausdrücklich der jeweilige Autor: Neuer1

  • Nicht komisch, sondern gewollt.

    Es ist nicht gewollt, sich als root grafisch anzumelden.

    Poste:

    Quellcode

    1. systemctl status display-manager.service


    Quellcode

    1. cat /etc/sddm.conf
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 122760 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Systemeinstellungen - Regionaleinstellungen - Formate ...
    ... war mein erster Gedanke.

    Habe mich aber nicht "getraut" dieses zu empfehlen, da ich davon ausgegangen bin, dass JEDER diese Settings kennt.
    Die Antwort wäre dann zuuu einfach.

    Aber ebenso richtig, in diesem Fall.

    @thomas
    "locale" kannt ich auch nicht - danke (-:
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 122761 haftet ausdrücklich der jeweilige Autor: sterun