noVNC remote desktop einrichten.

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema noVNC remote desktop einrichten. gibt es 36 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • noVNC remote desktop einrichten.

    Hallo alle,

    Hat hier schon jemand noVNCmal einrichten und nutzen können. Also ich verwende Opensuse Leap 15.
    Und ich will remote desktop verwenden aber über den Browser also es sol kein vncviewer verwendet werden.

    Ich bin auf noVNC und guacamole gestoßen. Aber ich kann weder das eine noch das andere einrichten so dass es läuft.
    Bzw vielleicht läuft es schon nur weiß ich es nicht.

    Ich bleibe mal bei noVNC. Ich habe das packet installiert und jetzt ?? Ich soll laut Homepage ein script aufrufen.
    launch.sh --vnc <SERVER-IP>:<VNC_PORT>
    Dieses script "launch.sh" exestiert aber nicht oder ich kann es nicht finden.

    Es gibt dann noche einen Möglichkeit Remotdesktop über Yast zu aktivieren.
    Auch da gibt es eine Option Browser zu aktivieren.
    Aber
    1. Schaffe ich das auch nicht bzw wenn ich es aktiviert habe weiß ich nicht wie ich auf den Rechner zugreifen kann.
    Laut hilfe soll man dann http://<IpAdddresse>:5801 (also da setzte ich jetzt meine vom Rechner ein auf den ich zugreifen möchte) zugreifen können. Das geht aber nicht.
    2. Laut hilfe braucht man dann ein java plugin. Das will ich aber eigentlich auch nicht.

    Ich hoffe ich habe mich klar ausgdrückt. Hat jemand Ahnung und kann mir da helfen ?


    Grüße

    Für den Inhalt des Beitrages 124327 haftet ausdrücklich der jeweilige Autor: lopder

  • Beide Lösungen brauchen auf der anderen Seite einen laufenden VNC- Server.

    Die Guacamole Variante läuft über ein Tomcat Java Webserver.
    Es ist deshalb langsamer als eine native VNC Verbindung.
    Und den muss man erst mal haben.

    noVNC ist die modernere Variante.
    Das Script lauch.sh findet sich im Unterverzeichnis utils.

    Aber, wie gesagt: Beide brauchen auf der Gegenseite einen laufenden vncserver.
    Gibt es einige.
    openSUSE bietet, glaub ich, drei davon.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 124330 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo

    Das ich einen vncserver dafür brauche ist mir klar und der ist auch eingerichtet und funktioniert läuft und ich kann auch übner den vncclient darauf zugreifen.

    Ja richtig laut doku Hompage soll man das irgendwie so aufrufen
    ./utils/launch.sh --vnc localhost:5900-5903

    Aber eine Verzeichnis Namens utils finde ich nicht zumindest nicht unter "/" und weiß auch nicht wo ich danach suchen sollte.
    Und wenn ich das Packet "noVNC" öffne finde ich zunindest im Packet in der Detailliste keine "launch.sh" Datei.
    Also weiß ich auch nicht wohin das genau abgelegt sein sollte.

    Guacamole schaffe ich seit Opensuse Leap 15 nicht mal mehr die packete dazu zu finden. Das lasse ich erstmal weg.


    Grüße

    Für den Inhalt des Beitrages 124332 haftet ausdrücklich der jeweilige Autor: lopder

  • Also ich würde sagen, das findest du wohl irgendwo dort in der Nähe, wo du es durch das Herunterladen hingespeichert hast.

    Mehr kann ich von meiner alten Glaskugel leider nicht ablesen.
    Die ist schon viel zu stumpf und abgewrackt durch ständigen unsachgemäßen Gebrauch.

    Das Projekt findet sich übrigens auf Github.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 124333 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo

    Berichtigung schrieb:

    Das Projekt findet sich übrigens auf Github.
    Ich habe da nichts runtergeladen ich habe das über die opensuse packetquellen bezogen.

    zypper addrepo https://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/Virtualization.repo
    zypper refresh
    zypper install novnc

    Und wenn ich mir das Packet names "novnc" in Yast in Details ansehe finde ich auch schon nicht so eine Datei.

    Sauerland schrieb:

    Remote Access with VNC | Reference | openSUSE Leap 15
    Wie oben am Anfang beschrieben habe ich das von dem link schon gemacht aber es funktioniert nicht. Ich habe auch das offizielle Handbuch wo mehr oder weniger das gleiche drinne steht.

    lopder schrieb:

    Es gibt dann noche einen Möglichkeit Remotdesktop über Yast zu aktivieren.
    Auch da gibt es eine Option Browser zu aktivieren.
    Aber
    1. Schaffe ich das auch nicht bzw wenn ich es aktiviert habe weiß ich nicht wie ich auf den Rechner zugreifen kann.
    Laut hilfe soll man dann http://<IpAdddresse>:5801 (also da setzte ich jetzt meine vom Rechner ein auf den ich zugreifen möchte) zugreifen können. Das geht aber nicht.
    2. Laut hilfe braucht man dann ein java plugin. Das will ich aber eigentlich auch nicht.
    Der Unterschied ist das im link nicht von einem java plugin sondern von "JavaScript-capable Web browser" die Rede ist. Das wäre für mich ok.

    Trotzdem läuft es nicht und ich wüsste nicht in welchen logs ich suchen kann woran das liegt. Weil mit einem vncviewer komme ich hin, mit dem Browser aber nicht.
    Und die Firewall habe ich testweise auch deaktiviert.

    Und noch was mein System ist frisch aufgesetzt und ich versuche als erstes dieses Remote Access zu aktivieren. Erst danach würde ich weiter packete laden.

    Grüße

    Für den Inhalt des Beitrages 124348 haftet ausdrücklich der jeweilige Autor: lopder

  • Du hättest von der Github Seite immerhin das Shellscript runterladen können.

    Aber ich denke, @Sauerland liegt schon richtig: Du wirst wohl sddm verwenden.
    Damit müsstest du den vncserver selbst komplett so konfigurieren, dass sddm umgangen wird.
    Es dürfte leichter sein auf einen anderen umzusteigen.

    Das Script führt übrigens nur einen Befehl aus:
    Es startet den vncserver unter websockify.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 124354 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hallo

    Sauerland schrieb:

    systemctl status display-manager.service

    ● display-manager.service - X Display Manager
    Loaded: loaded (/usr/lib/systemd/system/display-manager.service; enabled; vendor preset: enabled)
    Active: active (running) since Fri 2018-08-31 11:41:48 CEST; 2min 19s ago
    Process: 1125 ExecStart=/usr/lib/X11/display-manager start (code=exited, status=0/SUCCESS)
    Main PID: 1661 (sddm)
    Tasks: 4 (limit: 4915)
    Memory: 193.9M
    CPU: 11.015s
    CGroup: /system.slice/display-manager.service
    ├─1661 /usr/bin/sddm
    └─1690 /usr/bin/X -nolisten tcp -auth /run/sddm/{3af45b38-60a8-4533-b234-a4bdf9e6f001} -background none -noreset -displayfd 18 -seat seat0 vt7


    Aug 31 11:41:49 linux-gn5t sddm[1661]: Display server started.
    Aug 31 11:41:49 linux-gn5t sddm[1661]: Reading from "/usr/share/xsessions/default.desktop"
    Aug 31 11:41:49 linux-gn5t sddm[1661]: Reading from "/usr/share/xsessions/default.desktop"
    Aug 31 11:41:49 linux-gn5t sddm[1661]: Session "/usr/share/xsessions/default.desktop" selected, command: "/usr/bin/startkde"
    Aug 31 11:41:49 linux-gn5t sddm[1661]: Adding cookie to "/run/sddm/{3af45b38-60a8-4533-b234-a4bdf9e6f001}"
    Aug 31 11:41:49 linux-gn5t sddm-helper[1789]: [PAM] Starting...
    Aug 31 11:41:49 linux-gn5t sddm-helper[1789]: [PAM] Authenticating...
    Aug 31 11:41:49 linux-gn5t sddm-helper[1789]: [PAM] returning.
    Aug 31 11:41:49 linux-gn5t sddm[1661]: Authenticated successfully
    Aug 31 11:41:49 linux-gn5t sddm[1661]: Session started



    Berichtigung schrieb:

    Aber ich denke, @Sauerland liegt schon richtig: Du wirst wohl sddm verwenden.
    Damit müsstest du den vncserver selbst komplett so konfigurieren, dass sddm umgangen wird.
    Es dürfte leichter sein auf einen anderen umzusteigen.

    Das Script führt übrigens nur einen Befehl aus:
    Es startet den vncserver unter websockify.
    Das verwirrt mich ehrlich gesagt jetzt gerade.
    Ich lasse das fürs erste mal so stehen. Ich wollte nicht das script von irgendwo runter laden hätte erwartet das dass im Packet alles enthalten ist und ich bloß configfiles anpassen muss.

    Aber ich glaube wenn ich das über yast so wie im link von Sauerland, aktiviere ich schon irgendwie novnc bzw ist das mit novnc gelöst.
    Denn wenn mein system nach novnc suche finde ich zumindest configfiles in der Richtung. Ich habe auch ein configfile gefunden wo noVNC Webserver drinnen steht mit einen
    Variable Accept=False. Die bleibt imme rauf False egal was ich in yast einstelle. Wenn ich die auf manuell auf true setze sehe ich zumindest die noVNC Webseite und kann mich verbinden.
    Nur jetzt fragt es nach einem Passwort und ich habe keine Ahnung welches ich da angeben soll. Meine normalen Benutzerpassworter akzeptiert es jedenfalls nicht.

    Wenn ich den vncserver das erstemal manuell startet fragt es mich nach einem Passwort. Über yast aber nicht bzw habe nichts davon gefunden.

    Grüße,

    Für den Inhalt des Beitrages 124356 haftet ausdrücklich der jeweilige Autor: lopder

  • Sauerland schrieb:

    --cut--
    Ausgabe in Code-Tags hier posten.

    Du willst nicht, dass jeder auf diesen Desktop zugreifen kann.
    Und deshalb verlangt der vncserver beim Start nach einem festzulegenden Spasswort.

    Genau dieses Spasswort, wenn du es schaffst, eines einzutippen und zu bestätigen,
    wird dann beim Verbindungsversuch verlangt.
    Es wird sogar gespeichert, so dass ein neuerlicher Start derselben Instanz auch dasselbe Spasswort verwendet.

    Es mag eine gute Idee sein, sich in die Basics von VNC- Verbindungen ein wenig einzulesen.

    Und eher selten wird eine Distribution den Erwartungen von Einsteigern gerecht.
    Es ist eine andere Welt. Vergiss (fast) alles, was du bisher über OSe gelernt hast und lerne neu.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 124358 haftet ausdrücklich der jeweilige Autor: Berichtigung