rsync über ssh (zwecks Backup NAS nach Linux) - Konfigurationsfragen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema rsync über ssh (zwecks Backup NAS nach Linux) - Konfigurationsfragen gibt es 2 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • rsync über ssh (zwecks Backup NAS nach Linux) - Konfigurationsfragen

    Hallo,

    ich habe mir eine Synology Diskstation als NAS System gekauft. Dabei ist ein Programm "Hyperbackup" mit dem man auch die Systemkonfiguration des NAS sichern kann. Das habe ich letztlich hinbekommen, aber mit der "Unschönheit" dass ich ein Passwort im Klartext in eine Datei schreiben musste. Daher dieser Beitrag mit der Frage, wie man das anders - besser- machen kann.
    Kurz und treffend zusammengefasst um was es geht hat der Autor "geierb" in seinem Blogbeitrag blog.geierb.de/synology-hyperbackup-mit-rsync/
    Bei mir sieht die rsyncd.conf so aus:

    Quellcode

    1. #gid = users
    2. #read only = true
    3. #use chroot = true
    4. transfer logging = true
    5. log format = %h %o %f %l %b
    6. log file = /var/log/rsyncd.log
    7. pid file = /var/run/rsyncd.pid
    8. hosts allow = trusted.hosts
    9. slp refresh = 300
    10. use slp = false
    11. [Backup-der-DS]
    12. path = /home/ds-backup
    13. comment = Backup DS-System nach Linux Server
    14. use chroot = true
    15. read only = false
    16. list = true
    17. gid = users
    18. uid = erich
    19. hosts allow = DiskStation.fritz.box
    20. auth users = root, erich
    21. secrets file = /etc/rsyncd.secrets
    Alles anzeigen

    Die Verbindung kann nicht hergestellt werden, im Logfile findet sich:

    Quellcode

    1. 2018/12/23 15:51:10 [4882] connect from DiskStation.fritz.box (2001:4c50:33f:a000:211:32ff:fe9b:bff3)
    2. 2018/12/23 15:51:10 [4882] rsync allowed access on module Backup-der-DS from DiskStation.fritz.box (2001:4c50:33f:a000:211:32ff:fe9b:bff3)
    3. 2018/12/23 15:51:10 [4882] auth failed on module Backup-der-DS from DiskStation.fritz.box (2001:4c50:33f:a000:211:32ff:fe9b:bff3) for root: secret not found
    Das lässt sich nur beheben indem ich in rsyncd.secrets username und Passwort für root im Klartext hinterlege. Danach wird die Verbindung aufgebaut und ich kann den Backup durchführen. Im Log beginnt dieser Vorgang mit


    Quellcode

    1. 018/12/23 15:57:30 [5444] connect from DiskStation.fritz.box (2001:4c50:33f:a000:211:32ff:fe9b:bff3)
    2. 2018/12/23 15:57:30 [5444] rsync allowed access on module Backup-der-DS from DiskStation.fritz.box (2001:4c50:33f:a000:211:32ff:fe9b:bff3)
    3. 2018/12/23 14:57:30 [5444] rsync on Backup-der-DS/bck1/synobkpinfo.db from root@DiskStation.fritz.box (2001:4c50:33f:a000:211:32ff:fe9b:bff3)
    4. 2018/12/23 14:57:30 [5444] building file list
    Sowohl das NAS als auch der Linux Rechner hängen per LAN Kabel an einer Fritzbox. Es gibt weder im NAS noch in der Fritzbox einen User "root"

    Zum Einen möchte ich nicht das root Passwort im Klartext in einer Datei stehen haben und zum Anderen habe ich "herumgebastelt" bis es irgendwie lief (ohne tiefere Kenntnisse zu ssh, rsync). Daher meine Frage hier, wie man das "sauber" konfiguriert.

    Die rsync Einrichtungsseite im NAS, dort im Programm "Hyperbackup" siehe beigefügt.

    Danke und Gruß, Erich
    Bilder
    • Hyperbackup-rsync-setup.png

      54,4 kB, 613×508, 7 mal angesehen

    Für den Inhalt des Beitrages 127592 haftet ausdrücklich der jeweilige Autor: erich_s

    1. Mach deine Backups einfach als User und nicht als root.
      (Es ist IMMER eine SEHR SCHLECHTe Idee root als "Arbeitssklaven"account zu verwenden;
      richte dir notfalls lieber einen (System)User dafür ein.)
    2. Verwende für die SSH- Verbindung schlicht einen Key, statt Spasswort
      ssh-keygen erzeugt dir einen solchen Schlüssel. Gib dabei KEIN Spaswort an. Einfach jedesmal <Enter> drücken, statt Spassworteingabe. (Das Spasswort würde sonst bei jeder Verbindung, die mit diesem Schlüssel aufgebaut wird, abgefragt werden. Mit keinem (also einem leeren) Spasswort kann die Verbindung sehr schnell und ohne weiteres zutun aufgebaut werden.
    3. Übertrage den Key auf das Zielgerät mit ssh-copy-id
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 127594 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Das Passwort im Klartext in rsyncd.secrects zu schreiben konnte ich umgehen, diese Datei wird nur verwendet wenn in rsyncd.conf der Parameter "auth users" gesetzt ist. Den habe ich einfach weggelassen. Ansonsten habe ich einen "Backup User" angelegt um diese Backup Aktionen aus root und meinem eigenen Account rauszuhalten. Aber - nur root funktioniert über ssh. Beim Backup User finde ich im sshd log (über die Diensteverwaltung in YAST) dieses:

    Quellcode

    1. Dec 25 13:10:23 linux-611w sshd[25802]: Did not receive identification string from 2001:4c50:33f:a000:211:32ff:fe9b:bff3 port 43672
    2. Dec 25 13:10:23 linux-611w sshd[25803]: Did not receive identification string from 2001:4c50:33f:a000:211:32ff:fe9b:bff3 port 43674
    3. Dec 25 13:10:23 linux-611w sshd[25804]: Accepted keyboard-interactive/pam for root from 2001:4c50:33f:a000:211:32ff:fe9b:bff3 port 43676 ssh2
    4. Dec 25 13:10:43 linux-611w sshd[26581]: Did not receive identification string from 2001:4c50:33f:a000:211:32ff:fe9b:bff3 port 43678
    5. Dec 25 13:10:43 linux-611w sshd[26610]: Did not receive identification string from 2001:4c50:33f:a000:211:32ff:fe9b:bff3 port 43682
    Mein Workaround innerhalb meines LANs, ich gehe nicht über ssh sondern verwende rsync direkt (port 873), damit funktioniert es,d.h. ich kann Backups erstellen. Das reicht mir erstmal.
    Später würde ich das gerne auf ssh und Key umstellen, aber da muss ich noch ein bisschen forschen.

    Danke und Gruß, Erich

    Für den Inhalt des Beitrages 127649 haftet ausdrücklich der jeweilige Autor: erich_s