Samba-Authentifizierung - kein Zugang. Wie teste ich das weiter?

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Samba-Authentifizierung - kein Zugang. Wie teste ich das weiter? gibt es 5 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Samba-Authentifizierung - kein Zugang. Wie teste ich das weiter?

    Ich habe Probleme mit der Samba-Authentifizierung. Server ist Opensuse 15 bzw. 15.1. Ja, die User sind angelegt.
    Das komische ist, dass ich die gleiche smb.conf auf einem anderen PC erfolgreich verwende.

    testparm -v testet o.k.

    Wenn ich "valid users" weglasse, dann habe ich als Gast Zugang. Weder Root noch User bekommen Zugang. User1 ist angelegt und hat sich auch schon mal im System angemeldet. Wie kann ich weiter testen?

    Quellcode

    1. [global]
    2. ldap admin dn =
    3. passdb backend = tdbsam
    4. usershare allow guests = No
    5. wins server =
    6. wins support = No
    7. workgroup = netz4
    8. local master = yes
    9. security = user
    10. guest ok = yes
    11. guest account = nobody
    12. map to guest = bad user
    13. usershare allow guests = No
    14. unix extensions = yes
    15. [ArchivUser1]
    16. comment = ArchivUser1
    17. inherit acls = Yes
    18. path = /home/ArchivUser1
    19. read only = No
    20. valid users = user1
    21. vfs objects =
    22. browseable = Yes
    Alles anzeigen

    Für den Inhalt des Beitrages 133305 haftet ausdrücklich der jeweilige Autor: Find ich auch

  • Quellcode

    1. UUID=d7ec6bf1-9155-40a0-acff-19129f4c01cd / ext4 discard,acl,user_xattr 0 1
    2. UUID=f6f19dd2-4712-46c9-a235-670d9a1378ff /home ext4 discard,data=ordered,acl,user_xattr 0 2
    3. UUID=7decda28-78f6-4da3-a03a-ecd0054c2914 swap swap defaults 0 0
    4. UUID=50838ad6-15a5-4edb-a130-a43ae465c915 /home/samba ext4 acl,user_xattr 0 2
    Das ist die fstab. Vorher hatte ich di ePlatte mit Label eingebunden statt UUID und einfach nur defaults angegeben, macht aber keinen Unterschied.

    Was ich jetzt probiert habe ist "smbpasswd -a", also ein Samba-Kennwort für den User eingerichtet und es geht!!!. Das ist doch völlig verdreht. In der smb.conf steht eindeutig "passdb backend = tdbsam" Heißt das nicht, dass das Linux-Kennwort genommen wird ohne ein eigenes Samba-Kennwort?

    Für den Inhalt des Beitrages 133350 haftet ausdrücklich der jeweilige Autor: Find ich auch

  • Moinsen zusammen,

    nein, Samba will sein eigenes passwort haben, das liest die shadow (da stehen unter Linux die passwörter drin) nicht aus.
    Samba hat dazu lokal dann ein smbpasswd File aus dem es sich dann bedient. Das schaut leicht anders aus als die shadow :)
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 133358 haftet ausdrücklich der jeweilige Autor: Tamerlain