openVPN Client

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema openVPN Client gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • openVPN Client

    Hallo zusammen,
    ich versuche nun bereits einige Zeit mich mit meinem openVPN Server zu verbinden. Es will jedoch nicht funktionieren.

    Der VPN-Server läuft auf einer IPFire-Firewall. Dort habe ich auch die Clientdateien mit Schlüssel etc. erstellt.

    Mit diesem Zip bin ich auf meinem Laptop
    openSuse 15.1
    im NetworkManager mit + (ganz unten) auf "VPN-Verbindung importieren" gegangen und habe "meine.ovpn" Datei geöffnet.
    Die Dateien meine.ovpn und meine.p12 hatte ich zuvor in /etc/openvpn abgelegt und als root:root gekennzeichnet.

    Soweit sieht alles gut aus. Es gab noch eine Meldung im Zusammenhang mit dem Schlüssel.

    Wenn ich nun die Verbindung herstellen möchte sieht es so aus als ob eine Verbindung aufgebaut wird, jedoch nach ca. 60 Sec. bricht der Vorgang ab.

    mit tail -f /var/log/messages kommt beim Drücken der Verbindentaste:

    Quellcode

    1. 2019-09-10T16:12:30.769684+02:00 linux-gyob plasmashell[1729]: QDBusObjectPath: invalid path ""
    2. 2019-09-10T16:12:30.786913+02:00 linux-gyob kdeinit5[1688]: plasma-nm: Unhandled VPN connection state change: 2
    3. 2019-09-10T16:12:30.791140+02:00 linux-gyob kdeinit5[1688]: plasma-nm: Unhandled VPN connection state change: 3
    Info: ssh auf die Firewall funktioniert ohne Probleme.
    ein tail -f /var/log/messages auf dem VPB-Server bringt keine Anzeigen.

    Für mich sieht das im Moment so aus als ob der VPN-Client gar nicht hoch kommt.

    Was mache ich da falsch?
    MfG
    Switi vom Bienwald
    openSuse 15.0
    PostgreSQL 10.0

    Für den Inhalt des Beitrages 135692 haftet ausdrücklich der jeweilige Autor: heidieswi

  • Moin zusammen,

    also den Schlotz habe ich auch gehabt.

    Der Network Manager scheint was VPN angeht der Dödel vom Dienst zu sein - Username und Passwort zusätzlich providen zu müssen scheint den komplett zu überfordern.

    Ich hab mich damit nicht lang rumgärgert und mir ein Script geschrieben, was mir den Tunnel öffnet.

    Du musst hierzu im /etc/openvpn den client.ovpn in eine client.conf umwandeln.
    Wenn Username und Pass auch verlangt wird, haue diese in eine .txt Datei, die Du nach Gusto benamsen kannst.
    Diese Datei hat genau 2 Zeilen. In der ersten steht der Username und in der 2. das Passwort. Lesbar ist diese Datei _ausschliesslich_ vom User Root! Also ein chmod 400 auf die Datei lassen.

    In der client.conf editierst Du ganz am Ende die .txt Datei ein mit : auth-user-pass /etc/openvpn/<wieaucimmer die bei Dir heisst>.txt

    Nun kannst Du entweder immer von Hand den Befehl /usr/sbin/openvpn --config /etc/openvpn/client.conf eingeben oder aber das in ein Script verbacken, welches Du dann mit dem Rootuser aufrufst, fertig.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 135699 haftet ausdrücklich der jeweilige Autor: Tamerlain

  • Hallo Sauerland, hallo sterun,

    die Ausgabe von journalctl -b | grep -i vpn:

    Quellcode

    1. Sep 16 19:34:37 linux-gyob NetworkManager[1163]: <info> [1568655277.7819] audit: op="connection-update" uuid="2c76d995-8acc-412b-a35e-ffa4f34c37d2" name="ZUhds1-TO-IPFire" args="vpn.data" pid=2540 uid=1000 result="success"
    2. Sep 16 19:34:45 linux-gyob NetworkManager[1163]: <info> [1568655285.1540] vpn-connection[0x55ec586a0340,2c76d995-8acc-412b-a35e-ffa4f34c37d2,"ZUhds1-TO-IPFire",0]: Started the VPN service, PID 2573
    3. Sep 16 19:34:45 linux-gyob NetworkManager[1163]: <info> [1568655285.1603] vpn-connection[0x55ec586a0340,2c76d995-8acc-412b-a35e-ffa4f34c37d2,"ZUhds1-TO-IPFire",0]: Saw the service appear; activating connection
    4. Sep 16 19:34:45 linux-gyob kdeinit5[2027]: plasma-nm: Unhandled VPN connection state change: 2
    5. Sep 16 19:34:45 linux-gyob kdeinit5[2027]: plasma-nm: Unhandled VPN connection state change: 3
    6. Sep 16 19:34:45 linux-gyob NetworkManager[1163]: <info> [1568655285.1729] vpn-connection[0x55ec586a0340,2c76d995-8acc-412b-a35e-ffa4f34c37d2,"ZUhds1-TO-IPFire",0]: VPN plugin: state changed: starting (3)
    7. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: OpenVPN 2.4.3 x86_64-suse-linux-gnu [SSL (OpenSSL)] [LZO] [LZ4] [EPOLL] [PKCS11] [MH/PKTINFO] [AEAD] built on Jun 20 2017
    8. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: library versions: OpenSSL 1.1.0i-fips 14 Aug 2018, LZO 2.10
    9. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
    10. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: WARNING: normally if you use --mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1400)
    11. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: TCP/UDP: Preserving recently used remote address: [AF_INET]91.67.205.153:1194
    12. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: UDP link local: (not bound)
    13. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: UDP link remote: [AF_INET]91.67.205.153:1194
    14. Sep 16 19:34:45 linux-gyob nm-openvpn[2576]: NOTE: UID/GID downgrade will be delayed because of --client, --pull, or --up-delay
    15. Sep 16 19:35:45 linux-gyob NetworkManager[1163]: <warn> [1568655345.0218] vpn-connection[0x55ec586a0340,2c76d995-8acc-412b-a35e-ffa4f34c37d2,"ZUhds1-TO-IPFire",0]: VPN connection: connect timeout exceeded.
    16. Sep 16 19:35:45 linux-gyob nm-openvpn-serv[2573]: Connect timer expired, disconnecting.
    17. Sep 16 19:35:45 linux-gyob nm-openvpn[2576]: TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
    18. Sep 16 19:35:45 linux-gyob nm-openvpn[2576]: TLS Error: TLS handshake failed
    19. Sep 16 19:35:45 linux-gyob nm-openvpn[2576]: SIGTERM[hard,tls-error] received, process exiting
    20. Sep 16 19:35:45 linux-gyob NetworkManager[1163]: <warn> [1568655345.0231] vpn-connection[0x55ec586a0340,2c76d995-8acc-412b-a35e-ffa4f34c37d2,"ZUhds1-TO-IPFire",0]: VPN plugin: failed: connect-failed (1)
    21. Sep 16 19:35:45 linux-gyob NetworkManager[1163]: <info> [1568655345.0234] vpn-connection[0x55ec586a0340,2c76d995-8acc-412b-a35e-ffa4f34c37d2,"ZUhds1-TO-IPFire",0]: VPN plugin: state changed: stopping (5)
    22. Sep 16 19:35:45 linux-gyob NetworkManager[1163]: <info> [1568655345.0234] vpn-connection[0x55ec586a0340,2c76d995-8acc-412b-a35e-ffa4f34c37d2,"ZUhds1-TO-IPFire",0]: VPN plugin: state changed: stopped (6)
    23. Sep 16 19:41:54 linux-gyob kdeinit5[2027]: plasma-nm: Setting name: "vpn"
    Alles anzeigen
    Ich sehe, dass die Zieladresse und -port sowie die mtu den Einstellungen des Servers entsprechen.
    Ist es nun so, dass der Client zwar hochfährt jedoch keine Antwort der Gegenstelle bekommt?
    MfG
    Switi vom Bienwald
    openSuse 15.0
    PostgreSQL 10.0

    Für den Inhalt des Beitrages 135795 haftet ausdrücklich der jeweilige Autor: heidieswi

  • Hallo Tamerlain,
    kann ich mit dieser Datei punkten? Sieht mir etwas dünn aus.

    Quellcode

    1. #OpenVPN Client conf
    2. tls-client
    3. client
    4. nobind
    5. dev tun
    6. proto udp
    7. tun-mtu 1400
    8. remote hdsipf.ddnss.de 1194
    9. pkcs12 ZUhds1.p12
    10. cipher AES-256-CBC
    11. auth SHA512
    12. verb 3
    13. remote-cert-tls server
    14. verify-x509-name fwhds.hds.gov name
    Alles anzeigen
    MfG
    Switi vom Bienwald
    openSuse 15.0
    PostgreSQL 10.0

    Für den Inhalt des Beitrages 135796 haftet ausdrücklich der jeweilige Autor: heidieswi

  • Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 135798 haftet ausdrücklich der jeweilige Autor: sterun

  • Moin zusammen,

    äh Heidi eher nicht ... da fehlt vielzuviel. pks12 ist ausserdem auch nicht grad die Wahl schlechthin

    Was hier massiv fehlt wären die User Credentials (einzufügen mit auth-user-pass <gefolgt/von/Datei/mit/Credentials>).
    Die Zertifikate werden hier üblicherweise mit ca, cert und key angegeben.
    Die remote IP Adresse des Server gegen den authentifiziert wird fehlt auch (einzufügen mit remote <ipadresse>).

    Ich connectem ich z.B. auch nicht per UDP oder TLS client sondern per proto tcp-client.

    Schau mal hier. Da ist eine Beispiel client.conf mit Erklärungen.
    Viele Grüße,
    T.

    Für den Inhalt des Beitrages 135808 haftet ausdrücklich der jeweilige Autor: Tamerlain