Kmail , Zugriff auf die einzelnen Ordner nicht möglich nach Update auf LEAP 15,1

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Kmail , Zugriff auf die einzelnen Ordner nicht möglich nach Update auf LEAP 15,1 gibt es 19 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Kmail , Zugriff auf die einzelnen Ordner nicht möglich nach Update auf LEAP 15,1

    Hallo Mitstreiter,
    ich bin schon lange mit open Suse unterwegs und mache regelmäßig die Updates.Jetzt habe ich von LEAP 42,2 auf LEAP 15,1 upgedated und habe Probleme mit Kmail. Ich kann auf die einzelnen Ordner nicht mehr zugreifen. Den Ordner Posteingang hat er eingestellt wenn ich Kmail starte, er zeigt auch die dort liegenden Mails an, aber ich kann auf andere Ordner nicht zugreifen. Kmail holt auch die Mails vom Server ab und legt sie in die entsprechenden Ordner ab, aber ich kann dort nicht darauf zugreifen. Was habe ich falsch gemacht. Dummerweise habe ich vor dem Update aus Kmail keine Sicherung gemacht. Mein altes Homverzeichnis hatte ich aber nicht gelöscht sondern nach 15,1 so übernommen. Ich hatte praktisch nur das Rootverzeichnis formatiert und neu aufbauen lassen.Da ich nicht so fitt bin mit dem System, dachte ich, mit dem neuen System und Kmail auf die alten Daten zugreifen zu können. Die Ordner sind genauso vorhanden, wie sie unter 42,2 angelegt waren. Kann mir jemand auf die Sprünge helfen. Vielen Dank

    Für den Inhalt des Beitrages 136798 haftet ausdrücklich der jeweilige Autor: wolass

  • Grüß dich

    Hier mal keine Hilfe zu deinem Problem, aber wenigstens eine Antwort auf die Frage, was du falsch gemacht hast (oder hättest besser machen können):
    1. Kein Backup (KMail) - hast du ja auch schon geschrieben
    2. Bei einem Distributions-Upgrade niemals eine Version überspringen - kann gut gehen oder auch nicht
    (Richtig gewesen wäre ein Upgrade auf openSUSE Leap 42.3 - dann 15.0 - dann erst 15.1)
    War nur ein Tipp für die Zukunft :)

    Zu KMail:
    KMail / FAQs Tipps und Tricks – KDE UserBase Wiki
    Vielleicht ist der eine- oder andere Lösungsansatz dort vorhanden.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 136799 haftet ausdrücklich der jeweilige Autor: sterun

  • Hi,

    Zwei Dinge: Ich habe auf einem Testrechner unlängst auch einmal eine Neuinstallation von 15.1 gemacht und dann von einer Sicherung aus die .local und die .config zurückgespielt. Danach waren alle Ordner im kmail da, aber die waren leer. Ich habe das dann nicht weiterverfolgt, der Rechner hat dann seinen Geist aufgegeben. ;) Aber ziemlich sicher stimmte anschließend der Pfad nicht mehr. In meinen Sicherungen liegen die Mails in home/.local/share/local-mail/inbox oder wie diese Ordner sonst noch heißen. Schau mal, wo die alten Gespeicherten jetzt sind. Dann schick Dir Testmails und prüf nach, wo die (jetzt) landen.

    Und: Auf meinem Hauptrechner mit Leap 15.1 spinnt der kmail seit einigen Wochen auch: ich hole Mails, aber er findet vermeintlich keine, obwohl ich über mein Smartphone von deren Existenz weiß. Dann muss ich den kmail schließen (selten mich abmelden) und wieder öffnen und alles ist da. Vielleicht hilft ja auch so etwas schon.

    Herzlichst, Gisela

    Für den Inhalt des Beitrages 136802 haftet ausdrücklich der jeweilige Autor: giff

  • giff schrieb:

    In meinen Sicherungen liegen die Mails in home/.local/share/local-mail/inbox oder wie diese Ordner sonst noch heißen.
    /home/USERNAME/.local usw....

    Wobei:
    Username wird gemappt zu ID des Users, 1. User 1000, 2. User zu 1001 usw.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 136804 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Vielen Dank für Eure Tips!
    Unter folgendem Verzeichnis finde ich die Mails:/home/USERNAME/.local/share/.local-mail.directory/.Posteingang.directory/, in entsprechenden cur, new und tmp Unterverzeichnissen. Aber die Frage ist warum ich unter KMAIL darauf nicht zugreifen kann. Eine testweise versendete Datei an mich selbst versendet er, kommt auch an, wird im entsprechenden Ordner abgelegt, aber ich kann den Ordner nicht öffnen?????

    Vielen Dank für Euer Mitdenken !!

    Für den Inhalt des Beitrages 136810 haftet ausdrücklich der jeweilige Autor: wolass

  • N'Abend,

    Ich kann mir da nicht ganz einen Reim darauf machen, wie dieses "ich kann den Ordner nicht öffnen" aussieht. Keinen einzigen? Kommt eine Fehlermeldung? Wie viele Mailadressen (mithin Eingangs-, Ausgangs, - Sentmail- und Entwürfeordner) hast Du im kmail? Überall dasselbe?
    Ich würde jetzt wohl versuchen, einen neuen Benutzer anzulegen, dort den jungfräulichen kmail mit einer Deiner Email-Adressen einzurichten und dann zu sehen, was passiert. Wenn dort artig die Ordner aufgehen und ihre Arbeit verrichten, wissen wir schon mal mehr.

    Herzlichst, G.

    Für den Inhalt des Beitrages 136812 haftet ausdrücklich der jeweilige Autor: giff

  • Hallo Gisela,
    wenn ich KMAIL starte ist grün unterlegt der Posteingang und ich sehe 6 Emails für die ich keine Ordner angelegt habe. In andere ÜberOrdner z.B "Freunde", wo ich Unterordner angelegt habe in die die Emails der unterschiedlichen Freunde abgelegt werden. Je ein Freund unter "Freunde" hat einen eigenen Ordner. Ich mag es nicht, wenn Emails von unterschiedlichen Absendern in einen Ordner laufen. Wenn ich auf die Ordner mit dem Curser gehe und anklicke tut sich nichts. Ich bekomme auch keine Fehlermeldung.
    Gehe ich mit dem Cursor auf den Ordner Posteingang und klicke die rechte Maustaste kann ich einen weiteren Unterordner versuchen anzulegen. Es kommt eine Maske wo ich einen neuen Ordner eingeben kann. Klicke ich dann, legt er ihn nicht an.
    Was heißt das einen neuen Benutzer anzulegen? Für mich persönlich habe ich nur eine Email.
    Kann es sein das akonadi in irgendeiner Form noch damit zu tun hat?

    Liebe Grüße W

    Für den Inhalt des Beitrages 136813 haftet ausdrücklich der jeweilige Autor: wolass

  • Hallo, W.,
    Das klingt einigermaßen kompliziert. Meine Ordner sind nach meinen drei E-Mail-Adressen spezifiziert und in Unterordner schiebe ich Mails gegebenenfalls von Hand. Bei den Einstellungen (Identitäten, Versand und Empfang) stehen exakt die erforderlichen Daten der Mailserver drin und die ausgehenden und hereinkommenden Mails werden vom Rechner automatisch in den entsprechenden Ordnern unter /home/benutzer/.local/share/local-mail/ abgelegt. Hat Dein System unter 42.3 so funktioniert, wie Du das beschreibst?

    Neuen Benutzer anlegen: Den Yast aufrufen und dort unter "Benutzer und Gruppenverwaltung" auf "hinzufügen" klicken und einen neuen Benutzer (irgendein Name mit Passwort) einrichten. Beim Booten kannst Du dann wählen, ob Du oder der "neue" Benutzer angemeldet werden. Und da kannst Du den kmail testhalber neu einrichten. Da gibt es ja sogar einen Assistenten, der Dir für eine Email-Adresse die entsprechenden Ordner anlegt. Es genügt, glaube ich, Adresse und Passwort einzugeben. Wenn Du dann senden und empfangen kannst und diese Mails dann sauber in den entsprechenden Ordnern wiederfindest, kannst Du die Konfiguration dieses "Test-kmail" mit Deiner "richtigen" vergleichen.

    Herzlichst, G.

    Für den Inhalt des Beitrages 136814 haftet ausdrücklich der jeweilige Autor: giff

  • Hallo Gisela,
    ich habe wie Du geraten hast, einen neuen User angelegt. Habe Kmail auf meine Email-Adresse gesetzt und getestet. Ich kann in alle Ordner klicken, Mail versenden an mich , die auch ankommt. Also bei dem Testuser funktioniert es.Im Moment überlege ich, meinen User neu anzulegen, somit auch Kmail. Meine alten Emails habe ich gefunden und habe sie auch entsprechend gesichert, sodaß ich sie entsprechend umkopieren könnte. Etwas aufwändiger wäre es LEAP 15.1 neu zu installieren und auch die entsprechenden Partitionen zu verändern. Im Moment hat die swap Partition 2GB, / (root) 200GB und das /home Verzeichnis 535GB.
    Was mir noch auffiel war, das die Mails des neuen Testusers im Verzeichnis /home/User/.local/share/local-mail lagen, in meinem User unter
    /home/User/local/share/.local-mail.directory. Ich habe dann das Verzeichnis mit den aktuellen Mails nach /home/User/.local/share/local-mail/ verschoben, was aber an dem Effekt, das ich auf die Ordner unter Kmail nicht zugreifen konnte, nichts geändert hat. Was das Beste von beiden Alternativen ist weiß ich im Moment noch nicht.
    Vielen Dank aber für das Mitdenken und die Hilfe
    Wolfgang

    Für den Inhalt des Beitrages 136824 haftet ausdrücklich der jeweilige Autor: wolass