Kann nur noch nach Biosreset Opensuse Leap 15.1 mit Kernel 5.5.6-2.1 starten

Hinweis: In dem Thema Kann nur noch nach Biosreset Opensuse Leap 15.1 mit Kernel 5.5.6-2.1 starten gibt es 4 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo,


    nachdem ich mit Forumshilfe meinen neuen Computer im Wesentlichen aus bestehend aus einem Asrock Deskmini A300 und einem AMD Ryzen 5 3400G gut zum Laufen bekommen habe, habe ich doch ein recht massives Problem. Auf Empfehlung habe ich den Kernel von 4. irgendwas auf 5.5.6-2.1 upgedatet.
    Nach einem Neustart kam ich noch nichtmal mehr ins Bios und hätte um ein Haar die Hardware wieder zurückgeschickt. Dann habe ich aber das Bios mittels eines Jumpers resettet und schon startet das Gerät und der neue Kernel läuft ganz prima - bis zum nächsten Start. Mit dem 4er Kernel hatte ich dieses Problem nicht.
    Im Grunde bin ich mehr als verwundert, dass offensichtlich irgendwas ins Bios geschrieben wird, was die Kiste zum Erliegen bringt.


    Hat jemand eine Idee, woran das liegen könnte?


    LG


    Paul

  • Problem vorläufig gelöst, obwohl ich nicht wirklich weiß, was ich da getan habe.


    Ich habe Folgendes gemacht:
    1. In Yast--> Bootloader-Einstellungen--> Bootcode-Optionen den Bootloader von GRUB2 für EFI auf GRUB2 umgestellt.
    2. Dann 'Aus Partition booten' angehakt. 'Aktiv-Flag in Partitionstabelle für Bootpartition setzen' und 'Generischen Bootcode in MBR schreiben' angehakt gelassen. Flag für geschützen MBR auf 'setzen' gestellt.
    3. neu gestartet. Dann musste wieder das Bios resettet werden.
    4. Dann kam ich ins Bios, konnte aber nicht weiter starten, weil offensichtlich kein OS gefunden wurde.
    5. Im Bios unter Boot den 'CSM-Support' aktiviert und darin noch zwei weitere Einstellungen, die ich nicht kannte und auch nicht mehr erinnere, mit 'legacy only' aktiviert.


    Jetzt komme ich auf eine grafisch nicht mehr ganz so schöne Grub-Auswahlmöglichkeit und kann von da aus den Rechner starten. Das funktioniert jetzt auch bei einem Neustart.


    Insgesamt habe ich hier eher nach der Versuch und Irrtum Methode gearbeitet. Vielleicht gibt es jemanden, der die Vorgehensweise oder Einstellungen noch verbessern oder zumindest erklären kann.


    Gruß


    Paul

  • Jetzt komme ich auf eine grafisch nicht mehr ganz so schöne Grub-Auswahlmöglichkeit und kann von da aus den Rechner starten. Das funktioniert jetzt auch bei einem Neustart.

    Da kann ich Dir weiterhelfen.
    yast > Bootlader > Kernelparameter > Konsolenthema > Durchsuchen
    Da kommt als Vorschlag:
    /boot/grub2/themes/openSUSE/theme.txt
    das übernehmen.

  • Danke @sterun
    Mein Jahr 2000 Problem war: 2000 da bist Du 44 Jahre alt.
    Heute fühle ich mich noch jung.
    Und die Sonne geht jeden Morgen auf.
    Selbst wenn es neblig ist, wird es hell.
    Aber im Juni sollen schöne Sommertage kommen.
    Das haben die Wettermacher gesagt. ;)