OpenSuse startet mit tty1 und nicht mit tty7 (Graphisch)

Hinweis: In dem Thema OpenSuse startet mit tty1 und nicht mit tty7 (Graphisch) gibt es 17 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo!


    Vor 3 Tagen habe ich ein tumbleweed Update (20200520) gemacht. Dieses Update habe ich in der tty2 gemacht (ich bin das von arch/manjaro gewöhnt, updates ohne grafische Oberfläche zu machen).

    Nach einem Neustart bot mir das System an, mich in der tty1 einzuloggen. Natürlich konnte ich mit STRG + ALT + F7 in die graphische Oberfläche (GNOME) wechseln und mich dort einloggen. Allerdings konnte ich keine Einstellung im YaST finden, wo die default-Einstellung zum Login änderbar war. Ich habe also ein readonly-Snapshot gebootet und das System mittels sudo snapper rollback auf den Zustand vor dem Update gebracht. Nach einem Neustart wurde per default wieder die graphische Oberfläche zum Einloggen angeboten.


    Heute habe ich erneut ein Update (20200523) gemacht. Dieses wurde ebenfalls in der tty2 ausgeführt. Der Fehler tritt erneut ein. Nach dem Neustart bot mir das System per default die tty1 zum Einloggen an.


    tl;dr

    Wo kann ich einstellen, dass per default immer die tty7 (grafische Oberfläche) zum Einloggen angeboten wird?

    Besten Dank für eure Hilfe!

    AlphaLemmi

    Für den Inhalt des Beitrages 280323 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • @Sauerland

    Kann es auch hiermit zu tun haben?


    Was ergibt bei AlphaLemmi

    systemctl get-default

    Sollte so aussehen:

    Code
    systemctl get-default
    graphical.target

    Für den Inhalt des Beitrages 280348 haftet ausdrücklich der jeweilige Autor: sterun

  • Ja, könnte auch damit zu tun haben.

    Für den Inhalt des Beitrages 280349 haftet ausdrücklich der jeweilige Autor: tomfa-ng

  • @Sauerland

    Es läuft GNOME 3.36.2 auf x11 (X.Org 1.20.8)

    Code
    tux:/home/felix # update-alternatives --display default-displaymanager
    default-displaymanager - auto mode
    link best version is /usr/lib/X11/displaymanagers/gdm
    link currently points to /usr/lib/X11/displaymanagers/gdm
    link default-displaymanager is /usr/lib/X11/displaymanagers/default-displaymanager
    /usr/lib/X11/displaymanagers/console - priority 5
    /usr/lib/X11/displaymanagers/gdm - priority 25
    /usr/lib/X11/displaymanagers/lightdm - priority 15
    /usr/lib/X11/displaymanagers/xdm - priority 10


    sterun

    Sieht bei mir auch so aus:

    Code
    tux:/home/felix # systemctl get-default
    graphical.target


    Hilft das weiter?

    Für den Inhalt des Beitrages 280372 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • Mit dem neuen Update (heute eingespielt) hat sich der Zustand leider nicht geändert. Startet immer noch in der tty1

    @Sauerland  sterun  @tomfa-ng

    Für den Inhalt des Beitrages 280427 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • Poste mal:

    Code
    cat /etc/systemd/system/graphical.target.wants/display-manager.service

    Für den Inhalt des Beitrages 280430 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ebenso:

    Code
    cat /etc/gdm/custom.conf

    Für den Inhalt des Beitrages 280446 haftet ausdrücklich der jeweilige Autor: Sauerland

  • @Sauerland


    Sowie:

    Für den Inhalt des Beitrages 280463 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • Schon weitergekommen?

    Die obigen Angaben sehen „normal“ aus. Die Ausgaben von

    Code
    cat /etc/sysconfig/displaymanager

    (statt cat kann auch less oder more usw. genommen werden)

    und

    Code
    journalctl --system | grep -Ei -B5 -A15"dracut|error"
    Code
    journalctl --system | grep -Ei -B5 -A10 "plymouth"

    könnten eventuell noch Hinweise enthalten.


    So nebenbei, die Ein- und Ausgaben sind auch wirklich vom „defektem“ Tumbleweed?

    Für den Inhalt des Beitrages 280552 haftet ausdrücklich der jeweilige Autor: tomfa-ng