zypper: error while loading shared libraries

Hinweis: In dem Thema zypper: error while loading shared libraries gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo Zäma,


    auf meinem Laptop ist opensuse 15.3 installiert. Diesen Rechner benütze ich nicht sehr oft, muss aber etwas verbogen haben, denn ich kann keine Softwareupdate unter dem Netzwerkmanager durchführen:

    Info heißt, dass ich keinen Netzzugang habe, obwohl alles zum Internet hin funktioniert - mail, web uvm.

    Code
    zypper lr -d
    zypper: error while loading shared libraries: /usr/lib64/libzypp.so.1722: file too short

    unter YAST sieht das so aus:

    Code
    Internal error. Please report a bug report with logs.
    Run save_y2logs to get complete logs.
    Caller: /usr/lib64/ruby/vendor_ruby/2.5.0/yast/yast.rb:186:in `import_pure'
    Details: component cannot import namespace 'Pkg'

    Ich weiß nicht, was ich wo drehen soll; hat mir jemand einen Tipp?


    Danke für jede Information


    zappa.frank

  • Hallo zappa.frank ; Was passiert nach

    Code
    zypper clean -a && zypper ref

    ?

    Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt. Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

    Für den Inhalt des Beitrages 291396 haftet ausdrücklich der jeweilige Autor: Heinz-Peter

  • Ist da was falsch - Version

    Die ist von Leap 15.2

    Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt. Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

    Für den Inhalt des Beitrages 291399 haftet ausdrücklich der jeweilige Autor: Heinz-Peter

  • Oh, danke. Ich dachte ich hätte auf dem Laptop schon 15.3.

    okay, was läuft falsch?

    Code
    cat /etc/*release*
    NAME="openSUSE Leap"
    VERSION="15.2"
  • Vielleicht habe ich mal eine one-klick Installation durchgeführt und die hat alles durchgeschüttelt??

  • zappa.frank ; Kannst Du Yast öffnen?

    Falls nein dann hätte ich 15.3 installiert.


    Die 15.2 läuft aus.


    Grüße, Heinz-Peter

    Die Rechtschreibfehler in diesem Beitrag sind nicht urheberrechtlich geschützt. Jeder der einen findet darf ihn behalten und in eigenen Werken weiterverwenden.

    Für den Inhalt des Beitrages 291408 haftet ausdrücklich der jeweilige Autor: Heinz-Peter

  • Yast _ alles was mit Software zu tun hat - Fehler siehe oben; 2 code


    Ich verstehe das nicht - habe noch einen zweiten Laptop und da funktioniert alles. Okay, mich würde schon interessieren, wo da der Wurm drin ist.