Deaktivieren der ATI-Grafik im Notebook.

Hinweis: In dem Thema Deaktivieren der ATI-Grafik im Notebook. gibt es 3 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo Leute,


    ich bin jetzt nach ein paar Jahren Ubuntu mal wieder zur guten alten SuSE gewechselt. Leider gibt es da ein Problem mit den "Grafikkarten" in meinem Notebook. Ich habe eine Core I5 mit Intel HD Grafik und zusätzlich einen ATI Chip mit eigenem Ram in meinem Notebook. Wenn ich jetzt :


    Code
    sudo cat /sys/kernel/debug/vgaswitcheroo/switch


    eingebe, dann kommt folgendes:


    Code
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Pwr:0000:01:00.0


    Also stehen beide Grafikchips unter Strom und die interne Intel-Grafik ist die aktive.
    Das würde mich jetzt nicht stören, aber dadurch verbraucht das Notebook ziemlich viel Strom, und der Lüfter dreht sich einen Wolf. Selbst wenn kaum Last anliegt.
    Unter Ubuntu konnte man man das damit regeln:


    Code
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 acpi_backlight=vendor acpi_osi=Linux"


    Und danach GRUB aktualisieren. Klappt hier irgendwie nicht mehr. Das Kommando


    Code
    sudo update-grub


    funktioniert nicht.


    Kann mir da jemand helfen?


    Gruß Rene´

    Für den Inhalt des Beitrages 55795 haftet ausdrücklich der jeweilige Autor: ReneK71

  • openSUSE verwendet Grub2.


    Du kannst die Parameter auch im Yast-----System-----Bootloader-----Bootloader-Optionen einfügen.

    Für den Inhalt des Beitrages 55798 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo Sauerland,


    dass werde ich mal in aller Ruhe probieren. Danke, an Yast hatte ich noch gar nicht gedacht.


    Gruß René

    Für den Inhalt des Beitrages 55800 haftet ausdrücklich der jeweilige Autor: ReneK71

  • Tja, ich habe es ausprobiert, die Bootparameter über Yast an Grub zu übergeben, neu gebootet und immer noch rauschen im Blätterwald. vgaswitcheroo gibt immer noch die gleiche Meldung aus. Es werden beide Grafikchips betrieben. Hier mal die modifizierte Zeile, die ich über Yast eingegeben habe. Evtl fällt da jemandem was auf.

    Code
    resume=/dev/disk/by-id/ata-WDC_WD7500BPVT-60HXZT1_WD-WXB1A31J9244-part5 splash=silent quiet showopts pcie_aspm=force i915.i915_enable_rc6=1 i915.i915_enable_fbc=1 i915.lvds_downclock=1 acpi_backlight=vendor acpi_osi=Linux


    Ich möchte ja schon noch ne Weile bei openSuSE bleiben, aber so geht das nicht. Was mache ich falsch?


    Gruß René

    Für den Inhalt des Beitrages 55818 haftet ausdrücklich der jeweilige Autor: ReneK71