[cifs] mount error(22): Invalid argument

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema [cifs] mount error(22): Invalid argument gibt es 16 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • [cifs] mount error(22): Invalid argument

    Hallo,

    beim Versuch, ein Samba-Share mit der Option vers=3.0 zu mounten (ohne "vers" funktinoiert es), erhalte ich die Fehlermeldung:

    mount error(22): Invalid argument

    bzw. den Eintrag

    CIFS VFS: Unknown vers= option specified: 3.0

    in /var/log/messages.

    System ist 13.2

    Für den Inhalt des Beitrages 97517 haftet ausdrücklich der jeweilige Autor: rabe2

  • rabe2 schrieb:

    beim Versuch, ein Samba-Share mit der Option vers=3.0 zu mounten (ohne "vers" funktinoiert es), erhalte ich die Fehlermeldung:
    mount error(22): Invalid argument
    wie lautet dein vollständiger mount-befehl? Root-Konsole oder fstab?

    Bitte ALLES (prompt/Befehl/Fehlermeldung) hier in Codetags posten!
    There's no place like 127.0.0.1

    Für den Inhalt des Beitrages 97519 haftet ausdrücklich der jeweilige Autor: wurzel99

  • Weder man mount noch man fstab geben vers= als Option her. Was auch immer du erreichen möchtest, so geht es nicht.

    flo
    Auch zu finden bei der Mailingliste opensuse-de sowie im IRC als User grossing in den Netzwerken freenode und oftc - querys sind erlaubt, die Antwort kann dauern ;)

    Der Channel zum Forum: ##os-forum auf irc.freenode.net
    Per webchat webchat.freenode.net/##os-forum

    Alle von mir genannten Befehle sind als User auszuführen, außer ich schreibe explizit dazu "als root ausführen"!

    Meine Homepage

    Für den Inhalt des Beitrages 97520 haftet ausdrücklich der jeweilige Autor: grossing

  • @grossing Du hast recht, aber die Option existiert für

    Quellcode

    1. man mount.cifs

    @rabe2 Ansonsten schliesse ich mich meinen Vorrednern an. Das gewünschte Verzeichnis kannst Du auch zunächst manuell einfach durch

    Quellcode

    1. mount -t cifs -o username=[USERNAME],password=[PASSWORT],uid=[USERID],gid=[GROUPID] //[SERVER]/[VERZEICHNIS] [MOUNTPOINT]
    einbinden. Details dazu findest Du in den man-pages. Es gibt einige weitere Möglichkeiten, dass das automatisch bereits beim Anmelden erfolgt, oder auch erst dann wenn Du auf den Mountpoint zugreifst. Dazu musst Du aber genau das tun was grossing und wurzel99 schon geschrieben haben.
    be tolerant - not ignorant
    Alle Hunde sind schwarz.
    Es gibt einen Hund der nicht weiß ist.

    Für den Inhalt des Beitrages 97523 haftet ausdrücklich der jeweilige Autor: Boreas

  • wurzel99 schrieb:

    wie lautet dein vollständiger mount-befehl? Root-Konsole oder fstab?

    Quellcode

    1. //XXX.de/scratch /home/XXX/scratch cifs _netdev,rw,credentials=/root/samba/credentials-X,uid=XXX,gid=users,iocharset=utf8,user 0 0
    Diese Zeile in /etc/fstab funktioniert ohne Probleme. Füge ich vers=3.0 hinzu, kommt die genannte Fehlermeldung. Es geht also nicht um das manuelle oder automatische Mounten als solches, sondern um die Option vers=3.0, die laut

    Quellcode

    1. man mount.cifs

    sehr wohl existiert.

    Ich betreibe einen Server unter CentOS 7, da funktioniert die Option vers=3.0 ohne Probleme, nur eben nicht unter OpenSuSE 13.2.

    P.S.: Ich antworte erst jetzt, weil ich trotz entsprechender Einstellung keine Benachrichtungsmail über Antworten hier im Forum erhalten habe.

    Für den Inhalt des Beitrages 97528 haftet ausdrücklich der jeweilige Autor: rabe2

  • Nachtrag:

    Quellcode

    1. mount /home/XXX/scratch/

    geht problemlos, aber nicht:


    Quellcode

    1. mount -o vers=3.0 /home/XXX/scratch/
    2. mount error(22): Invalid argument
    3. Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)
    Das gleiche Ergebnis natürlich auch, wenn man vers=3.0. direkt in fstab ergänzt.

    Für den Inhalt des Beitrages 97529 haftet ausdrücklich der jeweilige Autor: rabe2

  • rabe2 schrieb:

    Diese Zeile in /etc/fstab funktioniert ohne Probleme. Füge ich vers=3.0 hinzu, kommt die genannte Fehlermeldung. Es geht also nicht um das manuelle oder automatische Mounten als solches, sondern um die Option vers=3.0, die laut
    glaub ich wohl .. die Frage ist ja nur ab es sowohl in der Konsole oder auch in der fastb schief geht

    rabe2 schrieb:

    Ich betreibe einen Server unter CentOS 7, da funktioniert die Option vers=3.0 ohne Probleme, nur eben nicht unter OpenSuSE 13.2.
    das riecht sehr nach einem bug .. also bugreport schreiben! Ob das aber für die 13.2 noch bearbeitet wird wage ich zu bezweifeln.
    There's no place like 127.0.0.1

    Für den Inhalt des Beitrages 97530 haftet ausdrücklich der jeweilige Autor: wurzel99

  • was gibt

    Quellcode

    1. mount.cifs -V

    aus? Bei mir erscheint

    Quellcode

    1. mount.cifs version: 6.4
    be tolerant - not ignorant
    Alle Hunde sind schwarz.
    Es gibt einen Hund der nicht weiß ist.

    Für den Inhalt des Beitrages 97533 haftet ausdrücklich der jeweilige Autor: Boreas