Leap 15 will anscheinend keine VirtualBox

Hinweis: In dem Thema Leap 15 will anscheinend keine VirtualBox gibt es 13 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,
    ich wieder einmal. :)


    OpenSUSE Leap 15.0, installiert am Freitag, den 25.05.2018 abends, will scheinbar kein VirtualBox in sich haben. :)


    Folgendes habe ich versucht:


    1. Repo einbinden: http(s)://download.virtualbox.org/virtualbox/rpm/opensuse/42.1/ Virtualbox-Repo (Link auf 13.2). Das hat bei 42.x funktioniert.
    Das Repo wird nicht akzeptiert.


    2. RPM von Oracle downloaded und nach /opt/RPMs/ (lokales Repo-Verzeichnis) kopiert. Das hat bisher auch immer funktioniert.
    Hier wird eine fehlende Abhängigkeit namens libvpx.so.1()(64bit) bemängelt, die nirgens existiert (auch mit Anbieterwechsel erlaubt nicht) . Eine libvpx.so.4 existiert in /usr/lib64/.


    3. Das in SUSE integrierte Virtualbox habe ich noch nie richtig zum Laufen bekommen, das Problem mit USB.
    Ich habe es trotzdem probiert. Hier soll ein Kernel-Downgrade gemacht werden, von 1.12.14-lp150.12.4.1 auf .....11.4. Aber was passiert dann, wenn der Kernel wieder updatet wird?


    Hat jemand eine Idee?
    Soll ich noch ein paar Updates abwarten?
    Ist das sonst noch jemandem aufgefallen?


    Viele Grüße
    Wolle

    Hauptsystem: Gigabyte B365M D3H - i5 9600K - Grafik UHD 630 - 32 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 1 x SSD (sda) - 2 x HD (sdb/sdc) - IDE-->USB-DVD (intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) + Terra 24" (1920x1080 matt) - Canon Pixma MX925 - HP Scanjet G4050


    TUXEDO Book BC1707: i7-8750H - UHD-Grafik 630 - 17,3" Display (Full-HD-IPS-matt) - 16 GB RAM - 2 x SSD Samsung 860 EVO (M.2 SATA III und SATA III) - WLAN & BT Intel Dual AC 9260 & BT 5

    Für den Inhalt des Beitrages 120895 haftet ausdrücklich der jeweilige Autor: Wolle1956

  • Ich würde es mal mit dem offiziellen Leap-15 Virtualbox Repo versuchen:


    Code
    zypper ar https://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/ openSUSE-Leap-15.0-Virtualbox


    Zur Info:
    Show Virtualization / virtualbox - openSUSE Build Service


    Möglicherweise sind die USB Probleme die Du hattest in der offiziellen Version nun nicht mehr vorhanden - ein Versuch schadet nie.

    Einmal editiert, zuletzt von wn48z ()

    Für den Inhalt des Beitrages 120898 haftet ausdrücklich der jeweilige Autor: wn48z

  • Ist nicht offitziell, eher semioffiziell....


    Braucht man auch nicht, Virtualbox ist im OSS Repo:



    Code
    zypper in virtualbox virtualbox-qt virtualbox-host-kmp-default

    PS:
    Es gibt kein Problem mit USB, man muss nur Hand anlegen:


    Zitat

    From openSUSE 11.4 on USB devices attached to the host can be used in guest operating systems after removing the '#' character in the last 2 lines of /etc/udev/rules.d/60-vboxdrv.rules. After a reboot USB support will work. Please consider the security risks this might cause.


    VirtualBox - openSUSE


    So sieht das dann bei mir aus:


    Code
    cat /etc/udev/rules.d/60-vboxdrv.rules
    KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="root", MODE="0600"
    KERNEL=="vboxdrvu", NAME="vboxdrvu", OWNER="root", GROUP="root", MODE="0666"
    KERNEL=="vboxnetctl", NAME="vboxnetctl", OWNER="root", GROUP="root", MODE="0600"
    SUBSYSTEM=="usb_device", ACTION=="add", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
    SUBSYSTEM=="usb", ACTION=="add", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh $major $minor $attr{bDeviceClass}"
    SUBSYSTEM=="usb_device", ACTION=="remove", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"
    SUBSYSTEM=="usb", ACTION=="remove", ENV{DEVTYPE}=="usb_device", RUN+="/usr/lib/virtualbox/VBoxCreateUSBNode.sh --remove $major $minor"

    Für den Inhalt des Beitrages 120899 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Das geht aber nur wenn man den "out of the box" Kernel benutzt. Der kommt aber nicht mit meiner Tastaurbeleuchtung klar (und noch andere Gründe) ;) daher hab ich Kernel-Stable, sprich 4.16.12.
    Und da hab ich VB bisher auch noch net zum Laufen bekommen, bin aber noch am basteln. Nu erstmal die anderen Baustellen, gibt noch paar Ungereimtheiten unter 15.0.

    Index of /repositories/Kernel:/stable:/KMP/standard
    Hier auf Leap 42.3:

    virtualbox-qt aus Kernel-stable-kmp funktioniert nicht, daher das aus dem Virtualization Repo.....



    Sollte aber bei Leap 15.0 kein Problem darstellen.....

    Für den Inhalt des Beitrages 120906 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Ich würde es mal mit dem offiziellen Leap-15 Virtualbox Repo versuchen:


    Code
    zypper ar https://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/ openSUSE-Leap-15.0-Virtualbox


    Zur Info:
    Show Virtualization / virtualbox - openSUSE Build Service


    Möglicherweise sind die USB Probleme die Du hattest in der offiziellen Version nun nicht mehr vorhanden - ein Versuch schadet nie.

    Das gibt es nicht mehr: Objekt nicht mehr verfügbar!
    Den gibt es, aber ich glaube, der hat nix mit VBox zu tun:


    Code
    http://download.opensuse.org/repositories/Virtualization/openSUSE_Leap_15.0/Virtualization.repo

    Ich werde es mal überprüfen.



    @Sauerland


    Das aus dem OSS-Repo will einen Kernel-Downgrade, schaue bitte nochmal unter Punkt 3.
    Deine Links werde ich mir aber ansehen. Hoffentlich ist das einfaches Englisch. :) Danke.



    Das geht aber nur wenn man den "out of the box" Kernel benutzt. Der kommt aber nicht mit meiner Tastaurbeleuchtung klar (und noch andere Gründe) ;) daher hab ich Kernel-Stable, sprich 4.16.12.
    Und da hab ich VB bisher auch noch net zum Laufen bekommen, bin aber noch am basteln. Nu erstmal die anderen Baustellen, gibt noch paar Ungereimtheiten unter 15.0.

    Den habe ich unter 42.3 und auch noch die 4 Repos KDE5 und Mozilla. Das lief alles bestens (einschl. Oracle VBox) bis eine Woche vor dem Erscheinen von 15.0. Seit dem Update ist kwin kaputt.
    Egal jetzt sind wir bei 15.0, und da wollte ich alles wieder beim Standard belassen.


    Was ist ein Out-of-the-Box-Kernel. Ist das der Vanilla?


    Danke euch und Gruß
    Wolle

    Hauptsystem: Gigabyte B365M D3H - i5 9600K - Grafik UHD 630 - 32 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 1 x SSD (sda) - 2 x HD (sdb/sdc) - IDE-->USB-DVD (intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) + Terra 24" (1920x1080 matt) - Canon Pixma MX925 - HP Scanjet G4050


    TUXEDO Book BC1707: i7-8750H - UHD-Grafik 630 - 17,3" Display (Full-HD-IPS-matt) - 16 GB RAM - 2 x SSD Samsung 860 EVO (M.2 SATA III und SATA III) - WLAN & BT Intel Dual AC 9260 & BT 5

    Für den Inhalt des Beitrages 120907 haftet ausdrücklich der jeweilige Autor: Wolle1956

  • Das aus dem OSS-Repo will einen Kernel-Downgrade, schaue bitte nochmal unter Punkt 3.
    Deine Links werde ich mir aber ansehen. Hoffentlich ist das einfaches Englisch. Danke.

    Dann lass es doch downgraden, bei mir läuft es auch......
    Ist übrigens derselbe kernel........


    Und lass die Finger von kernel-stable.......

    Für den Inhalt des Beitrages 120908 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Thema vorrübergehend geschlossen.


    2 Beiträge von HarryMalaria verschoben.


    Thema wieder geöffnet.

    Für den Inhalt des Beitrages 120941 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hallo auch,


    danke für die vielen Antworten.
    VirtualBox im OSS isr wohl nur etwas für die Profis hier, und das bin ich leider nicht.
    Ich warte mal Updates ab, ob sich da etwas ändert.


    Also erstmal danke.
    Gruß,
    Wolle

    Hauptsystem: Gigabyte B365M D3H - i5 9600K - Grafik UHD 630 - 32 GB DDR4 - TechniSat SkyStar 2 (DVB-S2) (PCI-alte Rev.) - 1 x SSD (sda) - 2 x HD (sdb/sdc) - IDE-->USB-DVD (intern) - iiyama xub3490wqsu 34" 21:9 (3440x1440 matt) + Terra 24" (1920x1080 matt) - Canon Pixma MX925 - HP Scanjet G4050


    TUXEDO Book BC1707: i7-8750H - UHD-Grafik 630 - 17,3" Display (Full-HD-IPS-matt) - 16 GB RAM - 2 x SSD Samsung 860 EVO (M.2 SATA III und SATA III) - WLAN & BT Intel Dual AC 9260 & BT 5

    Für den Inhalt des Beitrages 121053 haftet ausdrücklich der jeweilige Autor: Wolle1956

  • VirtualBox im OSS isr wohl nur etwas für die Profis hier, und das bin ich leider nicht.

    Warum das?


    Du darfst dann nur nicht vergessen, Virtualbox aus dem Oracle Repo zu deinstallieren, falls das installiert ist.

    Für den Inhalt des Beitrages 121054 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Hier jetzt unter Leap 15.0:


    Code
    uname -a
    Linux lenovo 4.12.14-lp150.12.4-default #1 SMP Tue May 22 05:17:22 UTC 2018 (66b2eda) x86_64 x86_64 x86_64 GNU/Linux


    Virtualbox funktioniert.

    Für den Inhalt des Beitrages 121055 haftet ausdrücklich der jeweilige Autor: Sauerland