Samba Server startet nicht unter Leap 15

Hinweis: In dem Thema Samba Server startet nicht unter Leap 15 gibt es 18 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    ich habe festgestellt, dass in meiner neu installierten Leap 15 der Samba Server nicht startet. Ich will den als Fileserver für Windows Clients benutzen und habe den Start von "manuell" auf "on Boot" umgestellt und die Firewall Ports geöffnet - alles über die grafische Oberfläche in Yast2. Jetzt habe ich gesehen dass der smb Dient nicht läuft und in der Dienste Verwaltung (in Yast2) diese Fehlermeldungen entdeckt:

    Ich bitte um Hilfe, wie ich das beheben kann.


    Danke und Gruß, Erich

    Für den Inhalt des Beitrages 125717 haftet ausdrücklich der jeweilige Autor: erich_s

  • Hallo Erich,


    den Dienst (als Root) schon mal neu gestartet?

    Code
    systemctl restart nmb smb

    Oder

    Code
    systemctl restart smb.service
    systemctl restart nmb.service

    Für den Inhalt des Beitrages 125718 haftet ausdrücklich der jeweilige Autor: sterun

  • Und du hast Leap 15 neu installiert?
    Also kein Upgrade?


    Ich frage, da es einen Bug (mit Lösung) bei einem Upgrade gibt.

    Für den Inhalt des Beitrages 125719 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo,


    ja ich habe Leap 15 vor einigen Monaten auf einer leeren Festplatte komplett neu installiert. Der Neustart Versuch führt bei SMB zum selben Fehler, NMB scheint zu gehen,. siehe

    Gruß, Erich

    Für den Inhalt des Beitrages 125720 haftet ausdrücklich der jeweilige Autor: erich_s

  • Process: 3799 ExecStart=/usr/sbin/smbd --foreground --no-process-group $SMBDOPTIONS (code=exited, status=255)

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 125721 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Ich habe keine Ahnung was die Zeile "Process 3799..." bedeutet. testparm sagt folgendes:


    Ich habe allerdings keine Windows Domäne, "WindowsData" ist die Freigabe die ich angelegt habe und auf die ich vom Windows Client aus zugreifen will.
    Wenn man "enter" drückt wird noch folgendes angezeigt:


    Gruß, Erich

    Für den Inhalt des Beitrages 125723 haftet ausdrücklich der jeweilige Autor: erich_s

  • Nach jeder Veränderung der Datei smb.conf sollte in einem Terminal der Befehl testparm ausgeführt werden um sicherzustellen, dass die Einträge keine grundlegenden Syntax-Fehler enthalten. Wird der Befehl testparm ohne Parameter ausgeführt, so werden nur die durch Einträge in der Datei smb.conf veränderten Optionen angezeigt. Der Befehl testparm -v bewirkt, dass außerdem auch die Default-Einstellungen angezeigt werden.

    Für den Inhalt des Beitrages 125724 haftet ausdrücklich der jeweilige Autor: sterun

  • Ahhh, mein Tablet Akku ist leer, kein Netzteil hier...
    Hast du alles selber konfiguriert?
    Auch Gruppen?
    Firewall testweise abgeschaltet?

    Code
    systemctl stop firewalld.service

    Und was sagt testparm -v
    Wie sieht deine smb.conf aus?

    Code
    /etc/samba/smb.conf

    Und hier etwas Lektüre:
    Samba | Reference | openSUSE Leap 15


    PS:
    Mein Akku = 5%
    Kann morgen erst wieder online gehen...

    2 Mal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 125725 haftet ausdrücklich der jeweilige Autor: sterun

  • Ich habe außer der WindowsData" Freigabe nichts konfiguriert, das war alles nach der Installation schon da. Für die Konfiguration habe ich immer die grafische Oberfläche in Yast2 benutzt, die smb.conf habe ich nicht editiert. Beigefügt der Output von testparm -v und die smb.conf. Firewall stoppen nützt nichts, gleicher Fehler.


    Gruß, Erich

    Dateien

    Für den Inhalt des Beitrages 125737 haftet ausdrücklich der jeweilige Autor: erich_s