Leap 15 Suspend Mode geht nicht

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Leap 15 Suspend Mode geht nicht gibt es 28 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Leap 15 Suspend Mode geht nicht

    Hallo,

    in meiner neuen Leap 15 Installation mit Gnome geht der Suspend Mode nicht mehr. Ich meine damit wenn ich das System über den Menüpunkt oben rechts am Bildschirm und gleichzeitigem Halten der "ALT" Taste in den Ruhemodus versetzen will. Bei OpenSuse 13.2 ging das noch problemlos. Nun passiert Folgendes:
    • Der Bildschirm geht sofort aus
    • der Rechner läuft weiter
    • und reagiert nicht mehr auf Eingaben / lässt sich nicht mehr starten
    Bisher ist es mir immer irgendwie gelungen (Magic Tasten) den Rechner komplett herunterzufahren (ohne den Netzstecker zu ziehen). Hier die Info zur Grafikkarte:

    Quellcode

    1. erich@linux-611w:~> /usr/sbin/hwinfo --gfxcard
    2. 34: PCI 100.0: 0300 VGA compatible controller (VGA)
    3. [Created at pci.378]
    4. Unique ID: VCu0.z7Ef6OuuTzE
    5. Parent ID: _Znp.mxGZ4sT7tg6
    6. SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
    7. SysFS BusID: 0000:01:00.0
    8. Hardware Class: graphics card
    9. Model: "ATI Juniper PRO [Radeon HD 5750]"
    10. Vendor: pci 0x1002 "ATI Technologies Inc"
    11. Device: pci 0x68be "Juniper PRO [Radeon HD 5750]"
    12. Driver: "radeon"
    13. Driver Modules: "radeon"
    14. Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
    15. Memory Range: 0xfea20000-0xfea3ffff (rw,non-prefetchable)
    16. I/O Ports: 0xe000-0xe0ff (rw)
    17. Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
    18. IRQ: 36 (1473053 events)
    19. Module Alias: "pci:v00001002d000068BEsv00000000sd00000000bc03sc00i00"
    20. Driver Info #0:
    21. Driver Status: radeon is active
    22. Driver Activation Cmd: "modprobe radeon"
    23. Config Status: cfg=no, avail=yes, need=no, active=unknown
    24. Attached to: #19 (PCI bridge)
    25. Primary display adapter: #34
    26. erich@linux-611w:~>
    Alles anzeigen
    Gruß, Erich

    Für den Inhalt des Beitrages 126695 haftet ausdrücklich der jeweilige Autor: erich_s

  • Hallo erich_s,

    du könntest einmal als root (bewirkt suspend to disk!)

    Quellcode

    1. echo disk > /sys/power/state


    probieren.

    Ansonsten noch bitte als root die Ausgaben von

    Quellcode

    1. fdisk -l
    und

    Quellcode

    1. cat /boot/grub2/grub.cfg | grep /boot/vmlinuz

    Für den Inhalt des Beitrages 126721 haftet ausdrücklich der jeweilige Autor: Egostra

  • angemeldet als root, in Terminal eingegeben echo disk > /sys/power/state
    --> Der Bildschirm geht sofort aus, der Rechner läuft noch gefühlt 30 Sekunden weiter und schaltet dann auch ab. Durch Drücken irgendeiner Taste (ich habe die Leertaste benutzt) erfolgt ein kompletter Neustart. Danach ist der Rechner in dem Status wie vor den Suspend.


    Quellcode

    1. fdisk -l
    2. Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    3. Units: sectors of 1 * 512 = 512 bytes
    4. Sector size (logical/physical): 512 bytes / 4096 bytes
    5. I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    6. Disklabel type: gpt
    7. Disk identifier: A895D9B9-172B-4FC7-BD79-913CBDC9AE7B
    8. Device Start End Sectors Size Type
    9. /dev/sda1 2048 1026047 1024000 500M EFI System
    10. /dev/sda2 1026048 84912127 83886080 40G Linux filesystem
    11. /dev/sda3 84912128 3890874367 3805962240 1.8T Linux filesystem
    12. /dev/sda4 3890874368 3907029134 16154767 7.7G Linux swap
    13. Disk /dev/sdc: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    14. Units: sectors of 1 * 512 = 512 bytes
    15. Sector size (logical/physical): 512 bytes / 512 bytes
    16. I/O size (minimum/optimal): 512 bytes / 512 bytes
    17. Disklabel type: dos
    18. Disk identifier: 0x0008a37c
    19. Device Boot Start End Sectors Size Id Type
    20. /dev/sdc1 2048 3907028991 3907026944 1.8T 5 Extended
    21. /dev/sdc5 4096 3907028991 3907024896 1.8T 83 Linux
    22. Disk /dev/sdb: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    23. Units: sectors of 1 * 512 = 512 bytes
    24. Sector size (logical/physical): 512 bytes / 512 bytes
    25. I/O size (minimum/optimal): 512 bytes / 512 bytes
    26. Disklabel type: dos
    27. Disk identifier: 0x0008a37c
    28. Device Boot Start End Sectors Size Id Type
    29. /dev/sdb1 * 2048 3906248703 3906246656 1.8T f W95 Ext'd (LBA)
    30. /dev/sdb5 151334912 3906248703 3754913792 1.8T 83 Linux
    Alles anzeigen
    sda ist die Systemplatte. sdb und sdc sind reine Daten- und Backup Disks

    Quellcode

    1. cat /boot/grub2/grub.cfg | grep /boot/vmlinuz
    2. linuxefi /boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=6890c477-0cd5-47d0-b555-ba0a54b17b0a ${extra_cmdline} resume=/dev/disk/by-id/ata-ST2000DM001-1ER164_S4Z0CAXK-part4 splash=silent quiet showopts
    3. linuxefi /boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=6890c477-0cd5-47d0-b555-ba0a54b17b0a ${extra_cmdline} resume=/dev/disk/by-id/ata-ST2000DM001-1ER164_S4Z0CAXK-part4 splash=silent quiet showopts
    4. linuxefi /boot/vmlinuz-4.12.14-lp150.12.25-default root=UUID=6890c477-0cd5-47d0-b555-ba0a54b17b0a ${extra_cmdline}
    5. linuxefi /boot/vmlinuz-4.12.14-lp150.12.22-default root=UUID=6890c477-0cd5-47d0-b555-ba0a54b17b0a ${extra_cmdline} resume=/dev/disk/by-id/ata-ST2000DM001-1ER164_S4Z0CAXK-part4 splash=silent quiet showopts
    6. linuxefi /boot/vmlinuz-4.12.14-lp150.12.22-default root=UUID=6890c477-0cd5-47d0-b555-ba0a54b17b0a ${extra_cmdline}

    Für den Inhalt des Beitrages 126728 haftet ausdrücklich der jeweilige Autor: erich_s

  • Habs nochmal ausprobiert: Ja, das Grub Menü mit den mehreren Auswahlmöglichkeiten und dem Runterzählen der Sekunden erscheint. Bei 0 Sekunden wird der Bildschirm dunkel, es dauert ein paar Sekunden, dann ist der Rechner wieder da wo er vor dem Suspend war.

    Gruß, Erich

    Für den Inhalt des Beitrages 126791 haftet ausdrücklich der jeweilige Autor: erich_s

  • erich_s schrieb:

    ... es dauert ein paar Sekunden, dann ist der Rechner wieder da wo er vor dem Suspend war.
    Auf bzw. unter dem Schreibtisch! Das ist ja reine Magie! Wo war er denn zwischendurch? In einem Paralleluniversum? :D

    Scherz beiseite, wenn du schreibst, der Rechner ist wieder da vor er vorher war, meinst du sicherlich das die zuvor offenen Anwendungen wieder genau so erscheinen wie du sie beim "Suspend to Disk" hinterlassen hast.
    Das wäre dann doch ok. Nur das Erscheinen des Grub-Menüs kommt mir seltsam vor...
    Deine Vorgehensweise mit der Alt-Taste oben rechts (unter Gnome) soll ein "Suspend to RAM" auslösen?
    Ich kann es nicht nachvollziehen, denn ich habe keine Gnome und im Moment auch kein Leap 15.0 zur Hand.

    Für den Inhalt des Beitrages 126794 haftet ausdrücklich der jeweilige Autor: ThomasS

  • erich_s schrieb:

    Ja, das Grub Menü mit den mehreren Auswahlmöglichkeiten und dem Runterzählen der Sekunden
    Dann war der Rechner wahrscheinlich komplett herunter gefahren...
    Was passiert, wenn du als root ein suspend to RAM mit

    Quellcode

    1. echo mem > /sys/power/state
    machst?

    Für den Inhalt des Beitrages 126797 haftet ausdrücklich der jeweilige Autor: Egostra

  • Hallo,

    die Interpretationen sind soweit richtig. Ich habe das auch so verstanden dass die Vorgehensweise mit dem "Ausschalten" Icon oben rechts (unter Gnome) und gleichzeitigem Drücken der Alt-Taste ein "Suspend to RAM" auslösen soll. Früher unter opensuse 13.2 war das so dass der Rechner runtergefahren ist und nach Drücken irgendeiner Taste (z.B. Leertaste) sofort gestartet ist, ohne Grub Menü. Der "suspend to Disk" scheint funktioniert zu haben sonst hätte ich den Rechner vermutlich nicht durch Drücken der Leertaste starten können, halt mit Grub Menü. Nützt mir aber wenig wenn das nur mit dem user root geht.
    Der "Syspend to Ram" liefert unter root einen Fehler:

    Quellcode

    1. echo mem > /sys/power/state
    2. bash: echo: write error: Device or resource busy
    Der Bildschirm geht kurz aus, dann wieder an und im Terminal steht dann der oben gezeigte Fehler. der Rechner läuft weiter.

    Gruß, Erich

    Für den Inhalt des Beitrages 126820 haftet ausdrücklich der jeweilige Autor: erich_s

  • Ich verstehe schon, dass man nicht immer den Umweg mit root über die Konsole gehen möchte. Diese Befehlen dienten
    auch nur den Zweck zu Überprüfen, ob der Suspend prinzipiell erstmal funktioniert. Das scheint nicht ganz der Fall zu sein.

    Wie hast du denn das Update auf Leap 15 gemacht?
    Hast du sonst noch irgendetwas anderes gemacht, z.B. anderen Grafiktreiber installiert?

    Poste bitte

    Quellcode

    1. zypper lr -Up

    Quellcode

    1. uname -a

    Quellcode

    1. /usr/sbin/hwinfo --gfxcard

    Für den Inhalt des Beitrages 126846 haftet ausdrücklich der jeweilige Autor: Egostra

  • Hallo,

    ich habe Leap 15 auf eine leere Disk komplett neu installiert von einer DVD. Sonst habe ich außer den angebotenen SW Updates nichts gemacht im Sinne von Treiber geändert oder so etwas. Da "VLC" und "Videos" manche Formate nicht abspielen konnten habe ich Codecs Paket nachinstalliert, daher kommt wohl des Packmann Repo.
    Hier die gewünschten Infos:

    Brainfuck-Quellcode

    1. zypper lr -Up
    2. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | URI
    3. ---+----------------------------------+-----------------------------------------+-----------+-----------------+----------------+-----------+-------------------------------------------------------------------------
    4. 3 | openSUSE-Leap-15.0-1 | openSUSE-Leap-15.0-1 | Nein | ---- | ---- | 99 | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_BD-RE_BH10LS30_K9FB5723545
    5. 5 | repo-debug-non-oss | openSUSE-Leap-15.0-Debug-Non-Oss | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/distribution/leap/15.0/repo/non-oss/
    6. 4 | repo-debug | openSUSE-Leap-15.0-Debug | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/distribution/leap/15.0/repo/oss/
    7. 7 | repo-debug-update-non-oss | openSUSE-Leap-15.0-Update-Debug-Non-Oss | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/update/leap/15.0/non-oss/
    8. 6 | repo-debug-update | openSUSE-Leap-15.0-Update-Debug | Nein | ---- | ---- | 99 | http://download.opensuse.org/debug/update/leap/15.0/oss/
    9. 8 | repo-non-oss | openSUSE-Leap-15.0-Non-Oss | Ja | (r ) Ja | Ja | 99 | http://download.opensuse.org/distribution/leap/15.0/repo/non-oss/
    10. 9 | repo-oss | openSUSE-Leap-15.0-Oss | Ja | (r ) Ja | Ja | 99 | http://download.opensuse.org/distribution/leap/15.0/repo/oss/
    11. 11 | repo-source-non-oss | openSUSE-Leap-15.0-Source-Non-Oss | Nein | ---- | ---- | 99 | http://download.opensuse.org/source/distribution/leap/15.0/repo/non-oss/
    12. 10 | repo-source | openSUSE-Leap-15.0-Source | Nein | ---- | ---- | 99 | http://download.opensuse.org/source/distribution/leap/15.0/repo/oss/
    13. 13 | repo-update-non-oss | openSUSE-Leap-15.0-Update-Non-Oss | Ja | (r ) Ja | Ja | 99 | http://download.opensuse.org/update/leap/15.0/non-oss/
    14. 12 | repo-update | openSUSE-Leap-15.0-Update | Ja | (r ) Ja | Ja | 99 | http://download.opensuse.org/update/leap/15.0/oss/
    15. 1 | http-opensuse-guide.org-5dca6c65 | libdvdcss repository | Ja | (r ) Ja | Ja | 99 | http://opensuse-guide.org/repo/openSUSE_Leap_15.0/
    16. 2 | http-packman.inode.at-e54c8f1b | Packman Repository | Ja | (r ) Ja | Ja | 99 | http://packman.inode.at/suse/openSUSE_Leap_15.0/
    17. erich@linux-611w:~>
    Alles anzeigen

    Quellcode

    1. uname -a
    2. Linux linux-611w 4.12.14-lp150.12.25-default #1 SMP Thu Nov 1 06:14:23 UTC 2018 (3fcf457) x86_64 x86_64 x86_64 GNU/Linux
    3. erich@linux-611w:~>

    Quellcode

    1. /usr/sbin/hwinfo --gfxcard
    2. 34: PCI 100.0: 0300 VGA compatible controller (VGA)
    3. [Created at pci.378]
    4. Unique ID: VCu0.z7Ef6OuuTzE
    5. Parent ID: _Znp.mxGZ4sT7tg6
    6. SysFS ID: /devices/pci0000:00/0000:00:02.0/0000:01:00.0
    7. SysFS BusID: 0000:01:00.0
    8. Hardware Class: graphics card
    9. Model: "ATI Juniper PRO [Radeon HD 5750]"
    10. Vendor: pci 0x1002 "ATI Technologies Inc"
    11. Device: pci 0x68be "Juniper PRO [Radeon HD 5750]"
    12. Driver: "radeon"
    13. Driver Modules: "radeon"
    14. Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
    15. Memory Range: 0xfea20000-0xfea3ffff (rw,non-prefetchable)
    16. I/O Ports: 0xe000-0xe0ff (rw)
    17. Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
    18. IRQ: 36 (139121 events)
    19. Module Alias: "pci:v00001002d000068BEsv00000000sd00000000bc03sc00i00"
    20. Driver Info #0:
    21. Driver Status: radeon is active
    22. Driver Activation Cmd: "modprobe radeon"
    23. Config Status: cfg=no, avail=yes, need=no, active=unknown
    24. Attached to: #19 (PCI bridge)
    25. Primary display adapter: #34
    26. erich@linux-611w:~>
    Alles anzeigen

    Gruß, Erich

    Für den Inhalt des Beitrages 126901 haftet ausdrücklich der jeweilige Autor: erich_s