Udisk / Dolphin einhängen einer Festplatte mit fstab erlauben

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Udisk / Dolphin einhängen einer Festplatte mit fstab erlauben gibt es 27 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Udisk / Dolphin einhängen einer Festplatte mit fstab erlauben

    Hallo zusammen,

    ich würde gerne mit Dolphin unter Opensuse eine Festplatte ohne die Eingabe des Root Passworts mounten / umounten.

    Dafür gibt es, soweit mit bekannt, in der fstab Datei die Option user.
    Das ermöglicht mir auch das mounten / umounten der Festplatte über die Konsole mit mount, jedoch nicht das einhängen der Platte über Dolphin.
    Ich habe nun ebenfalls herausgefunden, dass Dolphin zum mounten udisk verwendet und die Berechtigungen zum mounten in Udisk über polkit konfiguriert werden kann.
    Es gibt wohl die Option x-udisks-auth für die fstab Datei um das Mounten über udsik zu ermöglichen, was bei mir nun auch funktioniert.

    Mir ist nun jedoch nicht ganz klar weshalb es die Option x-udisks-auth gibt und die Option user von udisk ignoriert wird.

    Gibt es eine Möglichkeit udisk / polkit so zu konfigurieren, dass die Option user verwendet wird und das Mounten der Festplatte mit dem aktuellen User erlaubt bzw, was ist dafür die beste Möglichkeit dies zu erlauben. Muss ich die Option x-udisks-auth und user verwenden um das Mounten mit mount und Dolphin zu ermöglichen oder kann das auch mit einer Option für beide Programme erlaubt werden.


    Vielen Dank für die Hilfe.

    Für den Inhalt des Beitrages 132211 haftet ausdrücklich der jeweilige Autor: anfaenger15

  • UID und GID habe ich auch schon versucht, hatte jedoch für Udisk ebenfalls keine Auswirkung.
    In der fstab hat der Mountpoint die Optionen defaults,noauto,user.

    Sollte udisk normalerweise die Option user in der fstab berücksichtigen?

    Für den Inhalt des Beitrages 132214 haftet ausdrücklich der jeweilige Autor: anfaenger15

  • Nur mal so nebenbei:
    Es kommt auch auf das Dateisystem an, welches gemountet wird.
    Also:
    Poste die fstab und auch mal fdisk -l

    Hast du es mal mit krusader als Dateimanager und MountMan versucht?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 132220 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Das ist mir soweit klar das es auch auf das Dateisystem ankommt, jedoch funktioniert die fstab wie gewünscht mit dem mount Befehl.
    Ich gehe daher davon aus, dass die fstab korrekt ist.
    Daher nochmals meine Frage, wie bringe ich udsik dazu sich wie mount zu verhalten und den fstab Eintrag user nicht zu ignorieren oder ist das nicht vorgesehen und gibt es daher nur die Möglichkeit über die Option x-udisks-auth in der fstab bzw udsik über polkit soweit zu öffnen, dass ALLE Festplatten gemountet werden können?

    Ich verwende KDE und daher möchte ich ebenfalls den derzeitigen Dateimanager Dolphin verwenden und da dieser udsik zum mounten verwendet ist mein Ziel udsik soweit zum Laufen zu bringen. Die Verwendung von Kruader als Dateimanager ist für mich daher keine Option.

    Leider habe ich gerade keinen Zugriff auf die fstab aber diese ist wie folgt aufgebaut:
    UUID MOUNTPATH auto defaults,noauto,user 0 0

    Wie gesagt da die fstab und Festplatte mit mount auch ohne root Berechtigung gemountet werden kann ist diese korrekt.
    Es geht mir daher vielmehr um die polkit Einstellungen für udisk.

    Für den Inhalt des Beitrages 132229 haftet ausdrücklich der jeweilige Autor: anfaenger15

  • Es wird Zeit, dass du die /etc/fstab postest.

    Warum defaults, wenn du keine defaults haben willst?

    Die Einstellungen der fstab gelten für alle Subsysteme.
    Du bist auf dem Holzweg.

    man mount | sed -rn '/^[[:blank:]]+defaults/,/^[[:blank:]]+dev/{/^[[:blank:]]+dev/d;p}'
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von Berichtigung ()

    Für den Inhalt des Beitrages 132230 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • anfaenger15 schrieb:

    ich würde gerne mit Dolphin unter Opensuse eine Festplatte ohne die Eingabe des Root Passworts mounten / umounten.
    Dafür gibt es, soweit mit bekannt, in der fstab Datei die Option user.
    Ein gängiges Verfahren ist das Mount-Tool smb4k.
    Die fstab brauchst du dann nicht mehr anzufassen

    Quellcode

    1. https://software.opensuse.org/package/smb4k
    ich nehme immer die Version aus dem Repo KDE:Extra
    die Software mountet dir beliebige Laufwerke in einen Ordner ~/smb4k in deinem Home
    Die Software ist nach Einrichtung über Lesezeichen mit der Maus intuitiv sehr gut zu bedienen.
    There's no place like 127.0.0.1

    Für den Inhalt des Beitrages 132232 haftet ausdrücklich der jeweilige Autor: wurzel99

  • Die fstab (der relavante Eintrag ist UUID=YYY-YYY-YYYY-YYYY)

    Quellcode

    1. /XXX/XXX/Swap swap swap defaults 0 0
    2. UUID=XXX-XXX-XXX-XXX / btrfs defaults 0 0
    3. UUID=XXX-XXX-XXX-XXX /opt btrfs subvol=@/opt 0 0
    4. UUID=XXX-XXX-XXX-XXX /srv btrfs subvol=@/srv 0 0
    5. UUID=XXX-XXX-XXX-XXX /tmp btrfs subvol=@/tmp 0 0
    6. UUID=XXX-XXX-XXX-XXX /usr/local btrfs subvol=@/usr/local 0 0
    7. UUID=XXX-XXX-XXX-XXX /var/cache btrfs subvol=@/var/cache 0 0
    8. UUID=XXX-XXX-XXX-XXX /var/crash btrfs subvol=@/var/crash 0 0
    9. UUID=XXX-XXX-XXX-XXX /var/lib/libvirt/images btrfs subvol=@/var/lib/libvirt/images 0 0
    10. UUID=XXX-XXX-XXX-XXX /var/lib/machines btrfs subvol=@/var/lib/machines 0 0
    11. UUID=XXX-XXX-XXX-XXX /var/lib/mailman btrfs subvol=@/var/lib/mailman 0 0
    12. UUID=XXX-XXX-XXX-XXX /var/lib/mariadb btrfs subvol=@/var/lib/mariadb 0 0
    13. UUID=XXX-XXX-XXX-XXX /var/lib/mysql btrfs subvol=@/var/lib/mysql 0 0
    14. UUID=XXX-XXX-XXX-XXX /var/lib/named btrfs subvol=@/var/lib/named 0 0
    15. UUID=XXX-XXX-XXX-XXX /var/lib/pgsql btrfs subvol=@/var/lib/pgsql 0 0
    16. UUID=XXX-XXX-XXX-XXX /var/log btrfs subvol=@/var/log 0 0
    17. UUID=XXX-XXX-XXX-XXX /var/opt btrfs subvol=@/var/opt 0 0
    18. UUID=XXX-XXX-XXX-XXX /var/spool btrfs subvol=@/var/spool 0 0
    19. UUID=XXX-XXX-XXX-XXX /var/tmp btrfs subvol=@/var/tmp 0 0
    20. UUID=XXX-XXX-XXX-XXX /boot btrfs defaults 0 0
    21. UUID=XXX-XXX /boot/efi vfat umask=0002,utf8=true 0 0
    22. /XXX/XXX/home /home xfs defaults 1 2
    23. UUID=YYY-YYY-YYYY-YYYY /mnt/YYY-YYY-YYYY-YYYY auto defaults,noauto,user,x-udisks-auth 0 0
    Alles anzeigen


    Berichtigung schrieb:

    Es wird Zeit, dass du die /etc/fstab postest.

    Warum defaults, wenn du keine defaults haben willst?

    Die Einstellungen der fstab gelten für alle Subsysteme.
    Du bist auf dem Holzweg.

    man mount | sed -rn '/^[[:blank:]]+defaults/,/^[[:blank:]]+dev/{/^[[:blank:]]+dev/d;p}'
    Die defaults, da ich ja die defaults haben will und zusätzlich die Option user ;)

    Es ist richtig die Einstellungen der fstab gelten für alle Subsysteme, die Einstellungen von polkit jedoch sind nur bei udisk relevant, daher meine Vermutung mit dem Holzweg ...

    Für den Inhalt des Beitrages 132266 haftet ausdrücklich der jeweilige Autor: anfaenger15

  • Die UUID ist nur bei dir wirksam, daher hättest du die gar nicht maskieren müssen.......

    Was für ein Dateisystem ist auf der yyyy?
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 132267 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Es ist widersinnig solche Werte zu maskieren.
    Du gewinnst damit exakt gar nichts.
    Aber wir verlieren evtl. entscheidende Informationen.

    Ich habe dir einen Befehl gepostet, der dir ganz klar hätte zeigen können, dass die Option "defaults" das genaue Gegenteil der Option "user(s)" beinhaltet.
    Spezifiziere deine Optionen korrekt.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 132273 haftet ausdrücklich der jeweilige Autor: Berichtigung