Boot-Probleme nach Kernel-Update

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Boot-Probleme nach Kernel-Update gibt es 5 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Boot-Probleme nach Kernel-Update

    Hallo zusammen,
    bin neu im Forum & Wiedereinsteiger im Bereich Linux (meine vorherigen Erfahrungen liegen ca. 15 Jahre zurück) und habe mir jetzt Leap 15.1 parallel zu Windows 10 bzw. als zukünftige Alternative installiert.

    Nach der Installation habe ich die verfügbaren Patches einfließen lassen, leider startet danach das System auf der aktuellsten Kernel-Version (
    4.12.14-lp151.28.4.) nicht mehr.

    Ein Start mit 4.12.14-lp151.27.3 ist einwandfrei möglich.

    Brainfuck-Quellcode

    1. zypper se -si kernel
    2. Repository-Daten werden geladen...
    3. Installierte Pakete werden gelesen...
    4. S | Name | Typ | Version | Arch | Repository
    5. ---+-----------------+-------+----------------------+--------+-----------------------
    6. i+ | kernel-default | Paket | 4.12.14-lp151.28.4.1 | x86_64 | Main Update Repository
    7. i+ | kernel-default | Paket | 4.12.14-lp151.27.3 | x86_64 | Main Repository
    8. i | kernel-firmware | Paket | 20190118-lp151.1.10 | noarch | Main Repository

    Ich habe das System mal im Recovery-Modus über GRUB gestartet und dabei gesehen, dass es immer bei folgenden Ausgaben hängen bleibt:

    Quellcode

    1. [ 2.232002] ehci-pci 0000:00:1a.0: USB 2.0 started, EHCI 1.00
    Danach "friert" das System sozusagen ein, ich komme auch in dieser Position natürlich noch nicht auf das Terminal.

    Kennt jemand eine Lösung für dieses Problem bzw. ist es bekannt? Braucht ihr weitere Informationen?

    Vielen Dank für eure Hilfe!

    Grüße,
    Alex

    Für den Inhalt des Beitrages 133382 haftet ausdrücklich der jeweilige Autor: Ascom87

  • Die Schnellstart-Option, in den Windows Energie-Einstellungen, hast du deaktiviert?
    Dann poste einmal:

    Quellcode

    1. zypper lr -d
    Und

    Quellcode

    1. journalctl -b -1 -p err
    Und

    Quellcode

    1. /sbin/lspci -nnk | grep -EiA3 "vga|3d|disp|graphic"
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 133383 haftet ausdrücklich der jeweilige Autor: sterun

  • Guten Morgen,
    danke schon mal für die ersten Tipps. Schnellstart-Option bei Windows ist deaktiviert.

    Brainfuck-Quellcode

    1. zypper lr -d
    2. # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    3. ---+---------------------------+------------------------------------+-----------+-----------------+----------------+-----------+--------+----------------------------------------------------------------------------+-------
    4. 1 | openSUSE-Leap-15.1-1 | openSUSE-Leap-15.1-1 | Nein | ---- | ---- | 99 | rpm-md | hd:/?device=/dev/disk/by-id/usb-_Patriot_Memory_07AC12011D51F027-0:0-part2 |
    5. 2 | repo-debug | Debug Repository | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/15.1/repo/oss/ |
    6. 3 | repo-debug-non-oss | Debug Repository (Non-OSS) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/distribution/leap/15.1/repo/non-oss/ |
    7. 4 | repo-debug-update | Update Repository (Debug) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.1/oss/ |
    8. 5 | repo-debug-update-non-oss | Update Repository (Debug, Non-OSS) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/update/leap/15.1/non-oss/ |
    9. 6 | repo-non-oss | Non-OSS Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/non-oss/ |
    10. 7 | repo-oss | Main Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/distribution/leap/15.1/repo/oss/ |
    11. 8 | repo-source | Source Repository | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/15.1/repo/oss/ |
    12. 9 | repo-source-non-oss | Source Repository (Non-OSS) | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/distribution/leap/15.1/repo/non-oss/ |
    13. 10 | repo-update | Main Update Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/oss/ |
    14. 11 | repo-update-non-oss | Update Repository (Non-Oss) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/leap/15.1/non-oss/ |
    Alles anzeigen


    Quellcode

    1. sudo journalctl -b -1 -p err
    2. Specifying boot ID or boot offset has no effect, no persistent journal was found.

    Quellcode

    1. /sbin/lspci -nnk | grep -EiA3 "vga|3d|disp|graphic"
    2. 01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF114 [GeForce GTX 560 Ti] [10de:1200] (rev a1)
    3. Subsystem: eVga.com. Corp. Device [3842:1561]
    4. Kernel driver in use: nouveau
    5. Kernel modules: nouveau
    6. 01:00.1 Audio device [0403]: NVIDIA Corporation GF114 HDMI Audio Controller [10de:0e0c] (rev a1)
    7. Subsystem: eVga.com. Corp. Device [3842:1561]
    8. Kernel driver in use: snd_hda_intel
    9. Kernel modules: snd_hda_intel
    10. 03:00.0 PCI bridge [0604]: Integrated Technology Express, Inc. Device [1283:8892] (rev 30)
    Alles anzeigen

    @Sauerland: booten mit dem alten Kernel funktioniert problemlos. So wie ich das in der Bug-Beschreibung heraus gelesen habe, stimmt was mit dem nouveau Treiber für Nvidia nicht?

    Für den Inhalt des Beitrages 133386 haftet ausdrücklich der jeweilige Autor: Ascom87

  • @Ascom87

    Quellcode

    1. sudo journalctl -b -1 -p err
    2. Specifying boot ID or boot offset has no effect, no persistent journal was found.
    Der als Root auszuführende Befehl journalctl -b -1 soll die Ausgaben seit demletzten Bootvorgangs anzeigen.
    Das geht bei dir nicht, denn ... no persistent journal was fournd.
    Das kannst du in der Datei /etc/systemd/journal.conf ändern. Suche #Storage=auto und ersetze es durch Storage=persistent.
    Achte darauf, dass die Raute (#) auch entfernt ist.
    Dann kannst du auch ältere Journale aufrufen, journalctl -b -1, -b -2, -b -3, usw.

    Für den Inhalt des Beitrages 133403 haftet ausdrücklich der jeweilige Autor: ThomasS