Leap 15.1 und Shutdown auf einem Lenovo T520

Hinweis: In dem Thema Leap 15.1 und Shutdown auf einem Lenovo T520 gibt es 12 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Servus,


    arbeite mit OS seit vielen vielen Jahren ...


    seltsame Sache:
    Ich habe vor einigen Wochen eine Neuinstall 15.1 auf einem Lenovo T520 vorgenommen da OS 42.3 nicht mehr mit Updates unterstützt wird
    Alle Updates sind drauf


    Grafikkarte ist eine NVidia NVS 4200 M
    Ich nutze den NVidia-Treiber (390.129), da nouveau immer wieder einfach stehen bleibt und der Bildschirm komplett "einfriert" und nur durch power-off dann noch ausgeht


    Möchte ich in KDE herunterfahren, lande ich im Anmeldebildschirm
    Von der Konsole aus mit "shutdown -h now" lande ich im Anmeldebildschirm
    Nur "shutdown": Bis heute (vor den letzten NVidia-Updates) fährt er sauber runter. nach den Updates geht seitdem in den Stand-bye
    Mir bleibt fast nur noch der Hardware Power-Off, was allerdings auch net so ideal ist


    Irgendwas ist oberfaul, da mit OS 42.3 noch alles problemlos lief



    Habt ihr irgendwelche Ideen?
    Liegts am Kernel, irgendwelche Spezialparameter ...?


    Besten Dank schon mal


    Volker

  • Ich würde es mit einer anderen Gui versuchen.


    Nviia war einmal das Richtige für Linux(7.x und später).
    Das ist nicht mehr so, weil Nvidia Kunden verlieren möchte.
    Warum, das weiß nur der dingsdabumsda, oder wie der mit dem Huf und Schwanz heist.


    Irgendwas ist oberfaul, da mit OS 42.3 noch alles problemlos lief

    Kde5 oder auch Plasma genannt, will nicht mehr so richtig mit Nvidia.


    FALSCH!!!
    Nvidia will nicht mit Kde5 auch Plasma genannt.


    Aber bei 42.3 "ging" Kde4! Duck und weg;)
    .

    Für den Inhalt des Beitrages 136732 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Hallo Volker


    Hast du im UEFI (Bios) evtl. eine Einstellung, nur eine Grafikkarte zu nutzen?
    Optionen, falls mehrere Grafikkarten vorhanden sind:
    Integrated Graphics
    Discrete Graphics - (ausschl. ext. GraKa - würde ich mal testen)
    NVIDIA Optimus

    Für den Inhalt des Beitrages 136734 haftet ausdrücklich der jeweilige Autor: sterun

  • Servus,
    thx für Posts


    folgendes hab ich mal ausprobiert im BIOS:
    boot Thinkpad LCD (vorher genauso)
    graph device Optimus (vorher discrete)
    os detection optimus enable (vorher disable)


    Jetzt geht Abmelden, shutdown wieder sauber


    Scheint also a bisserl was gebracht zu haben


    Aber irgendwie scheint die Darstellung in Plasma nimmer ganz so scharf zu sein :-(


    Zusatzinfo:
    Das T520 ist in einer Docking an der ein Samsung S27B550 hängt


    cu


    Volker

  • Aber irgendwie scheint die Darstellung in Plasma nimmer ganz so scharf zu sein

    Systemeinstellungen - Anzeige und Monitor kontrolliert / optimiert?


    Deine gewählten (jetzigen) Bios-Settings entsprechen exakt der Herstellervorgabe.
    Bedeutet, das System entscheidet, welche Grafikkarte verwendet wird (onboard Intel oder Nvidia).
    Entweder du lässt das Bios wie es jetzt ist und installierst lediglich einen anderen Nvidia-Treiber oder du stellst im Bios ein, dass ausschl. die Intel onboard Karte verwendet wird (GraphicsDevice = IntegratedGraphics und OSDetectionforNVIDIAOptimus = Disabled).
    Ich persönlich verwende nur die onboard Intel und bin sehr zufrieden damit.
    Zum Thema Nvidia-Treiber können andere hier mehr sagen.


    Vorteile Nvidia:
    etwas mehr Leistung


    Vorteile Intel onboard:
    weniger aber trotzdem gute Leistung
    geringerer Stromverbrauch
    keine Treiber-Probleme


    Entscheident ist natürlich, was man mit seinem PC macht (Spiele, Videoschnitt usw).

    Für den Inhalt des Beitrages 136765 haftet ausdrücklich der jeweilige Autor: sterun

  • PS:
    Hier mal ein Screenshot (inkl. Erklärungen) deines UEFI bzgl. Grafikeinstellungen.
    Vielleicht hilft es dir oder anderen Helfern :-)

    Für den Inhalt des Beitrages 136767 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo,


    also ich hab nun mal die interne Grafikkarte probiert und Optimus deaktiviert. Meine Anwendung/Nutzung beinhaltet KEIN Videoschnitt, Games ... also nix wildes erstmal
    Shutdown, abmelden funzt nun wieder sauber und stabil
    via lsmod finde ich kein nvidia mehr


    Einzig die Darstellung haut mich noch net so vom Hocker. Irgendwie noch nicht so die ganz scharfe Darstellung wie vorher
    Aktuell ist der Monitor von der Docking via VGA an den Monitor angeschlossen. Docking hat zwar VGA, DVI und Display-Port, aber der Monitor nur VGA und HDMI
    evtl. via Adapter Displayport -> HDMI mal testen?
    Oder habe ich noch andere Möglichkeiten besser zu justieren?


    thx schon mal


    Volker

  • Hallo Volker


    Hast du in den Systemeinstellungen (Monitor) die Ausgabe nur am Samsung-Monitor oder wird das Bild am Laptop und auch am Samsung gleichzeitig ausgegeben?
    Ich würde es so konfigurieren, dass nur der Samsung angesteuert wird.
    Auflösung sollte dann sein: 1920 x 1080
    Bei der Bildwiederholrate würde ich mal experimentieren: 50-60 HZ


    Was du noch mal posten könntest:

    Code
    /sbin/lspci -nnk | grep -EiA3 "vga|3d|disp|graphic"

    Für den Inhalt des Beitrages 136783 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo,


    hier die Ausgabe von
    /sbin/lspci -nnk | grep -EiA3 "vga|3d|disp|graphic"


    00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0116]
    (rev 09)


    Subsystem: Lenovo Device [17aa:21d1]


    Kernel driver in use: i915


    Kernel modules: i915



    cu