Tumbleweed: Framebuffer, ATI Radeon RX570 und UHD-Monitor

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Tumbleweed: Framebuffer, ATI Radeon RX570 und UHD-Monitor gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Tumbleweed: Framebuffer, ATI Radeon RX570 und UHD-Monitor

    Moin,

    ich habe seit ein paar Tagen einen UHD-Monitor (3840x2160) und kann seitdem den Output während des Bootens nur noch mit Lupe lesen :( .

    Grafikkarte ist eine Radeon 570, der Monitor ist am Displayport angeschlossen. Über Yast habe ich bei der Bootloader-Konfiguration mal 1600x1200 ausgewählt, das wird aber geflissentlich ignoriert.

    hwinfo --framebuffer gibt nur

    Quellcode

    1. 02: None 00.0: 11001 VESA Framebuffer
    2. [Created at bios.459]
    3. Unique ID: rdCR.7Tnva6o_5vD
    4. Hardware Class: framebuffer
    5. Model: "(C) 1988-2010, Advanced Micro Devices POLARIS20"
    6. Vendor: "(C) 1988-2010, Advanced Micro Devices, Inc."
    7. Device: "POLARIS20"
    8. SubVendor: "AMD ATOMBIOS"
    9. SubDevice:
    10. Revision: "01.00"
    11. Memory Size: 48 MB
    12. Memory Range: 0x00000000-0x02ffffff (rw)
    13. Config Status: cfg=no, avail=yes, need=no, active=unknown
    Alles anzeigen
    aus.

    Wie kann ich eine vernünftige Auflösung einstellen?

    Für den Inhalt des Beitrages 136944 haftet ausdrücklich der jeweilige Autor: Oceanwaves

  • Eher nicht, da geht es ja um X11 bzw. SDDM (KDE). Ich meine aber die Startphase, also die Ausgaben von systemd, die ich sehe, wenn ich beim Systemstart F2 drücke (sofern Grub auf silent konfiguriert ist).

    Für den Inhalt des Beitrages 136946 haftet ausdrücklich der jeweilige Autor: Oceanwaves

  • @Sauerland
    Würde es etwas bringen, direkt in
    /etc/default/grub
    ...eine kleine Auflösung einzufügen unter:
    GRUB_GFXMODE=640x480
    Oder kann man es zu 100% ausschl., da @Oceanwaves es schon unter Yast - BootLoader-Konfiguration versucht hat?

    @Oceanwaves
    Schau mal hier:
    GNU GRUB Manual 2.04
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Dieser Beitrag wurde bereits 1 mal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 136949 haftet ausdrücklich der jeweilige Autor: sterun

  • sterun schrieb:

    @Oceanwaves
    Schau mal hier:
    GNU GRUB Manual 2.04
    Hatte mich mit dem letzten Link vertan.
    Wollte auf Grub verlinken und nicht auf gfxpayload:
    GNU GRUB Manual 2.04
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 136950 haftet ausdrücklich der jeweilige Autor: sterun

  • Moin!

    Ich habe die Auflösung extra mit Yast (Bootloader/Kernel-Parameter/Konsolenauflösung) konfiguriert, damit auch alle Config-Dateien angepasst werden. Je nachdem, was ich in Yast setze, ändern sich (mindestens) diese beiden Dateien:

    /etc/default/grub:

    Quellcode

    1. GRUB_TERMINAL="gfxterm"
    2. GRUB_GFXMODE="1024x768"

    Stand ursprünglich auf "auto", hab's dann probeweise mal auf (die von Yast angebotenen) Werte 1600x1200 und 1024x768 gesetzt.

    Gleichzeitig wird die Auflösung auch in /boot/grub/grub.cfg geändert:

    Quellcode

    1. if loadfont $font ; then
    2. echo "Please press t to show the boot menu on this console"
    3. set gfxmode=1024x768
    4. load_video
    5. insmod gfxterm
    6. fi
    7. terminal_output gfxterm

    Ändert aber nichts, egal ob "auto", "1600x1200" oder "1024x768", die systemd-Meldungen sind nur mit Lupe zu lesen.

    @Sauerland: Das Ubuntu-Tutorial hilft leider auch nicht.

    Dort steht z.B.
    Beim Booten versucht GRUB automatisch eine geeignete Auflösung zu finden. Normalerweise wird die größtmögliche Auflösung eingestellt.

    Das kann ich so zumindest bestätigen. Es wird eine ziemlich hohe Auflösung verwendet.


    Man startet das System neu und wechselt im Auswahlmenü des Bootmanagers mit einem Druck auf die Taste C in die GRUB 2-Konsole und gibt folgenden Befehl am Prompt (grub> _ ) ein:
    videoinfo Man erhält eine mehr oder weniger lange Liste, die je Zeile u.a. folgende Werte enthält:
    [...]0x123 800 x 600 x 24 Direct, mask: 8/8/8/0 pos: 16/8/0/00x11b 1280 x 1024 x 24 Direct, mask: 8/8/8/0 pos: 16/8/0/0[...]Die hier beispielhaft markierten Werte sind die auf dem jeweiligen System möglichen Auflösungen und Farbtiefen.
    Die Grub2-Konsole sagt mir leider, dass es den Befehl videoinfo nicht kennt. Man kann dort ja den Anfangsbuchstaben eines Kommandos eingeben und mit Tab dann vervollständigen lassen. Leider kennt mein Grub2 keinerlei Kommandos, die mit "v" beginnen (im alten Grub hieß das Kommando wohl noch vbeinfo).

    Für den Inhalt des Beitrages 136960 haftet ausdrücklich der jeweilige Autor: Oceanwaves

  • Hallo zusammen,

    ich könnte mir vorstellen, dass in dieser Phase gar nicht mehr GRUB zuständig ist sondern systemd. Ist das vielleicht dieses Problem?

    boot: HiDPI / font size support? · Issue #2750 · systemd/systemd · GitHub

    Hier wird auf einen console-mode verwiesen, der vermutlich mit Version 239 in systemd einmgeflossen ist. Wie man den setzen könnte, da verweise ich wieder an andere Experten hier im Forum.

    Für den Inhalt des Beitrages 136963 haftet ausdrücklich der jeweilige Autor: letsfindaway

  • Klang interessant, aber anscheinend gehört ESP/loader/loader.conf zu systemd-boot. Und bei mir sagt bootctl, dass systemd-boot gar nicht installiert ist:

    Quellcode

    1. # bootctl
    2. systemd-boot not installed in ESP.
    3. System:
    4. Firmware: n/a (n/a)
    5. Secure Boot: disabled
    6. Setup Mode: user
    7. [...]

    ESP ist /boot/efi, dort gibt es dann das Unterverzeichnis EFI.

    Andererseits sagt mit bootctl auch, dass Secure Boot nicht aktiv ist, das widerspricht aber eigentlich der Aussage im BIOS.

    Habe trotzdem mal /boot/efi/EFI/loader/loader.conf erstellt und nur

    Quellcode

    1. console-mode 2
    eingetragen. Hat aber leider nichts gebracht.

    Für den Inhalt des Beitrages 136974 haftet ausdrücklich der jeweilige Autor: Oceanwaves