rtl8821ce: Kein WLAN (und Bluetooth)

Hinweis: In dem Thema rtl8821ce: Kein WLAN (und Bluetooth) gibt es 42 Antworten auf 5 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo miteinander,


    habe folgendes Notebook: HP 15-da0103ng mit Leap 15.1
    Leider funktioniert das WLAN nicht. Ich denke, ich brauche einen Treiber?
    Kann mir jemand hier weiterhelfen?



    Danke und Gruß, Michael

    2 Mal editiert, zuletzt von Micky ()

    Für den Inhalt des Beitrages 139593 haftet ausdrücklich der jeweilige Autor: Micky

  • Alero: Bin nach Anweisung vorgegangen:
    Den folgenden Text per copy und paste in der Konsole einfügen und ausführen: wget -O collectNWData.sh CND_download && chmod +x collectNWData.sh && ./collectNWData.sh
    Danach kommt immer folgendes Ergebnis:
    !!! Das Programm ifconfig,arp,route ist nicht verfügbar. Das Programm nachinstallieren und das Script danach noch einmal ausführen


    Mit welchen Befehl nochmals installiere ich die Programme ifconfig,arp,route nach?

    Für den Inhalt des Beitrages 139597 haftet ausdrücklich der jeweilige Autor: Micky

  • Du musst den Treiber für den Chipsatz installieren. Dieser ist nämlich nicht direkt in Kernel. Es müsste aber ein fertiges Paket auf dem Repository von Sauerland sein. Vielleicht kann er mehr dazu sagen.

    Für den Inhalt des Beitrages 139600 haftet ausdrücklich der jeweilige Autor: mairo

  • Dir scheint einiges zu fehlen. Poste bitte mal


    Code
    zypper lr -d


    Lies auch mal hier ...


    Klick und Klick


    Fehlende Software kann man in Yast oder per zypper nachinstallieren. Beispiel:


    Root werden mit su, Passwort unsichtbar eingeben und dann ein


    Code
    zypper in ifconfig

    Nur so als Beispiel ...

  • Dieses Skript ist nicht ganz up to date.
    Seit 42.? wird ifconfig und route nicht mehr automatisch installiert. Sind obsolet aber noch nachinstallierbar.
    Der Nachfolger heißt ip. Damit sollte man sich befassen! Siehe in die Man-Pages.
    Zu dem Befehl arp müsste ich jetzt auch mal nachsehen. Wenn ich mich recht erinnere, war dieser auch ein standardmässiger einer jeden (open)SuSe-Installation.


    @Alero, auch wenn die Repoliste vollkommen in Ordnung ist, diese Programme werden nicht mehr automatisch während der Erstinstallation installiert.


    Zu dem nicht mehr so ganz aktuellem Skript zurückzukommen.
    Erst mal vielen Dank an die, die es geschrieben haben. Und eine Bitte an die, die es (hoffentlich) noch pflegen: Eine Modifikation auf die neuen Programme/Tools wäre Toll!
    In der Hoffnung, dass es die Richtigen lesen oder jemand, der die Richtigen kennt :)

    Für den Inhalt des Beitrages 139603 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Mist! Muss jetzt weg! Bin am Montag wieder da! Danke schon mal für alle Beiträge! Werde sie alle lesen, kann aber erst am Montag umsetzen, da auswärts nun kein WLAN auf Notebook verfügbar. :-( Gruß, Michael

    Einmal editiert, zuletzt von Micky ()

    Für den Inhalt des Beitrages 139604 haftet ausdrücklich der jeweilige Autor: Micky

  • Repoliste sieht nicht schlecht aus.


    Nur kleine Schönheitskorrekturen: #15 und #2 sind doppelt. (warum?) Lösche #2!
    Repo #4 (libdvdcss) kann nach erfolgreicher Installation von libdvdcss2 deaktiviert werden. Soll sich mit dem Packman-Repo beißen....


    Das ganze hat aber nichts mit deinem Problem zu tun....

    Für den Inhalt des Beitrages 139608 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Als root:


    Code
    zypper ar -f https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.1_Update/ Sauerland-Update

    Das fügt mein Repo für das OSS-Update Repo hinzu.

    Code
    zypper in rtl8821ce-kmp-default btrtl-kmp-default

    Ersteres ist Wlan-Treiber, zweiteres Bluetooth.