xsane und simple-scan funktionieren nicht

Hinweis: In dem Thema xsane und simple-scan funktionieren nicht gibt es 34 Antworten auf 4 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Funktioniert mit den SANE Paketen aus deinem Repo leider immer noch nicht (auch nicht nach Neustart des PCs).
    Es kommen bei "xsane" sowie "simple-scan --debug" die gleichen Fehlermeldungen wie im Eingangspost.


    Code
    S | Name | Typ | Version | Arch | Repository
    ---+--------------------------+-------+------------------------+--------+-----------------------
    i+ | sane-backends | Paket | 1.0.29.git20200222-2.1 | x86_64 | Sauerland_branch
    i+ | sane-backends-autoconfig | Paket | 1.0.29.git20200222-2.1 | x86_64 | Sauerland_branch
    i+ | xsane | Paket | 0.999-2.10 | x86_64 | Haupt-Repository (OSS)

    Für den Inhalt des Beitrages 140044 haftet ausdrücklich der jeweilige Autor: AlphaLemmi

  • Habe das gleiche Problem. Nach Update des sane-backends in meiner Tumbleweed Installation auf Version 1.0.27-5.11 kommt ebenfalls der bisher beschriebene Fehler:
    Xsane, wie auch simple-scan zeigen das gleiche Verhalten, wie vom Thread-Ersteller beschrieben.
    Hier schein die libsane-brother4.so.1.0.7 ein Problem mit dem sane-backend zu bekommen.


    dmesg wirft folgendes aus:


    [ 2474.470803] scanimage[6850]: segfault at 10 ip 00007fad6b0d0761 sp 00007fff2cf84a60 error 4 in libsane-brother4.so.1.0.7[7fad6b0b9000+2e000]
    [ 2474.470827] Code: eb 24 48 8b 45 c0 8b 48 10 48 8b 45 c0 48 8b 10 48 8d 35 9a 1a 01 00 bf 02 00 00 00 b8 00 00 00 00 e8 eb 1e ff ff 48 8b 45 c0 <8b> 50 10 be 01 00 00 00 bf 02 00 00 00 e8 35 15 ff ff 89 c2 48 8b


    bzw. simple-scan
    [14338.008704] scan-thread[18168]: segfault at 10 ip 00007fd959584761 sp 00007fd959e9d5f0 error 4 in libsane-brother4.so.1.0.7[7fd95956d000+2e000]
    [14338.008729] Code: eb 24 48 8b 45 c0 8b 48 10 48 8b 45 c0 48 8b 10 48 8d 35 9a 1a 01 00 bf 02 00 00 00 b8 00 00 00 00 e8 eb 1e ff ff 48 8b 45 c0 <8b> 50 10 be 01 00 00 00 bf 02 00 00 00 e8 35 15 ff ff 89 c2 48 8b




    Auf einem anderen Rechner, ebenfalls Tumbleweed, jedoch das sane-backend mit Version 1.0.27-5.9 besteht der Fehler nicht.

    Einmal editiert, zuletzt von repi ()

    Für den Inhalt des Beitrages 140198 haftet ausdrücklich der jeweilige Autor: repi

  • Hi,
    zur Info. Ich habe heute das System aktualisiert (zypper dup). Ich kann jetzt wieder scannen, obwohl sich an der SANE Version nichts geändert hat.
    Wie sieht das bei euch aus?

    Für den Inhalt des Beitrages 140251 haftet ausdrücklich der jeweilige Autor: r3z5

  • Hi,
    zur Info. Ich habe heute das System aktualisiert (zypper dup). Ich kann jetzt wieder scannen, obwohl sich an der SANE Version nichts geändert hat.
    Wie sieht das bei euch aus?

    Das kann ich bestätigen!
    Bin immer noch bei


    sane-backends 1.0.27-5.11


    und kann trotzdem wieder scannen.


    Seltsam!

    Für den Inhalt des Beitrages 140304 haftet ausdrücklich der jeweilige Autor: AlphaLemmi