Links an Firefox übergeben

Hinweis: In dem Thema Links an Firefox übergeben gibt es 7 Antworten. Der letzte Beitrag () befindet sich ganz unten auf dieser Seite.
  • Hallo liebe Community,


    immer wenn ich in einer Anwendung einen Link anklicke, öffnet Firefox die Webseite nicht direkt, sondern in folgendem Format:


    file:///home/suse/.cache/kioexec/krun/16057_0/unnamed


    Chromium öffnet die Links wie sich das gehört.

    Testweise habe ich in Opensuse (Tumbleweed) einen neuen Benutzer angelegt. Unter diesen Benutzer öffnet Firefox die links einwandfrei.


    Ich bin mir nicht sicher ob die Suse oder der Firefox das Problem ist.


    Könnt ihr mir helfen das leidige Problem loszuwerden?


    Grüße Frank



    Opensuse Tumbleweed mit Plasma 5.19.2

    Firefox 77.0.1

  • Einstellungen ... Systemeinstellungen ... Persönliche Informationen ... Anwendungen ... Webbrowser ... was steht dort eingetragen?

  • Hallo Frank


    Geht es, wenn du dein Firefox-Profil umbenennst?

    Falls nötig, vorher deine Lesezeichen sichern:

    Dazu starte Firefox - Lesezeichen - Lesezeichen verwalten - Importieren und sichern - sichern...

    Firefox beenden.


    Profil umbenennen in der Konsole als normaler User:

    Code
    mv ~/.mozilla/firefox/ ~/.mozilla/firefox_org

    Anschl. startet Firefox mit den Standard-Settings.

    Gesicherte Lesezeichen wieder herstellen und testen.


    Alles wieder rückgängig machen, kannst du mit:

    Code
    rm -r ~/.mozilla/firefox/

    Und anschl.:

    Code
    mv ~/.mozilla/firefox_org/ ~/.mozilla/firefox

    Für den Inhalt des Beitrages 281804 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo steron,


    vielen Dank für Deine Antwort.


    Also das Verschieben des Firefox Profils hat nicht geholfen.


    Evtl. ist es ein Thema des Plasma Desktops im Zusammenspiel mit Firefox.


    Wenn ich z.B. in Thunderbird einen Link anklicke dann bekomme ich eine Benachrichtigung wie diese:


    Code
    Kopiervorgang abgeschlossen:
    nach ~/.cache/kioexec/krun/5906_0/aHR0cHM6Ly93d3cub3BlbnN1c2UtZm9ydW0uZGUvdGhyZWFkLzYzODc3LWxpbmtzLWFuLWZpcmVmb3gtJUMzJUJDYmVyZ2ViZW4vP3Bvc3RJRD0yODE4MDQjcG9zdDI4MTgwNA

    Auf mich wirkt das als würde der Inhalt der Website auf die Festplatte kopiert und dann der Speicherort an Firefox übergeben. Nur warum?

  • Also, mit einem neuen User, wie du geschrieben hast, geht es.

    Dann teste mal:

    Systemeinstellungen - Persönliche Informationen - Anwendungen - Webbrowser - mit folgendem Befehl: firefox %u


    Nachtrag:

    Wenn es nicht geht, poste noch bitte die Ausgabe von:

    Code
    grep Exec /usr/share/applications/firefox.desktop

    Einmal editiert, zuletzt von sterun ()

    Für den Inhalt des Beitrages 281974 haftet ausdrücklich der jeweilige Autor: sterun

  • Hallo Leute,


    vielen Dank für Eure Hilfe. Ich weiß nicht was es war, aber als ich eben auf den Link zu diesem Thread in der Benachrichtigungs- Email klickte, öffnete Firefox diese Seite wie sich das gehört.


    Nach meinem letzten Beitrag habe ich noch einmal zwischen Firefox und Chromium als Standardbrowser geswitched und wieder zurück. Außerdem habe ich noch ein Distributionsupdate gefahren, welches eine neue Version von Firefox mit sich brachte. Möglicherweise war das der Grund.


    Ich werde den Tread als erledigt kennzeichnen und wünsche Euch noch eine schöne Zeit


    Gruß Frank