redis-server start via systemd request repeated too quickly

Hinweis: In dem Thema redis-server start via systemd request repeated too quickly gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo Leute,


    beim Versuch redis-server via systemd zu starten erhalte ich folgende Fehlermeldungen:

    Ich habe schon diverse Internetbeiträge probiert, sowie den Pfad zur Config Datei von redis-server im ExecStart angepasst von systemd, doch nichts half.


    Über Hilfestellungen hierzu wäre ich also sehr dankbar.


    Server OS: openSUSE Tumbleweed, Konsole


    MFG


    derwunner

    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 282360 haftet ausdrücklich der jeweilige Autor: derwunner

  • Hast du mal testweise "AppArmor" deaktiviert?

    - Terminal als Root (mit su)
    - yast
    - Sicherheit und Benutzer
    - AppArmor
    - Einstellungen
    - Ganz oben die Markierung entfernen bei "AppArmor aktivieren"

    Kontrolle mit:
    aa-status

    Für den Inhalt des Beitrages 282365 haftet ausdrücklich der jeweilige Autor: sterun

  • Meist findet sich in der Konfiguration des jeweiligen Dienstes der Fehler. Diese Dienste versuchen zu starten, werfen aber dabei Fehler, weil die Konfig irgendeinen Humbug enthält, und systemd entschließt sich irgendwann diesen Dienst nicht mehr erneut starten zu lassen, um nicht weiter mit sinnlosen Startversuchen das System zu belasten.


    Gucke in den Logfiles deines Redis, was da wirklich schief läuft. Kläre das, und es sollte wieder anständig zucken.

    Manchmal liegt der Fehler auch in den Berechtigungn/Owndership der Dateien, die der Service schreiben möchte.

    Prüfe auch dort alle Einträge der Konfig, wem die Dateien gehören müssen, wo sie liegen und ob dort der User, unter dem der Redis ausgeführt wird, auch schreiben darf. (Dateien, wie Pidfile, Logfiles, Sockets, Pipes etc.)

    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 282373 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Berichtigung Config habe ich nochmal geschaut, scheint zu passen. Außerdem habe ich die pid file in der systemd service Datei /usr/lib/systemd/system/redis@.service nach /run/redis/%i.pid gelegt, weil systemd aufgrund der neuen Struktur es so wollte (liegt wohl noch mit der veralteten Struktur im Package).

    In den Logs steht leider nichts.

    Den sysctl Wert für vm.overcommit_memory=1 wollte er noch mit dem Kommando sysctl vm.overcommit_memory=1 übernommen haben im laufenden Kernel. Das konnte ich soweit den Redis Ferhlemeldungen bzw. Anleitungen darin entnehmen.

    Außerdem hätte ich noch das da:

    Code
    WARNING you have Transparent Huge Pages (THP) support enabled in your kernel. This will create latency and memory usage issues with Redis. To fix this issue run the command 'echo never > /sys/kernel/mm/transparent_hugepage/enabled' as root, and add it to your /etc/rc.local in order to retain the setting after a reboot. Redis must be restarted after THP is disabled.

    Wie kann man das ins moderne systemd "übersetzen"?


    sterun Ja, es scheint wohl ein AppArmor Problem zu sein. Ich habe es wie beschrieben von Dir deaktiviert (der Haken ist nicht mehr gesetzt, habe ich zweimal überprüft), aber es gibt immer noch Probleme mit AppArmor:

    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 282421 haftet ausdrücklich der jeweilige Autor: derwunner

  • Hast du denn redis gestartet?

    Code
    /usr/sbin/rcredis start

    Damit geht es komischerweise. Im Chat hieß aber ich solle folgendes verwenden zum Starten von Redis, was nicht geht:

    Code
    systemctl start redis@default

    Was ist denn nun richtig und warum?

    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 282423 haftet ausdrücklich der jeweilige Autor: derwunner

  • Du brauchst eine default.conf in /etc/redis/

    Dann :



    Denn:

    ExecStart=/usr/sbin/redis-server /etc/redis/%i.conf

    bedeutet:

    Es wird expandiert mit dem Ausdruck, der auf @ folgt:

    Code
    systemctl start redis@default

    Also default.conf

  • Ok ja, vielen Dank, das hat zumindest ein Problem gelöst.


    Jetzt habe ich noch folgendes Problem, wo mir DuckDuckGo keine passenden Ergebnisse ausspuckte:

    Das Paket redis-apparmor ist allerdings installiert:

    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 282525 haftet ausdrücklich der jeweilige Autor: derwunner

  • zypper lr -d:

    Code
    # | Alias | Name | Aktiviert | GPG-Überprüfung | Aktualisierung | Priorität | Typ | URI | Dienst
    --+----------------------------------+---------------------------------------------------------+-----------+-----------------+----------------+-----------+--------+-----------------------------------------------------------------------------------+-------
    1 | download.opensuse.org-non-oss | Haupt-Repository (NON-OSS) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/ |
    2 | download.opensuse.org-oss | Haupt-Repository (OSS) | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
    3 | download.opensuse.org-tumbleweed | Hauptaktualisierungs-Repository | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/update/tumbleweed/ |
    4 | home_darix_apps | just some rubyapps and their deps (openSUSE_Tumbleweed) | Ja | (r ) Ja | Nein | 99 | rpm-md | https://download.opensuse.org/repositories/home:/darix:/apps/openSUSE_Tumbleweed/ |
    5 | openSUSE-20200610-0 | openSUSE-20200610-0 | Ja | (r ) Ja | Ja | 99 | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/ |
    6 | repo-debug | openSUSE-Tumbleweed-Debug | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/debug/tumbleweed/repo/oss/ |
    7 | repo-source | openSUSE-Tumbleweed-Source | Nein | ---- | ---- | 99 | NONE | http://download.opensuse.org/source/tumbleweed/repo/oss/ |


    zypper se -si redis

    Code
    S | Name | Typ | Version | Arch | Repository
    ---+----------------+-------+-------------------------+--------+--------------------------------------------------------
    i+ | php7-redis | Paket | 5.2.2-1.2 | x86_64 | (Systempakete)
    i+ | redis | Paket | 6.0.5-172.3 | x86_64 | just some rubyapps and their deps (openSUSE_Tumbleweed)
    i+ | redis-apparmor | Paket | 1.0.0+git95.b4196ec-1.1 | noarch | just some rubyapps and their deps (openSUSE_Tumbleweed)

    Diese Signatur ist derzeit nicht verfügbar.

    Für den Inhalt des Beitrages 282608 haftet ausdrücklich der jeweilige Autor: derwunner