Beiträge von derwunner

    Hallo,


    hast Du php7-mysql installiert?

    Code
    zypper in php7-mysql

    Das hat mit Apache Module aktivieren und deaktivieren nichts zu tun.


    Ein paar Tipps noch am Rande:

    • steige auf PHP 7.4 um, das end of life von 7.2 ist bald erreicht
    • benutze FPM als Dienst dazwischen. PHP direkt als Apache Modul ist unsagbar langsam
    • wenn es um die lokale Entwicklung geht, dann tut man sich vielleicht mit Tools wie ddev (Docker) oder laravel/Homestead (vagrant mit VirtualBox oder VMWare backend) leichter

    MFG


    derwunner

    Lesen:

    Code
    cat /etc/apparmor.d/usr.sbin.redis

    Ja, da steht man solle es vom Template kopieren und dass die Namen übereinstimmen müssen mit der jeweiligen config Datei von redis. Das habe ich gemacht:

    Code
    cp /etc/apparmor.d/redis.d/redis.template /etc/apparmor.d/redis.d/redis.default

    Trotzdem geht es nicht. Ich habe sogar das auskommentierte in der Datei "scharf" gestellt und es ändert nichts daran:

    Was mache ich falsch?

    Da muss ich Dich auch mal berichtigen ;)


    Das Date Kommando wird umgewandelt in einen Datums-String, weil es in doppelten Anführungszeichen steht, das würde mit echo genauso gehen. Ohne Prozent Platzhalter ist printf oder sprintf recht witzlos und wahrscheinlich auch langsamer in der Ausführung. printf bzw. sprintf sind C Funktionen. %s steht für "setze an der Stelle einen String" also der Reihenfolge nach, wie man die Parameter nach den zu ersetzenden String angibt.

    Normalerweise kann man in PHP & Co., also Skript- oder Programmiersprachen, die die C Funktionen schlicht durchreichen auch sowas machen, um die Parameter beliebig oft benutzen zu können, aber das klappte irgendwie in der Bash nicht:

    Code
    printf "Aepfel sind %1$s, Birnen sind auch %1$s. Aber Spinat zaehlt zum %2$s und nicht zum %1$s\n" "Fruechte" "Gemuese"

    Mit z. B. %d kann man Zahlen formatiert ausgeben, also beispielsweise X Nullen voranstellen um alle Zahlen auf die gleiche Länge zu bringen; oder eine Nachkommastellen Präzision einstellen. Dazu am besten mal die man Page konsolidieren, den genauen Syntax muss ich auch jedes mal nachsehen.


    Die Pipe Funktionen (oder wie man das nennen soll) >> und > sind C's STDOUT und haben per se nichts mit Unix zu tun, das geht auch in Windows. Aber ja, C wurde ursprünglich von der NASA für Unix entwickelt.

    Hi,


    ich hatte auch mal kurz drüber geschaut. Sieht für mich nach blutigen Anfänger aus.


    Dein Code ist anfällig für SQL Injections, Formatierung komplett wild, usw. Ich würde wetten, dass Du auch keine CSRF Tokens benutzt.


    Nimm ein Framework, gerade bei großen Sachen ist das empfehlenswert, man muss nicht jedes Mal das Rad neu erfinden. Fange am besten hier an zu lernen: https://symfonycasts.com Es ist wirklich einfaches englisch. Fange am besten damit an, Objektorientierte Programmierung zu lernen. Da gab es auf der Seite auch mal einen freien Kurs.


    Noch was: Nimm foreach Schleifen für Arrays, das ist nach dem Iterator Prinzip. Also er merkt sich die alte Position und biegt den Zeiger von dort aus direkt auf die nächste um. Mit einer while Schleife und einem Index fängt er jedes mal bei 0 an das Zählen. Das merkt man gerade bei großen Datenmengen.


    MFG


    derwunner

    Die Ausgabe von:

    Code
    zypper se -s kernel mesa libgbm libdrm | grep ^[iv]

    siehe Anhang


    Ich dachte ich bekomme es in zwei Beiträgen hin, aber selbst dafür ist es noch zu lang.


    PS: MIttlerweile habe ich das Flimmern auch bei Wayland. Aber vom Nichtstun, also Hochfahren und ca. 10 bis 20 Minuten warten hängt er sich nicht mehr auf.

    Code
    /sbin/lspci -nnk | grep -EiA3 vga
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon 540/540X/550/550X / RX 540X/550/550X] [1002:699f] (rev c7)
           Subsystem: Micro-Star International Co., Ltd. [MSI] Device [1462:8a90]
           Kernel driver in use: amdgpu
           Kernel modules: amdgpu



    Code
    uname -r
    5.8.10-1-default

    Also nach dem Upgrade habe ich jetzt das Problem, das bei X11 einzelne GUI Elemente, wie z. B. Logos von Webseiten manchmal flimmern.


    Und bei Wayland geht das Programm polychromatic und polychromatic-tray nicht mehr. Das ist ein Programm zur Steuerung von Razer Hardware in Form einer GUI. Außerdem hängt manchmal kurz die Maus, geht dann aber wieder weiter. TeamViewer verweigert seit dem Update in Wayland komplett den Dienst. Vorher bekam ich nur einen Warnhinweis, dass keine eingehenden Sitzungen mit Wayland gehen.

    Zwischendurch hatte ich auch der KDE Datei Indexer baloo das journalctl voll gespamt. Nach einem balooctl disable && rm -rf ~/.local/share/baloo && balooctl enable && balooctl check ging es dann besser. Ob es noch auftritt, kann ich erst die nächsten Tagen nach intensiven arbeiten mit TW feststellen.


    Also momentan fühlt es sich an wie die Wahl zwischen Pest und Cholera. Wobei mir Wayland doch ein Stück besser gefällt.


    Kann es sein, dass mir irgendwelche Treiber oder Kernel Einstellungen fehlen? Ich meine eine 4 GB Grafikkarte sollte nicht ruckeln.


    Eine saubere Neuinstallation wäre erst in ca. einen Monat möglich.

    Es muss ja irgendein grundlegender Installationsfehler sein. Ich weiß auch nicht, welche "neuere" Tumbleweed-Version Du nutzt. Tumbleweed hat ja genaugenommen keine Version, sondern wird durch laufende Updates fortgeschrieben.


    Ich meinte damit die Rolling Release Snapshot Nummer. Das ist sogesehen soweit wie ich es verstanden habe schon eine Version. Denn man soll ja keine Updates installieren, sondern immer nur Distributionsupgrades ausführen. Also das nicht: zypper up dafür das: zypper dup

    Du hast eine Radeon-Grafikkarte, aber offensichtlich keinen Radeon-Treiber? Da sollte man den passenden Treiber vielleicht hier herunterladen:

    Braucht es nicht, AMD bietet freie Treiber an, deshalb sind die im Kernel integriert. Natürlich sofern das nicht openSUSE per Paket-Konvention oder dergleichen in ein extra Kernel Paket ausgelagert hat.


    Mittlerweile bin ich auf einer neueren Tumbleweed Version. Es stellte sich heraus, dass man gelegentlich zwischen X11 und Wayland durchwechseln muss bei der Benutzer-Anmeldung. In manchen TW Versionen geht X11 besser und in manchen Wayland.


    Es wäre noch interessant zu wissen in welcher ~/.config Datei man "Plasma (Wayland)" hinterlegen muss fürs automatische Anmelden mit "Plasma (Wayland)", denn manchmal speichert er es nach dem Abmelden und erneuten Anmelden und manchmal nicht.

    Mittlerweile bleibt bei OpenGL 3 und weich zeichnen (oder so ähnlich) manchmal kurz die Maus stehen, geht dann aber wieder. Es machte zwischen openGL 3 weich und genau keinen Unterschied - bei beiden bleibt gelegentlich die Maus kurz stehen.

    Hallo,


    seit ein paar openSUSE Tumbleweed Versionen, ich meine das war seit ca. Juni 2020 so, also es war nicht von Anfang an mit Tumbleweed so, friert der Desktop komplett ein.

    In letzter Zeit trat es regelmäßig im laufenden Betrieb auf, zu unterschiedlichen Zeiten. Es war also vorerst für mich kein Zusammenhang erkennbar.

    Wenn es auftritt, dann tauchen immer solche Meldungen im journalctl auf:

    Code
    Sep 16 21:08:26 localhost.localdomain kwin_x11[2561]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 43352, resource id: 16777223, major code: 18 (ChangeProperty), minor code: 0

    selbst mit Standard Fensterdekorator von KDE Plasma / openSUSE. Bei dem Fensterdekorator "K01" ist es noch etwas schlimmer:

    Wenn er einfriert, dann hilft bloß noch die Reset-Taste, es geht kein Affenklammergriff (STRG + ALT + ENTF) mehr und kein STRG + ALT + F2


    Nachdem der Renderer für KDE auf XRender umgestellt ist, gibt es keine Probleme mehr. openGL 2.0 und 3.1 machen keinen Unterschied, beide hängen sich auf. Auf die Idee mit der Umstellung bin ich nach etwas Recherche gestoßen: https://forum.kde.org/viewtopic.php?t=128788 und: https://forums.opensuse.org/sh…hics-Card-Still-Supported


    Hardware:

    Mainboard: ASRock 970 Extreme3 Revision 1

    CPU: AMD FX-4100

    Festplatten: Eine HDD für /boot, eine HDD für Daten und eine M.2 Disc für das System via PCIe 2.0 4x Adapter. Ein Boot von der M.2 Disc und dem Adapter mit Secure Boot wäre theoretisch möglich, aber das gibt das UEFI BIOS in der neuesten Version nicht her, weil hierfür die Treiber fehlen im UEFI selbst um den Adapter richtig anzusteuere für das Booten davon.

    Grafikkarte: 4GB MSI Radeon RX 550 4GT LP OC Aktiv PCIe 3.0 x16 (x8) 1xDVI / 1xHDMI 2.0 (Retail)

    Soundkarte: Creative X-Fi Fatal1ty Professional Series (sehr alt, läuft aber noch top) auf PCIe 2.0 1x


    Die Mountpoints (der Standard Installationsvorschlag wurde mit meinen Ergänzungen übernommen):


    glxinfo in Verbindung mit openGL:

    Tumbleweed Release (/etc/os-release):


    Das Perfide ist, dass ich bisher keine Probleme mit XRender feststellen konnte, selbst openGL Anwendungen laufen innerhalb fehlerfrei (z. B. getestet anhand von WebGL Spielen, Schriftarten Anti Analyzing, uws.).


    Für Ratschläge hierzu woran es liegen könnte, wäre ich dankbar. Denn ich kann mir schon vorstellen, dass openGL der bessere Renderer für KDE ist :)


    MFG derwunner