Tumbleweed: man wird nicht mehr gefunden

Hinweis: In dem Thema Tumbleweed: man wird nicht mehr gefunden gibt es 12 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Hallo,


    seit neuestem wird auf meinem Tumbleweed-System das "man"-Kommando nicht mehr gefunden.


    Code
    ~ # man man
    If 'man' is not a typo you can use command-not-found to lookup the package that contains it, like this:
    cnf man

    man ist natürlich instaliiert, wurde aber gestern aktualisiert:

    /usr/bin/man ist vorhanden und ist ein Link:

    lrwxrwxrwx 1 root root 21 Aug 27 14:48 /usr/bin/man -> /etc/alternatives/man


    /etc/alternatives/man ist vorhanden und ebenfalls ein Link:

    lrwxrwxrwx 1 root root 23 Jul 25 09:34 /etc/alternatives/man -> /usr/lib/man-db/wrapper


    Dieser ist aber falsch! wrapper ist seit gestern nicht mehr in /usr/lib/man-db/, sondern in /usr/libexec/man-db/


    Ist das eine fehlerhafte Installation, muss ich den Link in /etc/alternatives manuell ändern oder geht das irgendwie über das Kommando alternatives?

    Für den Inhalt des Beitrages 283030 haftet ausdrücklich der jeweilige Autor: Oceanwaves

  • Das neueste Update habe ich noch nicht gemacht. Bei der 20200824 funktioniert noch alles. Wenn es nach dem Update bei mir auch so ist, liegt es daran, das ein Programmierer was verändert hat.


    Edit: Es liegt am Update. Sieht bei mir auch so aus ...


  • Die aktuellen snapshots der vergangenen Woche sind sehr ... naja...


    Hab hier einen Rechner, der komplett kein DNS mehr kann.

    PRAISE THE OMNISSIAH

    Für den Inhalt des Beitrages 283035 haftet ausdrücklich der jeweilige Autor: Scytale

  • Sieht so aus als wenn cron auch betroffen ist. Ich habe 2 Skripte in /etc/cron.daily, die wurden zuletzt am 29.08. (vor dem Update) ausgeführt:

    Code
    ~ # ll /var/spool/cron/lastrun
    total 0
    -rw-r--r-- 1 root root 0 Aug 29 03:15 cron.daily

    Das Skript run-crons ist mit dem Update ebenfalls von /usr/lib/cron nach /usr/libexec/cron umgezogen.


    Bugreport dazu gibt es bereits: https://bugzilla.opensuse.org/show_bug.cgi?id=1175934

    Für den Inhalt des Beitrages 283051 haftet ausdrücklich der jeweilige Autor: Oceanwaves

  • Ja, das letzte Update war eine Katastrophe. Es wurde wieder aller möglicher Kram installiert, den ich deinstalliert hatte, Sprachen verschwanden und allerlei anderes Ungemach. Wir warten mal das nächste Update ab.

  • Die Neuinstallation von man zu erzwingen soll wohl Abhilfe schaffen.


    Seit dem 10.08 sind die TW Snapshots eine Katastrophe, nichts hat mehr das 80er Stabilitätsranking übertroffen. Der aktuelle Snapshot hängt bei unter 40. u.a. mit kaputter crontab.


    Als Enduser sollte man echt nur bei Ratings über 90 updaten...

    PRAISE THE OMNISSIAH

    Für den Inhalt des Beitrages 283060 haftet ausdrücklich der jeweilige Autor: Scytale

  • Die Neuinstallation von man zu erzwingen soll wohl Abhilfe schaffen.


    Seit dem 10.08 sind die TW Snapshots eine Katastrophe, nichts hat mehr das 80er Stabilitätsranking übertroffen. Der aktuelle Snapshot hängt bei unter 40. u.a. mit kaputter crontab.


    Als Enduser sollte man echt nur bei Ratings über 90 updaten...

    Ich benutze jetzt Leap 15.2, das hat ein Rating von 100..........

    Einmal editiert, zuletzt von Sauerland ()

    Für den Inhalt des Beitrages 283063 haftet ausdrücklich der jeweilige Autor: Sauerland