[Gelöst] Virtualbox startet nicht

Hinweis: In dem Thema [Gelöst] Virtualbox startet nicht gibt es 27 Antworten auf 3 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • weiss nicht ob es hier den Gepflogenheiten entspricht - aber es ist mein erstes Posting in diesem Forum, und dehalb bitte ich um Nachsicht :)


    Nachdem ich ziemlich exakt dieselbe Problematik bei mir hatte wie in #1 beschrieben, war ich eigentlich schon recht optimistisch die VirtualBox mit Windows XP zum Laufen zu bringen - nach Befolgung aller Schritte wie sie zuvor von Sauerland beschrieben worden sind...


    Leider leider will sie aber immer noch nicht (die Box), wenngleich jetzt andere Gründe vorzuliegen scheinen:



    >RTR3InitEx failed with rc=-1912 (rc=-1912)
    The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing


    '/etc/init.d/vboxdrv setup'


    may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.<


    Wie gesagt, habe ich zuvor das gesamte Procedere befolgt - und die ursprünglichen Schwierigkeiten schienen damit auch behoben zu sein:


    >linux-o963:/home/willibald # /etc/init.d/vboxdrv setup
    Stopping VirtualBox kernel modules done
    Uninstalling old VirtualBox DKMS kernel modules done
    Trying to register the VirtualBox kernel modules using DKMS done
    Starting VirtualBox kernel modules done<



    Nur, ganz so einfach scheint's doch nicht zu sein :D



    >Für die virtuelle Maschine Windows XP konnte keine neue Sitzung eröffnet werden.
    The virtual machine 'Windows XP' has terminated unexpectedly during startup with exit code 1.<


    Achja - habe mein Zeug von virtualbox.org - nicht als Paket aus der Distribution, wenngleich dieses zuvor auch versucht worden ist (aber dann via Yast deinstalliert).


    Ich hoffe sehr auf Sauerland ^^

    2 Mal editiert, zuletzt von willibald ()

    Für den Inhalt des Beitrages 54095 haftet ausdrücklich der jeweilige Autor: willibald

  • Achja - habe mein Zeug von virtualbox.org - nicht als Paket aus der Distribution, wenngleich dieses zuvor auch versucht worden ist


    Warum hast Du nicht Virtualbox aus dem Repo installiert.
    Dieses Modulmisere wirst Du dann bei jeder kleinen Änderung im Kernel haben, weil nämlich dann die Virtualbox Module nie automatisch neu eingebunden werden.
    Um VBox aus einer anderen Quelle lauffähig zu bekommen müssen die Kernelsourcen und alle Programmteile (make, gcc usw...) installiert sein, die man zum Compile eines Kernels und seiner Module benötig! Ist das geschehen?

    Für den Inhalt des Beitrages 54112 haftet ausdrücklich der jeweilige Autor: repi

  • Was bezwecken diese Befehle - wie ist die Methode? Ich würde gerne die Herangehensweise verstehen...







    Code
    linux-o963:/home/willibald # uname -a
    Linux linux-o963 3.4.33-2.24-desktop #1 SMP PREEMPT Tue Feb 26 03:34:33 UTC 2013 (5f00a32) x86_64 x86_64 x86_64 GNU/Linux


    Ausgabe bitte in Code-Tags, siehe meine Signatur

    2 Mal editiert, zuletzt von Sauerland ()

    Für den Inhalt des Beitrages 54128 haftet ausdrücklich der jeweilige Autor: willibald

  • Ich dachte, diese Schwierigkeiten würden mit der Installation von DKMS gelöst sein...?
    Mein Versuch VirtualBox aus dem Repo zu installieren verlief leider nicht erfolgreich: ich konnte mich zwar der vboxusers group zuordnen - bekam beim Versuch VirtualBox zu starten, aber jedesmal eine Fehlermeldung, ich sei kein Mitglied dieser Gruppe...
    make zumindest sollte installiert sein.

    Für den Inhalt des Beitrages 54130 haftet ausdrücklich der jeweilige Autor: willibald

  • Zitat

    Was bezwecken diese Befehle - wie ist die Methode? Ich würde gerne die Herangehensweise verstehen...


    Mit zypper werden die Repos verwaltet, Programme installiert usw.
    Ist wie Yast------Software installiere, nur halt nicht grafisch.


    Siehe:

    Code
    zypper help


    Code
    zypper [Befehl] --help


    Code
    man zypper

    q bricht "man zypper" ab.


    Code
    uname -a


    zeigt den gerade laufenden kernel an.



    Die Ausgaben sehen eigentlich gut aus, an den Prioritäten könnte man noch feilen.
    Hast Du die Winxp-Version neu installiert?
    Falls es eine alte Installation ist, irgendwas an den Einstellungen verändert?


    vbox-extensions sind installiert?
    http://download.virtualbox.org…4.2.10-84104.vbox-extpack

  • Ich dachte, diese Schwierigkeiten würden mit der Installation von DKMS gelöst sein...?
    Mein Versuch VirtualBox aus dem Repo zu installieren verlief leider nicht erfolgreich: ich konnte mich zwar der vboxusers group zuordnen - bekam beim Versuch VirtualBox zu starten, aber jedesmal eine Fehlermeldung, ich sei kein Mitglied dieser Gruppe...
    make zumindest sollte installiert sein.


    Soll das heißen, Du hast dieses versucht, was repi geschrieben hat?
    Stimmt die Ausgabe aus Post # 5 noch?
    Darauf bezogen sich alle meine Antworten.


    Das ist das Repo für VirtualBox von Oracle:
    http://download.virtualbox.org/virtualbox/rpm/opensuse/11.4/
    Die URL passt für openSUSE 11.4 bis 12.3

  • Danke für die Erläuterungen bezüglich zypper- werde mir das später in Ruhe mal ansehen...


    Nach meinem Verständnis habe ich Windows XP noch gar nicht installiert .- VirtualBox habe ich zuvor noch nie auf dem Rechner gehabt. Speicher und virtuelle Festplattengröße wurden konfiguriert - im Virtual Box Manager wird oben rechts Windows XP als VM angezeigt - und Doppelklicken auf dieses Symbol, um mit der Windows-Installation zu beginnen, führt zu den eingangs genannten Fehlermeldungen:


    RTR3InitEx failed with rc=-1912 (rc=-1912)


    The VirtualBox kernel modules do not match this version of VirtualBox. The installation of VirtualBox was apparently not successful. Executing


    '/etc/init.d/vboxdrv setup'


    may correct this. Make sure that you do not mix the OSE version and the PUEL version of VirtualBox.



    #9 Soll ich die Ausgaben entsprechend #5 nocheinmal abfragen und hier posten???
    Habe meine Installation von hier:
    http://download.virtualbox.org…04_openSUSE114-1.i586.rpm
    Diese Datei ist im Verzeichnis i586 des von Dir genannten Links nicht enthalten.
    Bin jetzt etwas ratlos, was ist zu tun?

    Für den Inhalt des Beitrages 54136 haftet ausdrücklich der jeweilige Autor: willibald