Update bricht mit Fehler ab, nach Reboot schwarzer Schirm mit Mauszeiger

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Update bricht mit Fehler ab, nach Reboot schwarzer Schirm mit Mauszeiger gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Update bricht mit Fehler ab, nach Reboot schwarzer Schirm mit Mauszeiger

    Hallo,

    erst einmal: Hallo, dies ist mein erster Post in diesem Forum, ich hoffe, ich mache alles richtig...


    >>Zum Problem (und zu dem im angehefteten Postingthread gewünschten Angaben):
    • wird ein PC / Notebook / Netbook verwendet: Thinkpad T540p
    • über die Hardware Geräte wie z.b. Netzwerkkarte, Grafikkarte, Soundkarte usw., eben jene Geräte die die vermeintlichen Probleme verursachen: Dürfte keine Rolle spielen
    • welche SuSE Distribution ist in Betrieb (z.b. SuSE 13.0 SuSE 13.1 in 32 / 64 Bit Version): 64 Bit, OpenSuse Leap 42.3, Kernel 4.4.143-65 default
    • welcher Desktop / Arbeitsumgebung Bspw. → KDE 3 / KDE 4.1 / KDE 4.2 / Gnome oder Xfce etc.: KDE (keine Ahnung, welche Version...)
    • ist dies eine Erst - Installation mit oder ohne schon durchgeführte Update' s: Installation läuft seit einem Jahr und wurde div. Male upgedatet
    Zu mir: Ich bin ein einfacher User, kein Admin. Es bestehen bei Linux nur sehr rudimentäre Kenntnisse, meine letzte richtige Benutzung einer Konsole war unter DOS 6.22... - daher: Wenn es geht, bitte eine direkte Step-by-Step-Anleitung für Dummys... - lieben Dank :)

    Problemlage:

    1. Das letzte Update lief nicht sauber durch, ich habe auch nicht geprüft, weshalb der Abbruch kam, sondern nur runtergefahren. Nach dem Hochfahren und dem Startscreen (grüne Punkte) erscheint statt des grafischen Log-Ins nur ein Mauszeiger vor schwarzem Hintergrund
    2. Starten über abgesicherte Modi bringt dieselben Ergebnisse
    3. Der Wechsel auf die Konsole mit Ctrl-Alt-F1 fördert nach Login die Meldung "login: write lastlog failed: No space left on device" zutage
    4. Meine Hypothese dazu: Über die Systemsicherung (Zypper?) sind beim Update jedes Mal Systemabbilder gemacht worden, der Plattenplatz ist dabei beim letzten Update ausgereizt worden, weshalb das Update abgebrochen hat. Die grafische Oberfläche kann nicht starten, weil kein Speicherplatz mehr. Nur: Wie lösche ich den Kram auf/über die Konsole, wenn es so ist? Wie genau vorgehen (step-by-step)?
    Vielen Dank schon einmal im Voraus,

    Gruß,
    Flo

    Für den Inhalt des Beitrages 126105 haftet ausdrücklich der jeweilige Autor: Jack GT

  • Du hast das ganz richtig erkannt.
    Die Platte/Partition ist voll, weil du mit (vermutlich) dem Dateisystem btrfs arbeitest.
    Jedes Updaten oder jede Installation von Software erzeugt dabei einen Snapshot, damit du im Falle einer Katastrophe einfach auf den vorherigen Zustand zurückschalten kannst.

    Ich denke, du hast schlicht eine viel zu kleine Rootpartition am Start.
    Damit wirst du nicht glücklich. Ich würde dir raten, da wirklich gehörig mehr Platz zu nehmen.
    (viel mehr lässt sich mit deinen knappen Angaben nicht vernünftig sagen).

    Du hast aber noch ein paar andere Optionen:
    Platz schaffen entweder durch Lösche alter Snapshots, oder durch Rücksetzen auf einen Snapshot, bei dem es noch ging.

    Es gibt hier im Forum viele Anleitungen dazu. Suche einfach mal nach "Btrfs Shapshots löschen".
    Ich selbst verwende das nicht, will dazu also weiter nichts sagen.
    Das machen heute, wenn die endlich doch mal wieder aufstehen, aber sicher einige andere...
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 126106 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Anmelden als User:root
    Passwort des Users root eingeben
    snapper list zeigt alle Schnappschüsse an
    snapper delete vonNR-bisNR löscht Schnappschuss vonNR bis zu Schnappschus bisNR.
    beides natürlich mit den Nummern aus snapper list ersetzen.
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 126107 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Man muss erstmal dahin kommen, das einzugeben. Wenn das System voll ist, kann man ewig warten, bis eine grafische Anmeldung glückt.
    - Ich starte den Rechner, wähle gleich beim Bootmanager eine vorangegangene Konfig. (wg. Abbruch des Updates)
    - Wenn die Anmeldemaske kommt, mit Strg-ALT-F1 oder eine andere Zahl auf eine andere Konsole wechseln (Standard ist bei mir die Strg-Alt-F3)
    - Keine grafische Anmeldung machen, sondern nur Login mit root oder normalem Nutzer
    - und dann die von Sauerland eingegebenen Befehle eingeben, wenn Sie den normalen Nutzer (nicht root) gewählt haben, dann den Befehlen ein sudo für die Adminrechte voranstellen
    Ich lasse beim Snaplöschen zumeist den oder die letzten 2 Schnäpse stehen.

    Für den Inhalt des Beitrages 126131 haftet ausdrücklich der jeweilige Autor: ansegisel

  • ansegisel schrieb:

    Man muss erstmal dahin kommen, das einzugeben. Wenn das System voll ist, kann man ewig warten, bis eine grafische Anmeldung glückt.
    Im grub Taste e drücken, dann statt nomodeset einfach eine 3:
    Grub2 zusätzliche Bootparameter einfügen

    Aber immer mit einem Leerzeichen zum letzten Befehl......
    Links in dieser Signatur bitte zum Lesen anklicken!

    Code-Tags <<<Klick mich
    zypper <<<Klick mich
    Netzwerkprobleme <<<Klick mich

    Für den Inhalt des Beitrages 126133 haftet ausdrücklich der jeweilige Autor: Sauerland

  • Neu

    Sauerland schrieb:

    Im grub Taste e drücken, dann statt nomodeset einfach eine 3:
    Dann läuft Dein Linux ohne GUI und Du kannst als root die Befehle eingeben.

    (login root > Bei der Eingabe des Passwortes wird nichts angezeigt.)

    Für den Inhalt des Beitrages 126151 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Neu

    Na, aber wenn die / Partition voll ist, bis aus letzte Byte, hast du als user root auch nicht mehr viele Möglichkeiten.
    So was hatte ich auch vor nicht all zu langer Zeit. Hatte nichts mit Btrfs und Snapper zu tun. Mein Backupmedium war nicht gemountet und es wurde alles munter auf /media/backup (also auf der Rootpartition) gesichert.
    Einfach eine Live-CD/DVD gebootet und alles unter /media/backup gelöscht! (Das Backupmedium war dazu natürlich NICHT gemountet.)

    Das was zuvor beschrieben wurde konnte ich nicht anwenden.......

    Für den Inhalt des Beitrages 126153 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Neu

    Vielen Dank für Eure Hinweise, habe ich befolgt und die Kiste läuft wieder! Ich bin auch ganz beeindruckt über die schnellen und präzisen Antworten :thumbsup: .

    Schönes WE!

    Für den Inhalt des Beitrages 126155 haftet ausdrücklich der jeweilige Autor: Jack GT

  • Neu

    Was war es denn, was hat dir geholfen?
    Es ist nicht nur schön für die Helfenden, auch für die, die nur mitlesen.
    Wie genau konntest du das Problem denn lösen?

    Für den Inhalt des Beitrages 126156 haftet ausdrücklich der jeweilige Autor: ThomasS

  • Neu

    ThomasS schrieb:

    Was war es denn, was hat dir geholfen?
    Es ist nicht nur schön für die Helfenden, auch für die, die nur mitlesen.
    Wie genau konntest du das Problem denn lösen?
    Jetzt wollen wir wissen, warum!!!

    Jack GT schrieb:

    Vielen Dank für Eure Hinweise, habe ich befolgt und die Kiste läuft wieder! Ich bin auch ganz beeindruckt über die schnellen und präzisen Antworten
    Der Dank ist angekommen.
    Die Lösung könnte oder kann anderen Usern (Nutzern) helfen.
    Wenn sie wissen, daß es wieder geht, aber nicht warum.....
    müssen sie wieder nachfragen.

    Für den Inhalt des Beitrages 126157 haftet ausdrücklich der jeweilige Autor: Kanonentux