Dualboot Leap 15.0 und Win 10 Grub2 prompt

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Dualboot Leap 15.0 und Win 10 Grub2 prompt gibt es 11 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Dualboot Leap 15.0 und Win 10 Grub2 prompt

    Hallo Linux-Community

    Ich habe das Problem, dass beim booten nicht die Auswahl erscheint, wo man das System auswählen kann. Es erscheint nur die Grub2 Eingabeaufforderung. Wenn ich während dem booten mit "ESC" in den Bios Bootmanger starte und dort "Continue" wähle startet er so wie es sollte. Die Systemauswahl des Grub erscheint und ich kann den Rechner mit openSuse oder Win 10 starten.

    PC: HP Pavilion, Intel i5-8th Gen, 8GB RAM
    1xSSD 258GB
    1xHDD 1TB
    Grafik: Nvidia GTX 1050 Ti
    Windows 10 clean Installation auf SSD
    openSuse Leap 15 auf SSD

    Win 10 wurde zuerst installiert und danach openSuse.

    Hier die Ausgabe von fdisk -l:

    Quellcode

    1. palmi@linux-4al2:~> sudo /usr/sbin/fdisk -l
    2. [sudo] Passwort für root:
    3. Festplatte /dev/nvme0n1: 238,5 GiB, 256060514304 Bytes, 500118192 Sektoren
    4. Einheiten: Sektoren von 1 * 512 = 512 Bytes
    5. Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
    6. E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
    7. Festplattenbezeichnungstyp: gpt
    8. Festplattenbezeichner: 5C952F84-0ED6-4936-B087-1A0F7B1E0098
    9. Gerät Anfang Ende Sektoren Größe Typ
    10. /dev/nvme0n1p1 2048 534527 532480 260M EFI-System
    11. /dev/nvme0n1p2 534528 567295 32768 16M Microsoft reserviert
    12. /dev/nvme0n1p3 567296 252338175 251770880 120,1G Microsoft Basisdaten
    13. /dev/nvme0n1p4 498098176 500105215 2007040 980M Windows-Wiederherstellungsumgebung
    14. /dev/nvme0n1p5 252338176 481980415 229642240 109,5G Linux-Dateisystem
    15. /dev/nvme0n1p6 481980416 498098175 16117760 7,7G Linux Swap
    16. Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.
    17. Festplatte /dev/sda: 931,5 GiB, 1000204886016 Bytes, 1953525168 Sektoren
    18. Einheiten: Sektoren von 1 * 512 = 512 Bytes
    19. Sektorgröße (logisch/physikalisch): 512 Bytes / 4096 Bytes
    20. E/A-Größe (minimal/optimal): 4096 Bytes / 4096 Bytes
    21. Festplattenbezeichnungstyp: gpt
    22. Festplattenbezeichner: 806029B3-4BA3-4652-8201-1A92886A2C8F
    23. Gerät Anfang Ende Sektoren Größe Typ
    24. /dev/sda1 2048 1877764095 1877762048 895,4G Microsoft Basisdaten
    25. /dev/sda2 1919707136 1953523711 33816576 16,1G Microsoft Basisdaten
    26. /dev/sda3 1877764096 1919707135 41943040 20G Linux-Dateisystem
    27. Partitionstabelleneinträge sind nicht in Festplatten-Reihenfolge.
    Alles anzeigen

    In der Bootreihenfolge im Bios steht openSuse Secure-Boot an oberster Stelle.

    Ist die Einstellung im Bootloader falsch? Muss ich im Bios Secure-Boot deaktivieren?

    Als Anhang noch die Einstellung des Bootloaders:


    Vielen Dank im Voraus für Eure Bemühungen.
    :smilie_pc_011:

    Für den Inhalt des Beitrages 126934 haftet ausdrücklich der jeweilige Autor: tinker68

  • Ganz wichtig:
    Hast du unter Windows 10 die "Schnellstart Option" deaktiviert?
    Ist zu finden in den erweiterten Energieoptionen bei "Schließen des Laptops" oder so ähnlich bzw. bei "Drücken des Netzschalters".

    Und im BIOS / UEFI direkt die Bootreihenfolge kontrollieren.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 126936 haftet ausdrücklich der jeweilige Autor: sterun

  • Danke für die schnelle Antwort, werde ich gleich probieren.

    In der Bootreihenfolge im Bios ist "openSuse Secure Boot" ganz oben. Oder ist das falsch? Habe dort auch schon die Reihenfolge geändert, jedoch ohne Erfolg.

    Bin dann mal kurz im Windows.
    :smilie_pc_011:

    Für den Inhalt des Beitrages 126939 haftet ausdrücklich der jeweilige Autor: tinker68

  • tinker68 schrieb:

    In der Bootreihenfolge im Bios ist "openSuse Secure Boot" ganz oben. Oder ist das falsch?
    Das sollte ok sein (-:
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 126941 haftet ausdrücklich der jeweilige Autor: sterun

  • tinker68 schrieb:

    Muss ich im Bios Secure-Boot deaktivieren?
    NEIN, wenn du Windows 10 und openSUSE Leap im SecureBoot Modus installiert hast, sollte man es so belassen.
    Obwohl ich persönlich immer versuche, dieses zu meiden.

    Melde mich gleich noch mal.
    Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 126944 haftet ausdrücklich der jeweilige Autor: sterun

  • Siehe einmal ob in yast - Bootloader - Bootloader-Optionen "Fremdes OS testen" aktiv ist.

    Für den Inhalt des Beitrages 126950 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Dann würde ich es deaktivieren, den Bootloader speichern und dann aktivieren und den Bootloader wieder speichern.

    Wenn ich aber in meinem Hirnkasten nachfrage, war das, denke ich, nach dem Einspielen aller Updates auch erledigt.

    Für den Inhalt des Beitrages 126953 haftet ausdrücklich der jeweilige Autor: Kanonentux

  • Hab ich gemacht. Geht auch nicht.

    Bei der Gelegenheit bin ich beim booten noch mal ins Bios, um die Bootreihenfolge nochmal zu überprüfen. Hier ein screenshot:


    Dabei ist mir aufgefallen, wenn ich das bios verlasse bootet der Rechner in den Grub und ich kann mein System auswählen. Wenn ich boote ohne eine Aktion (bios startmanager, bios), so wie man gewöhnlich einen Rechner eben startet, geht es nicht.
    :smilie_pc_011:

    Für den Inhalt des Beitrages 126956 haftet ausdrücklich der jeweilige Autor: tinker68