Opensuse 15.0 Installation bei vorhandenen Partitionen

Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

Hinweis: In dem Thema Opensuse 15.0 Installation bei vorhandenen Partitionen gibt es 15 Antworten auf 2 Seiten. Der letzte Beitrag () befindet sich auf der letzten Seite.
  • Opensuse 15.0 Installation bei vorhandenen Partitionen

    Hallo zusammen,

    Bevor ich etwas falsch mache wollte ich mich nochmal kurz informieren.

    Ich besitze einen Laptop mit Win10 und opensuse 42.2 Dual Boot (Uefi und Secure Boot aktiv).

    Nachdem ich seit letzter Woche aus Grub nicht mehr in opensuse booten kann (cannot find inode + kernel panic), habe ich mein Home gesichert und möchte mit einem Update auf opensuse 15.0 gleich zwei Fliegen mit einer Klappe schlagen.

    Das Windows 10 kann ich inzwischen wieder booten und das möchte ich wenn möglich auch so beibehalten.

    Für die Installation habe ich secure boot ausgeschaltet. Beim Anlegen der Partition habe ich die mount points wie abgebildet wieder gesetzt. Ich kann jedoch nicht weiter machen, da die vorhandene Efi Partition aktuell zu klein sei.

    Was schlagt ihr zur Lösung vor? Sollte ich die bestehende Efi Partition löschen und an anderer Stelle anlegen?

    Vielen Dank schon im Voraus.
    [Blockierte Grafik: https://uploads.tapatalk-cdn.com/20190201/d21aae4349a01ed44b4f4023a91bc95a.jpg]

    Gesendet von meinem EML-L29 mit Tapatalk

    Für den Inhalt des Beitrages 128889 haftet ausdrücklich der jeweilige Autor: tom739

  • Ich würde vor alle Secureboot mit UEFI nicht ausschalten.
    openSUSE kann damit schon seit längerem recht gut.

    Ich klicke keine Tapatalk Links.
    Aber ich würde halt dann die EFI Partition etwas vergrößern.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 128894 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Zitat Albert Einstein:
    "Zwei Dinge sind unendlich, das Universum und die menschliche Dummheit,
    aber bei dem Universum bin ich mir noch nicht ganz sicher."

    Für den Inhalt des Beitrages 128897 haftet ausdrücklich der jeweilige Autor: sterun

  • So, jetzt mit Bild. Bisher hatte Secure Boot auch bei mir funktioniert.
    Ich dachte nur, dass ich es während der Neu-Installation besser ausschalte?!

    Wie vorgeschlagen, die Partition einfach zu vergrößern, ist leider nicht so einfach.
    Windows hat da einiges rum-partitioniert, was es etwas kompliziert macht.

    sda1 - 450 MB - Diagnose Partition (NTFS)
    sda2 - 100MB - EFI
    sda3 - 16 MB - Microsoft Reservierte Partition
    sda4 - 233 GB - Windows Daten Partition (C:\ NTFS)
    sda5 - 0,76GB - Diagnose Partition (NTFS)
    sda6 - 2GB - SWAP
    sda7 - 40GB - ROOT (Btrfs)
    sda8 - 189 - XFS (Home)
    Bilder
    • partitionen.jpg

      48,77 kB, 992×496, 8 mal angesehen

    Für den Inhalt des Beitrages 128901 haftet ausdrücklich der jeweilige Autor: tom739

  • @tom739 das sieht mir so aus, als wenn das ein gekaufter Rechner mit fertiger Windowsinstallation war! Wahrscheinlich sogar eine "Home Version" davon! Windows 10 Enterprise in der Version 1809 fertigt bei der Installation eine 500 MB EFI Partion an! Diese wäre auch für OpenSuse Leap 15.0 groß genug!
    sda1 Diagnose Partion braucht Windows eigentlich nicht!
    sda3 und sda5 braucht Windows eigentlich auch nicht!

    Mein Rat, alle Partionen löschen, ein vernünftiges Windows darauf installieren (keine Home Edition, am besten eine Enterprise Version 1809), darauf achten, das genügend Platz für Opensuse bleibt und danach Opensuse installieren!

    Für den Inhalt des Beitrages 128904 haftet ausdrücklich der jeweilige Autor: Z_O_O_M

  • Da wäre ich vorsichtiger.

    Viele Hersteller legen komprimierte Abbilder der Installation in solche "Rescue"- Partitionen.
    Wenn man sein Windows wirklich nicht mehr verwenden will, mag man das schon alles löschen.

    Und manche Hersteller halten in solchen Partitionen auch proprietäre Testprogramme, die ihrem Support und der Fehleranalyse dienen.
    Auch die will man wahrscheinlich nicht einfach löschen.

    Es sei denn, man weiß wirklich, was man tut.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 128909 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Hi Z_O_O_M, Hi Berichtigung,

    vielen Dank schon mal für die Tipps. Ich mir nicht sicher wofür diese Windows Partitionen im Einzelnen genau sind.
    Da sie nicht sonderlich groß sind, würde ich sie erst mal beibehalten.
    Falls ich den Laptop nochmal komplett neu aufsetze, kann ich gerne Win10 Enterprise in Betracht ziehen.

    Frage:
    Wurde die sda2 (EFI) Partition von opensuse erstellt und exklusiv von opensuse genutzt?
    Kann ich nicht sda6 (swap), sda7 (root) und sda8 (home) löschen und die Installation von opensuse neu vornehmen lassen?
    Würde opensuse dann eine neue EFI PArtition anlegen?

    Grüße
    Tom

    Für den Inhalt des Beitrages 128956 haftet ausdrücklich der jeweilige Autor: tom739

  • Es sollte genau eine EFI- Partition geben, auch wenn man problemlos mehrere haben könnte.
    Das macht die Sache aber nur schwieriger in der Verwaltung.

    Es ist per definitionem die Aufgabe EINER EFI-Partition, dass von dort ALLE Betriebssysteme gestartet werden, die auf dieser Kiste installiert sind.

    Normalerweise würde openSUSE schon eine EFI-Partition anlegen. Aber das hängt sehr stark von der tatsächlichen Hardware ab.
    Da ist dein erster Ansprechpartner das BIOS deines Rechners.
    Nur was das zulässt, ist möglich.
    Und das hängt u.a. davon ab, ob ein TP (TrustedPlatform) Modul verbaut ist, und was dir der Boardhersteller via BIOS alles erlaubt.
    Sokrates sagte, dass er nichts wisse.
    Ich bin viel, viel klüger als Sokrates.
    Ich weiß ganz genau, dass ich gar nichts weiß.

    Für den Inhalt des Beitrages 128959 haftet ausdrücklich der jeweilige Autor: Berichtigung

  • Ok, hier ein kurzes Update:

    • Ich habe einen alten kernel booten können und ein snapper rollback gemacht
    • Danach habe ich per USB Installationsstick ein "Update" auf opensuse 15.0 durchgeführt
    • Im Moment sieht wieder alles soweit gut aus, auch wenn es keine cleane Neuinstallation war
    Danke für die Hilfe.

    Für den Inhalt des Beitrages 129015 haftet ausdrücklich der jeweilige Autor: tom739